Reply to topic

Unable to open Yakuake on external display

MariusElvenwood
Registered Member
Posts
2
Karma
0
I'm currently using a laptop with an external display through HDMI, the external display is my primary.
I use Yakuake as my quick access to my terminal with the F12 shortcut. 2 days ago I had no issues with Yakuake but suddenly (possibly following an update) I'm unable to use the shortcut to open Yakuake when my mouse is in the external display, only on the laptop screen. If Yakuake is open in the laptop screen and the mouse is on the external display the shortcut will collapse Yakuake, but I can't open it again.
The shortcut works when the displays are unified, but I would prefer to extend the displays. How can I configure Yakuake so it will open in whichever monitor the mouse is currently in?

Kernel release: 4.19.10-arch1-1-ARCH
Display server: xorg 1.20.3-1
Display manager: SDDM
Desktop environment: Plasma 5.14.4-1

Workspace -> Window Management -> Window Behaviour -> Active screen follows mouse is active
Configure - Yakuake -> Window -> Open on screen: At mouse location.

edit: updated xorg version
serhiivaskiv
Registered Member
Posts
1
Karma
0
Confirming that. Same settings.
Code: Select all

KDE Plasma version: 5.12.7
KDE Frameworks version: 5.47.0
Qt version:  5.9.5

Kernel version: 4.15.0-45-generic
X.Org version: 1.19.6
Display manager: SDDM

Mesa DRI Intel(R) HD Graphics 520 (Skylake GT2)  (0x1916)
    Version: 18.2.2
    Accelerated: yes


Not sure if that's related, but not long before bug started to occur I've added command
Code: Select all
xset -dpms
to autostart (KDE System Settings -> Startup and Shutdown) to fix issue with external monitor.
MariusElvenwood
Registered Member
Posts
2
Karma
0
serhiivaskiv wrote:Not sure if that's related, but not long before bug started to occur I've added command
Code: Select all
xset -dpms
to autostart (KDE System Settings -> Startup and Shutdown) to fix issue with external monitor.

Thanks for the recommendation. I tried it out but it didn't work, Yakuake and other Guake-like terminals just wouldn't drop down on the external monitor.
I also noticed before I tried your recommendation is that Yakuake would drop down on the laptop monitor, but if at any point I tried opening Yakuake on the external monitor it wouldn't respond, even if I tried opening it on the laptop monitor.
The fix for me was to reset my plasma configuration by removing ~/.config/plasma-org.kde.plasma.desktop-appletsrc, loggin out and the logging in again.
There must have been a configuration in there that was preventing me from opening Yakuake on the external monitor, regardless of how I tried to change the settings.
thio
Registered Member
Posts
1
Karma
0
MariusElvenwood wrote:
serhiivaskiv wrote:Not sure if that's related, but not long before bug started to occur I've added command
Code: Select all
xset -dpms
to autostart (KDE System Settings -> Startup and Shutdown) to fix issue with external monitor.

Thanks for the recommendation. I tried it out but it didn't work, Yakuake and other Guake-like terminals just wouldn't drop down on the external monitor.
I also noticed before I tried your recommendation is that Yakuake would drop down on the laptop monitor, but if at any point I tried opening Yakuake on the external monitor it wouldn't respond, even if I tried opening it on the laptop monitor.
The fix for me was to reset my plasma configuration by removing ~/.config/plasma-org.kde.plasma.desktop-appletsrc, loggin out and the logging in again.
There must have been a configuration in there that was preventing me from opening Yakuake on the external monitor, regardless of how I tried to change the settings.


I had the same problem and creating new ~/.config/plasma-org.kde.plasma.desktop-appletsrc solved it for me.

However I have the following setup:
    Secondary monitor is above the primary monitor
    The panel on primary monitor positioned at the top of the screen (below secondary monitor)
    No panel on secondary monitor
When I resetted the plasma-org.kde.plasma.desktop-appletsrc, yakuake was working fine but my panel was on the bottom, so I moved it back to top of primary screen.
Yakuake stopped working on secondary as soon as I did that. I moved the panel back to bottom or top of secondary screen, yakuake working again.

After this I loaded back the original plasma-org.kde.plasma.desktop-appletsrc and moved the panel to top of secondary screen and yakuake is showing up on both screens.

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], Google [Bot], Invictus, Majestic-12 [Bot]