Reply to topic

Kate bug at startup

hay207
Registered Member
Posts
3
Karma
0

Kate bug at startup

Fri Oct 04, 2019 8:05 am
Hi all, when i start my computer, kate opens lots of empty documents/windows, which i close manually,
this happens when i have selected globally restore previous session and in kate restore opened documents, Thanks.
airdrik
Registered Member
Posts
1788
Karma
5
OS

Re: Kate bug at startup

Fri Oct 04, 2019 8:15 pm
Sounds almost like working as designed; though perhaps some more details are needed.

Kate provides its own session management to keep track of what things were opened when a session is closed so it can resume your session right back where you left off. The behavior can be configured via Settings -> Configure Kate -> Sessions. You can also configure the sessions themselves using the Sessions menu, including creating, opening, saving and editing the sessions (there's also a widget you can add to the desktop or panel to start a specific kate session).
You might check in Sessions -> Open Session and/or Sessions -> Manage Sessions to see what shows up and clean up any old sessions.
If need be, you can manually edit the sessions, including the "anonymous" default session under $XDG_DATA_HOME/kate.

On top of this, Plasma also has session management set up to remember the things you had open when you logged out so that it can open them up for you when you log in. This behavior can be configured via System Settings -> Startup and Shutdown -> Desktop Session. Depending on how Plasma's and Kate's session management are cooperating, may be contributing to the problem.


airdrik, proud to be a member of KDE forums since 2008-Dec.
hay207
Registered Member
Posts
3
Karma
0

Re: Kate bug at startup

Thu Oct 17, 2019 10:41 am
There is a screenshot of how many kate windows open at boot/startup

https://ibb.co/6JDzT48
airdrik
Registered Member
Posts
1788
Karma
5
OS

Re: Kate bug at startup

Fri Oct 25, 2019 6:45 pm
Well, to try and reset things you'd probably need to reset both Kate's session management as well as Plasma's session management.

To reset Plasma's session management, open System Settings and go to Startup and Shutdown > Desktop Session. under On Login, select "Start with an empty session". Then log out and log back in. Subsequently you can go back in there and change it back to "Restore previous session" if you want Plasma to open the applications you had open when you logged out upon logging in. (if changing the setting back results in it still re-opening kate on login when it was supposedly closed, you might add it to the list of excluded applications. You might also double-check that kate is in fact closed when you log out and not still open in the background somewhere).

To reset Kate's session management, start by opening Kate. Under Sessions > Session Management, you can clean up any explicitly-saved sessions. Under Settings > Configure Kate > Sessions, you can select to "Start new session" and then close and reopen Kate to reset the default session. (you can also try manually editing the $XDG_DATA_HOME/kate/anonymous.katesession file to clear out the session information, but it looks like that also includes other things like recent file lists and per-file scroll locations, so only remove stuff you're sure you don't want)


airdrik, proud to be a member of KDE forums since 2008-Dec.

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], Google [Bot], Majestic-12 [Bot], Sogou [Bot], taxpayer, tuthuoc, Yahoo [Bot]