Reply to topic

Deluge downloaded from Discover has no GUI

User avatar mb720
Registered Member
Posts
7
Karma
0
Hi!

I'm running Discover on top of Arch Linux.

After installing Deluge using Discover and trying to start Deluge (with Discover's play button), an error message popped up saying "Cannot launch Deluge".
I entered "deluge" in Konsole but saw only "run deluge" and "Get Deluge...", indicating that Deluge wasn't properly installed.

In Konsole, calling deluge resulted in this message:

deluge: error: argument {console,web} [UI args]: invalid choice: 'gtk' (choose from 'console', 'web')


I solved this by installing the Deluge's GTK GUI using

Code: Select all
pacman -S deluge-gtk


Is this an oversight in Discover?
User avatar Mamarok
Manager
Posts
4363
Karma
11
OS
Sounds more like a packaging error from the distro, unsolved dependencies is not something Discover can be blamed for


Currently running Kubuntu 19.10, Plasma 5.18.3, Frameworks 5.67.0, Qt 5.12.4, kernel 5.3.0-42
FWIW: it is always useful to state the Plasma version and distribution when asking questions in this forum, makes it easier for us to help ...
User avatar mb720
Registered Member
Posts
7
Karma
0
Package deluge provides a TUI and web interface for Deluge.
Package deluge-gtk provides a GUI for Deluge.

I'm pretty certain that when installing Deluge from Discover, people expect to get the latter, not the former.
Especially since starting Deluge with KRunner only works that way.
User avatar Mamarok
Manager
Posts
4363
Karma
11
OS
Again, this is packaging and dependencies, these need to be done correctly by the packagers, Discover will only provide what the distro provides.


Currently running Kubuntu 19.10, Plasma 5.18.3, Frameworks 5.67.0, Qt 5.12.4, kernel 5.3.0-42
FWIW: it is always useful to state the Plasma version and distribution when asking questions in this forum, makes it easier for us to help ...
User avatar mb720
Registered Member
Posts
7
Karma
0
In Discover, when I search for "Deluge", and click the "Install" button on the only search result returned, how does Discover pick the package to install?
Does PackageKit choose to do the equivalent of pacman -Sy deluge instead of pacman -Sy deluge-gtk?
User avatar Mamarok
Manager
Posts
4363
Karma
11
OS
Well, when I search for deluge I find two packages in Discover, on is the GTK client. If you find only one then something is wrong in the packaging, talk to your distro.

I was wondering: why don't you just use KTorrent if you are using Plasma anyway?


Currently running Kubuntu 19.10, Plasma 5.18.3, Frameworks 5.67.0, Qt 5.12.4, kernel 5.3.0-42
FWIW: it is always useful to state the Plasma version and distribution when asking questions in this forum, makes it easier for us to help ...
User avatar mb720
Registered Member
Posts
7
Karma
0
talk to your distro


I set this system up with
Code: Select all
pacstrap /mnt base linux linux-firmware grub plasma vi vim sudo networkmanager packagekit-qt5
from an Arch Linux live image. I don't think the concept of "distro" applies in this case. I could ask on the Arch Linux Forums but I assume they'd tell me it's Discover who chooses the package deluge over deluge-gtk, making this the relevant forum.

why don't you just use KTorrent


I'm setting up Plasma and applications for a friend and they prefer Deluge.
airdrik
Registered Member
Posts
1845
Karma
5
OS
The Arch Linux Forums is exactly what Mamarok is meaning by ask your distro. The base system is the Arch Linux distribution of linux; Arch Linux is what provides the packaging support (unless you created your own custom from-scratch linux distribution using its own packaging system).


airdrik, proud to be a member of KDE forums since 2008-Dec.

 
Reply to topic

Bookmarks



Who is online

Registered users: amanrique, Baidu [Spider], Bing [Bot], farid, Google [Bot], MSN [Bot], PanMat, Sogou [Bot], Stephen Leibowitz, YaCy [Bot]