Reply to topic

Probable Locale bug ? Not sure. Guide plz.

bijaydeyp
Registered Member
Posts
10
Karma
0
OS
The problems are below...

I fresh installed kubuntu-20.04 with time zone Iceland (Raykjavik) while installing by installer. After logging in the system, I changed the formats(https://imgur.com/a/hlTGkZz) to UK. But the changes did not take place after re-log in. That is, the Log In screen(https://imgur.com/a/tZpXotB) is in the iceland's formats(Numbers+time+currency+measurement_unit) still there even after reboot.

Tested similar installation on another partition. This time, selected time-zone 'UK' by installer. Post-installation 'Formats' changed to Iceland. Log out & re-log in. Yet, Log In screen is in english format instead of Icelandic.

Anyone experienced the same? ???
bijaydeyp
Registered Member
Posts
10
Karma
0
OS
Also tried in Manjaro KDE. Same problems there. It seems to be universal for KDE distos. :(

Last edited by bijaydeyp on Sat May 30, 2020 6:33 pm, edited 1 time in total.
User avatar Mamarok
Manager
Posts
4740
Karma
12
OS
Are you sure you have an actual UK keyboard set? And why did you install Icelandic if you don't use it?

I very much doubt this is a bug, can't reproduce this here at all.


Currently running Kubuntu 20.04, Plasma 5.18.5, Frameworks 5.68.0, Qt 5.12.8, kernel 5.4.0-40
FWIW: it is always useful to state the exact Plasma version and distribution when asking questions in this forum, makes it easier for us to help ...
bijaydeyp
Registered Member
Posts
10
Karma
0
OS
Hi mam.
I use US keyboard always. The intention to select Iceland time zone was to use the GMT time.
I am talking about time locale( i.e days+months). They remain unchanged at each desktop session (i.e. Login screen). Ref. https://imgur.com/a/tZpXotB

Thanks :)
User avatar Mamarok
Manager
Posts
4740
Karma
12
OS
Wait, you use the Icelandic locale to use GMT? GMT stands for Greenwich Mean Time, and the Royal Observatory Greenwich is in London, UK, not in Iceland...

Anyway: it could be that a necessary script to get proper Qt5 translations is interfering:

Code: Select all
locale -a

will give you the current setting.

Since you chose Icelandic on installation, the script ~/.config/plasma-locale-settings.sh might still have these settings and will overwrite your changes on every Plasma start.

Code: Select all
kcmshell5 formats

Should allow you to regenerate this script to the correct region.

To complicate things even more, the system wide default value is written into /etc/default/locale , but can be changed in a user specific setting by an entry in $HOME/.pam_environment, I suggest erasing the latter if you are the only user of the system, and set the locale settings globally:
Code: Select all
sudo LC_ALL=en_GB.UTF-8

should do the trick if the kcmshell5 settings didn't help.


Currently running Kubuntu 20.04, Plasma 5.18.5, Frameworks 5.68.0, Qt 5.12.8, kernel 5.4.0-40
FWIW: it is always useful to state the exact Plasma version and distribution when asking questions in this forum, makes it easier for us to help ...
bijaydeyp
Registered Member
Posts
10
Karma
0
OS
:'(
Wait, you use the Icelandic locale to use GMT? GMT stands for Greenwich Mean Time, and the Royal Observatory Greenwich is in London, UK, not in Iceland...

Read the last comment ... https://askubuntu.com/questions/169376/ ... oot#169384

should do the trick if the kcmshell5 settings didn't help.

I am getting this .... https://imgur.com/a/RmOqgdr
User avatar Mamarok
Manager
Posts
4740
Karma
12
OS
That comment was from 6 years ago on a dual boot system where there is a conflict in the BIOS settings, this has nothing to do with locale settings.

If you can't load the kcmshell5 to change the formats, then something is very wrong in your installation, I suggest you check if your Kubuntu installation is really complete, it doesn't seem so if you can't even load the most basic system settings.


Currently running Kubuntu 20.04, Plasma 5.18.5, Frameworks 5.68.0, Qt 5.12.8, kernel 5.4.0-40
FWIW: it is always useful to state the exact Plasma version and distribution when asking questions in this forum, makes it easier for us to help ...
bijaydeyp
Registered Member
Posts
10
Karma
0
OS
If you can't load the kcmshell5 to change the formats,

Running the command gives that terminal output as well as it loads the formats settings.
But look my 1st post. Already said, changing the formats wouldn't resolve the problems. I tried already by manual & terminal way.
Regards
bijaydeyp
Registered Member
Posts
10
Karma
0
OS
This problem finally solved. https://forum.manjaro.org/t/sddm-kde-su ... ion/147267

Many thanks to @Mamarok for helps. :)

Update: https://bugs.kde.org/show_bug.cgi?id=422339

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], claydoh, fozziebear, Google [Bot], idriskalp, Sogou [Bot], spoontex, tymond, Yahoo [Bot]