Reply to topic

Autoremove kills Plasma

User avatar peerwal
Registered Member
Posts
20
Karma
0
OS

Autoremove kills Plasma

Thu Oct 15, 2020 2:40 pm
Hi everybody,

After having upgraded to Plasma 5.20 I ran sudo apt-get -autoremove, which resulted in Plasma not starting anymore during my next boot-up. I fixed that issue by re-installing the packages that had been removed. Autoremove shouldn't delete any files that are still required, should it? So, how could this happen and what should I take care of before I run this command next time?

Any comments are appreciated.
User avatar claydoh
Registered Member
Posts
679
Karma
5
OS

Re: Autoremove kills Plasma  Topic is solved

Thu Oct 15, 2020 7:40 pm
You probably have an incomplete update, and you probably are missing some packages, which is making apt want to remove some things.

A few standard Debian/Ubuntu things to try here are:

Code: Select all
sudo dpkg --configure -a
sudo apt -f install

This will check for and install any packages that were not fully installed or failed for some reason, and then look for and install any missing packages.

then try updating again
Code: Select all
sudo apt update && sudo apt full-upgrade


or
Code: Select all
pkcon refresh
pkcon update


claydoh, proud to be a member of KDE forums since 2008-Oct, and KDE user since 2001
User avatar peerwal
Registered Member
Posts
20
Karma
0
OS

Re: Autoremove kills Plasma

Fri Oct 16, 2020 11:43 am
Thanks for your comment.

I tried to check for/install incomplete packages but did not find any, so, updating again did not find any new packages either. However the system seems to be running well now, so no reason for worrying for the time being.

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], claydoh, cmb, DeMus, frantesta, Google [Bot], hagdervriese, shmu26, Sogou [Bot], Yahoo [Bot]