Reply to topic

Konsole has whitespaces whenever I start

greenz1
Registered Member
Posts
4
Karma
0
I am using Konsole as my terminal emulator in Fedora 28. I was tinkering with some system settings and they seem to have added few whitespaces to my Konsole.
Image

I am not messing around. Those white spaces are not added by me. Every time I open the Konsole they are there.

I have tried fixing/deleting Konsole config files from the location below but to no avail.
Code: Select all
~/.config/konsolerc

And
Code: Select all
~/.local/share/konsole
airdrik
Registered Member
Posts
1390
Karma
2
OS
I'd guess that you and diddyonkde in viewtopic.php?f=227&t=153628 are experiencing the same problem.
I'd recommend one of you file a bug to bugs.kde.org.


airdrik, proud to be a member of KDE forums since 2008-Dec.
diddyonkde
Registered Member
Posts
14
Karma
0
User avatar TKL-Ansi
Registered Member
Posts
42
Karma
0
OS
Could it be that you changed PS1?
I don't know if Fedora offers a GUI to set the prompt but Konsole usually reads the ~/.bashrc file which includes PS1.

The 'Prompt String' variable PS1 is responsible for the look of your standard prompt.

For example, on terminal type

Code: Select all
PS1='>>>  '

or
Code: Select all
PS1='>>>'

and you get a new prompt with or without white space.

https://www.linuxnix.com/linuxunix-shell-ps1-prompt-explained-in-detail/


:wq
airdrik
Registered Member
Posts
1390
Karma
2
OS
There's more to it than that. Check the bug report and the video that diddyonkde posted in viewtopic.php?f=227&t=153628 it seems to have to do with the handling of wide characters where the right half of the character is being presented as a space instead of the rest of the character.
(also PS1 is defined and used by the shell (e.g. bash) not the terminal emulator - konsole doesn't care how you've defined your bash or zsh or ipython prompt, it's just there to render the characters that whatever command is currently running printed to the screen)


airdrik, proud to be a member of KDE forums since 2008-Dec.
User avatar TKL-Ansi
Registered Member
Posts
42
Karma
0
OS
airdrik wrote:also PS1 is defined and used by the shell (e.g. bash)


I know, guess why I mentioned the bashrc
Change PS1 in the bashrc or simply add PS1='>>> ' to the end,
restart Konsole and you see a different prompt.

I focus on the OP and his screenshot, he uses bash and you only see a prompt which has whitespace.
Could be a bug, I don't know. I just added an idea.


:wq
mdevi
Registered Member
Posts
2
Karma
0
Well, I faced the exact same issue and I am using Konsole as my terminal emulator in Fedora 28 same like you, I really think that this is some kind of bug. Can you tell me the mybkexperience where to file the bug report?

Last edited by mdevi on Wed Sep 05, 2018 11:02 am, edited 1 time in total.
User avatar TKL-Ansi
Registered Member
Posts
42
Karma
0
OS
I installed the kde spin of Fedora 28 in virtualbox and applied all the updates.

No issues with default settings.

I can reproduce the whitespace issue, when I select a non monospaced font in the settings,
but Konsole explicitly warns you about such a font:

By its very nature, a terminal program requires font characters that are equal width (monospace). Any non monospaced font may cause display issues. This should not be necessary except in rare cases.


Do you use a special font in your Konsole profile?


:wq
greenz1
Registered Member
Posts
4
Karma
0
My issue originated when I installed KDE from inside GNOME and removed GNOME.

@mdevi the bug report has been filed by @diddyonkde

 
Reply to topic

Bookmarks



Who is online

Registered users: ahabgreybeard, Baidu [Spider], Bing [Bot], Exabot [Bot], gfielding, Google [Bot], mcoudert, robgriff444, Sogou [Bot], Yahoo [Bot], zaldymacalalad