Reply to topic

[SOLVED] konsole not working after upgrade to KDE4

tar1827
Registered Member
Posts
7
Karma
0
Thanks in advance for any help...I am a relative n00b.
I use KDE with Fedora and yesterday I used the pre-upgrade utility to go from F8 to F10. The previous version of KDE was 3.5, I think. The Fedora upgrade appeared to go perfectly until I started using KDE4. Now I have discovered that I do not have the use of konsole. I finally found out how to use krunner in order to get xterm to run; but from the console I have only verified that konsole does not run. It's as if it is not installed. (-bash: konsole: command not found).

I learned that it is part of kdebase, so since I am at KDE 4.1.2, I thought that upgrading to KDE 4.2 might solve the problem. Using yum extender GUI and yum in xterm I tried to upgrade and/or install. It always fails with the same errors:

[size=x-small]# yum install kdebase
{snip}
Transaction Check Error:
file /usr/share/config/plasmoids.knsrc from install of kdelibs-6:4.2.0-15.fc10.i386 conflicts with file from package kdebase-workspace-4.1.2-14.fc10.i386
file /usr/share/kde4/servicetypes/plasma-animator.desktop from install of kdelibs-6:4.2.0-15.fc10.i386 conflicts with file from package kdebase-workspace-4.1.2-14.fc10.i386
file /usr/share/kde4/servicetypes/plasma-applet.desktop from install of kdelibs-6:4.2.0-15.fc10.i386 conflicts with file from package kdebase-workspace-4.1.2-14.fc10.i386
file /usr/share/kde4/servicetypes/plasma-containment.desktop from install of kdelibs-6:4.2.0-15.fc10.i386 conflicts with file from package kdebase-workspace-4.1.2-14.fc10.i386
file /usr/share/kde4/servicetypes/plasma-dataengine.desktop from install of kdelibs-6:4.2.0-15.fc10.i386 conflicts with file from package kdebase-workspace-4.1.2-14.fc10.i386
file /usr/share/kde4/servicetypes/plasma-packagestructure.desktop from install of kdelibs-6:4.2.0-15.fc10.i386 conflicts with file from package kdebase-workspace-4.1.2-14.fc10.i386
file /usr/share/kde4/servicetypes/plasma-runner.desktop from install of kdelibs-6:4.2.0-15.fc10.i386 conflicts with file from package kdebase-workspace-4.1.2-14.fc10.i386
file /usr/share/kde4/servicetypes/plasma-scriptengine.desktop from install of kdelibs-6:4.2.0-15.fc10.i386 conflicts with file from package kdebase-workspace-4.1.2-14.fc10.i386
file /usr/lib/libakonadi-kabc.so.4 from install of kdepimlibs-4.2.0-2.fc10.i386 conflicts with file from package kdepim-libs-6:4.1.2-5.fc10.i386[/size]


I tried renaming some of the files to see if it would help, but I never observed signs of progress. What can I do to get my KDE fully operational again?
User avatar bcooksley
Administrator
Posts
19765
Karma
87
OS
It appears that you have package version mismatches. Please ensure that the correct KDE 4.2 repository has been added and is updated. Then ensure that all KDE related packages are fully updated, and try again.


KDE Sysadmin
[img]http://forum.kde.org/content/bcooksley_sig.png[/img]
tar1827
Registered Member
Posts
7
Karma
0
Thanks for the reply. Can you point me to a howto or an existing thread related to adding / updating the repository? Based upon my latest effort, I believe that I'm not setting up the repositories correctly. Also, in the past, I have always used ATRPMS, I don't know if RPMFUSION conflicts with it or not--I got the impression that they attempt to offer the same thing.

Following the steps at this link
F10 Tips & Tricks, I did:


I got these errors this time:
[size=x-small]Transaction Check Error:
file /usr/lib/kde4/plugins/marble/CompassFloatItem.so conflicts between attempted installs of kdeedu- libs-4.1.2-2.fc10.i386 and kdeedu-marble-4.2.0-7.fc10.i386
file /usr/lib/kde4/plugins/marble/MapScaleFloatItem.so conflicts between attempted installs of kdeedu -libs-4.1.2-2.fc10.i386 and kdeedu-marble-4.2.0-7.fc10.i386
file /usr/lib/kde4/plugins/marble/MarbleOverviewMap.so conflicts between attempted installs of kdeedu -libs-4.1.2-2.fc10.i386 and kdeedu-marble-4.2.0-7.fc10.i386
file /usr/lib/kde4/plugins/marble/MarbleStarsPlugin.so conflicts between attempted installs of kdeedu -libs-4.1.2-2.fc10.i386 and kdeedu-marble-4.2.0-7.fc10.i386
file /usr/lib/libmarblewidget.so.4 conflicts between attempted installs of kdeedu-libs-4.1.2-2.fc10.i 386 and kdeedu-marble-4.2.0-7.fc10.i386[/size]


Perhaps this is also informative?
[size=x-small]
[[email protected] yum.repos.d]# ll
total 84
-rw-r--r-- 1 root root 570 2008-03-04 13:45 atrpms.repo.error
-rw-r--r-- 1 root root 1962 2008-11-06 15:06 fedora-rawhide.repo
-rw-r--r-- 1 root root 1090 2008-11-06 15:06 fedora.repo
-rw-r--r-- 1 root root 1108 2008-11-06 15:06 fedora-updates.repo
-rw-r--r-- 1 root root 1181 2008-11-06 15:06 fedora-updates-testing.repo
-rw-r--r-- 1 root root 155 2008-03-04 13:40 freshrpms.repo
-rw-r--r-- 1 root root 1904 2007-11-07 11:11 livna-devel.repo
-rw-r--r-- 1 root root 1808 2007-11-07 11:11 livna.repo
-rw-r--r-- 1 root root 2003 2007-11-07 11:11 livna-testing.repo
-rw-r--r-- 1 root root 1022 2008-11-03 08:16 rpmfusion-free-rawhide.repo
-rw-r--r-- 1 root root 1079 2008-11-03 08:16 rpmfusion-free.repo
-rw-r--r-- 1 root root 1134 2008-11-03 08:16 rpmfusion-free-updates.repo
-rw-r--r-- 1 root root 1194 2008-11-03 08:16 rpmfusion-free-updates-testing.repo
-rw-r--r-- 1 root root 1067 2008-11-03 08:25 rpmfusion-nonfree-rawhide.repo
-rw-r--r-- 1 root root 1124 2008-11-03 08:25 rpmfusion-nonfree.repo
-rw-r--r-- 1 root root 1179 2008-11-03 08:25 rpmfusion-nonfree-updates.repo
-rw-r--r-- 1 root root 1239 2008-11-03 08:25 rpmfusion-nonfree-updates-testing.repo[/size]


Any other help would be greatly appreciated!
Thanks.


bcooksley wrote:It appears that you have package version mismatches. Please ensure that the correct KDE 4.2 repository has been added and is updated. Then ensure that all KDE related packages are fully updated, and try again.
User avatar bcooksley
Administrator
Posts
19765
Karma
87
OS
These instructions might be of help: http://blog.bfccomputing.com/articles/2 ... rt-version


KDE Sysadmin
[img]http://forum.kde.org/content/bcooksley_sig.png[/img]
tar1827
Registered Member
Posts
7
Karma
0
Thanks. That was a helpful link. I was able to get all of the yum updates to work based upon this, but KDE still did not work. Ultimately, I achieved success by first renaming my old .kde folders to something else, then removing all of KDE, then re-installing it. After a few struggles with X, I got it all working. I wish I had known about removing or renaming the .kde directories before upgrading from KDE3 to KDE4. That would probably have saved me.

I appreciate the hints!

bcooksley wrote:These instructions might be of help: http://blog.bfccomputing.com/articles/2 ... rt-version

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], Bryan ??, Google [Bot], grahm, Lupccs, Mace68, Raxker, sh-zam, Sogou [Bot], Yahoo [Bot]