Reply to topic

Cannot use Konsole, error on startup

User avatar bcooksley
Administrator
Posts
19765
Karma
87
OS
Your issue seems to be different. Please try reproducing under a new user. If you cannot reproduce, remove ~/.kde4/share/apps/konsole/


KDE Sysadmin
[img]http://forum.kde.org/content/bcooksley_sig.png[/img]
FelipeM87
Registered Member
Posts
1
Karma
0
OS

try this.

Sun Mar 20, 2011 11:41 pm
Try this, was the solution for me :)

open another terminal *not konsole and go to /bin
$ cd /bin
and
$ sudo chmod 777 bash

now try to open Konsole. Must work right now, because the trouble was about the permision to load /bin/bash

:)
User avatar bcooksley
Administrator
Posts
19765
Karma
87
OS
Note that 777 permissions (rwxrwxrwx) are very dangerous for a system-wide executable. 755 would be more appropriate (rwxr-xr-x)


KDE Sysadmin
[img]http://forum.kde.org/content/bcooksley_sig.png[/img]
paul.kashofer
Registered Member
Posts
5
Karma
0
OS
Hi!

I have the same error on Kubuntu 10.04
KDE=4.4.5
Language=German

And the same error i can find here (in german):
http://forums.gentoo.org/viewtopic-t-85 ... art-0.html

The error happens just sometimes, so its difficult to reconstruct it.
The error happens on my PC, on my notebook (same os) this happens never.

The access rights of /bin/bash are already: -rwxr-xr-x
Changing this will not help, i think.

There is no .kde4 folder in my home, but a .kde!

I will try to delete .kde/share/apps/konsole

(sorry for bad english)
paul.kashofer
Registered Member
Posts
5
Karma
0
OS
Hello.

removing .kde/share/apps/konsole did not help for me!
(Anything else i can do?)
User avatar bcooksley
Administrator
Posts
19765
Karma
87
OS
First, ensure that ~/.kde/ is the right directory to start with. The output of "kde4-config --localprefix" will reveal this. Another popular option is ~/.kde4/

Second, try removing ~/.kde/share/config/konsolerc as well.


KDE Sysadmin
[img]http://forum.kde.org/content/bcooksley_sig.png[/img]
paul.kashofer
Registered Member
Posts
5
Karma
0
OS
Thanks, for your fast reply.

~/.kde/ is the right directory in Kubuntu.

Now I delete both.
I will post later, if this did not solve the issue!
paul.kashofer
Registered Member
Posts
5
Karma
0
OS
Sorry, but the issue still exists.

Now i got the following massage:
Hinweis: Das Programm „/media/Daten/home/ppp/Musik/Radio/RecShell“
mit den Argumenten „/media/Daten/home/ppp/Musik/Radio/RecShell“
kann nicht gestartet werden.

in english:
The application "Path/to/my/shellScript" with the arguments "Path/to/my/shellScript"
can not be started.

I tried to start my ShellScript from KDE menu.
(Anything else i can do?)
User avatar bcooksley
Administrator
Posts
19765
Karma
87
OS
Using a virtual terminal, execute the following please (as your user - not root):
Code: Select all
killall -9 konsole
rm -rf $(kde4-config --localprefix)/share/apps/konsole/
rm -f $(kde4-config --localprefix)/share/config/konsole*


Then login to KDE again and try to start Konsole. All custom profiles and Konsole settings you may have setup will be destroyed by the above process.


KDE Sysadmin
[img]http://forum.kde.org/content/bcooksley_sig.png[/img]
paul.kashofer
Registered Member
Posts
5
Karma
0
OS
Hi to all!

Since i did this, the issue does not occur again!
I think this problem is solved for me.

Many thanks to bcooksley!
User avatar toad
Global Moderator
Posts
1259
Karma
7
OS
Had the same problem.

Solution which worked for me:
putting /bin/sh in terminal profile gave me a limited shell with which I could edit my /etc/inputrc (which I had edited previously - and wrongly :P). Now my bash is working again.

Many thanks to bcooksley!


Debian testing
User avatar scummos
Global Moderator
Posts
1153
Karma
7
OS
Does running /bin/bash work in another terminal emulator, such as xterm? If that is the case, something is wrong with konsole; otherwise, something is severly broken in the rest of your setup.

Cheers


I'm working on the KDevelop IDE.
Tuku
Registered Member
Posts
1
Karma
0
My case:
There was strange file '/bin/bash' , 0 bytes, no idea where it came from.

% ls -la /bin/bash*
-rwxr-xr-x 2 tukul User 0 Dec 17 2015 /bin/bash
-rwxr-xr-x 2 tukul tukul 739859 Jan 27 2017 /bin/bash.exe

Remove it, leaving bash.exe only

Now konsole start without problems.


Edit 1: fix konsole spell, I mean, mess console spell....whatever :-\

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], Google [Bot], Gregstrq, grosser, magkoc, martinknopp, mirass, mrvldmr, mutterhunt, orcuan, Sogou [Bot], Yahoo [Bot]