Reply to topic

Cannot set alarms in KAlarm

petern
Registered Member
Posts
27
Karma
0
OS

Cannot set alarms in KAlarm

Fri Mar 01, 2013 6:12 pm
I recently encountered akonadi-related problems with KMail, which I have solved following discussion on the Kontact & PIM Forum. At the same time I lost my stored alarms in KAlarm (Version 2.9.4-ak), and couldn't re-set them, since most of the drop-down menu items were greyed out. The KMail solution involved reinstating the missing local-mail Agent in Akonadi, but I still can't set any alarms in KAlarm and I wonder if anyone has any ideas on this? I run a fully updated PCLInuxOS system on a desktop PC with an AMD Athlon(tm) II X2 250 Processor and 4 GByte RAM. KMail and KAlarm are the only PIM components I use.

If I start KAlarm via Konsole I get the following error message:

[peter_h@localhost ~]$ kalarm
QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
[peter_h@localhost ~]$

and the KAlarm window opens, but with no alarms set, and the greyed-out menus still in evidence.
djarvie
KDE Developer
Posts
66
Karma
0
OS

Re: Cannot set alarms in KAlarm  Topic is solved

Wed Mar 06, 2013 8:31 pm
The menu items being greyed out will almost certainly be due to there being no enabled, writable, active KAlarm calendars. Check which (if any) calendars are enabled in KAlarm by View -> Show Calendars. Select Active Alarms, and ensure that at least one writable calendar has a check mark to denote enabled. Writable calendars are shown in black print, while read-only calendars are shown grey.

If you don't see any calendars listed, you can add an existing calendar file (or create a new calendar file) by clicking the Add button under the Calendars list. The default active alarms calendar file is ~/.kde/share/apps/kalarm/calendar.ics (or similar path, depending on your distro).


KAlarm author
petern
Registered Member
Posts
27
Karma
0
OS

Re: Cannot set alarms in KAlarm

Thu Mar 07, 2013 3:11 pm
Thanks for the advice. The Active Alarms checkbox had become un-ticked for some reason, and re-ticking it brought back the missing alarms.
djarvie
KDE Developer
Posts
66
Karma
0
OS

Re: Cannot set alarms in KAlarm

Thu Mar 07, 2013 11:28 pm
I'm glad it's working again. In view of your difficulty in realising what was wrong (and if the calendar view wasn't enabled, I can't blame anybody for not realising), I'll add a warning when KAlarm starts up without a writable active calendar, to tell the user what is wrong - see KDE Bug 316338.


KAlarm author
User avatar Dimitrios
Registered Member
Posts
659
Karma
0
OS

Re: Cannot set alarms in KAlarm

Wed Sep 11, 2013 4:21 am
Thank you, i had the same problem me too


«The magic continues...»
http://www.mageia.org
Image
neurodavidus
Registered Member
Posts
1
Karma
0

Re: Cannot set alarms in KAlarm

Thu Mar 27, 2014 2:32 pm
Dear Djarvie,

Here is a first time user of Kalaram. (A bit frustrated). From fresh install of Kalarm in yast (opensue12.3) I coud not intuitively create a new alarm. Everything was grayed.
I gave up. Then after a few days, I got back to it and found this thread. I though I had the answer when I read your comment (quoted below).

However when I follow your instruction (View, show Calendar, Add .... navigate in .kde/..... until I select something called calendar.ics then nothing appear in the Calendar window. And everything is grayed. I might probably miss something obvious.

WOuld you be kind enough to help me ?

thanks a lot






If you don't see any calendars listed, you can add an existing calendar file (or create a new calendar file) by clicking the Add button under the Calendars list. The default active alarms calendar file is ~/.kde/share/apps/kalarm/calendar.ics (or similar path, depending on your distro).[/quote]
djarvie
KDE Developer
Posts
66
Karma
0
OS

Re: Cannot set alarms in KAlarm

Mon Mar 31, 2014 12:44 pm
Normally when you start KAlarm for the first time, its calendars should be created and enabled automatically. For some reason that doesn't seem to have happened in your case.

What version of KAlarm are you running (use Help -> About)?

Did any error messages appear when you started KAlarm (either the first time, or on subsequent attempts)? If so, what were they, and did you follow any instructions which they contained?

When you do View -> Calendars, what do you see in the Calendars pane? I assume that a calendar is shown there - is it checked? If not, it needs to be checked to enable it. Otherwise, right click on the calendar and select Show Details. Please copy the details into your reply here.


KAlarm author
staleym
Registered Member
Posts
3
Karma
0

Re: Cannot set alarms in KAlarm

Sat Sep 02, 2017 11:57 pm
AI have suddenly developed this same issue today despite using KAlarm in the last 2 days.
My system:
Lenovo IdeaPad 310-15ABR
Linux: Slackware64-14.2 MultiLib (up to date in all respects as today)
Kernel: 4.4.75
KDE: 4.14.32alarms
QT: 4.8.7-x86_64-4
Kalarm: 2.10.12-ak

I have reinstalled package, run fsck on all partitions, rebooted, logged out, logged back in, checked akonadi_console and server is running with Kalarm, Kalarmssss, Active Alarms, Archived Alarms, Alarm Templates and calendar.ics are marked "Ready" I have even renamed .kde/share/apps/kalarm so a new directory would be created on next start. There is no xsession-error file generated when I restart KAlarm. I have not changed any permissions since I last used KAlarm successfully though I did check all directory/subdirectory/file permissions and they are appropriate.

I have followed all your directions in this thread. Show Calendars is active. There are no calendars in the Calendar box under Active, Archived, Templates. I added new directory and file in the appropriate config boxes and nothing is added!

I created a New User to my system and it works there (a 1 minute test alarm).

Still, I am unable to get a New function and my old alarms are not present. I've spent hours trying to resolve this. Have you any suggestions for something I might have missed?

Warm regards
Staley
djarvie
KDE Developer
Posts
66
Karma
0
OS

Re: Cannot set alarms in KAlarm

Sun Sep 10, 2017 7:09 pm
If the calendars show as Ready in akonadiconsole, they certainly should show up in the Calendars box in KAlarm, even if they are not enabled there.

1) Can you confirm that in the Calendars box, you clicked the "Add..." button to add the alarm calendars when you saw that there were no Active Alarms calendars listed.

2) Which did you select after clicking Add: a "KAlarm Calendar File" or a "KAlarm Directory"?

3) Did you specify an existing alarm calendar file/directory when you configured the alarm calendar after clicking Add, or did you specify a new calendar file/directory?

4) In akonadiconsole, right click on Active Alarms (or one of the other active alarms calendars), and select Configure -> Remotely. Please report what is listed there.

As was stated in an earlier post, the File -> New, and the New button, menu option are greyed out if KAlarm thinks that there is no active alarm calendar configured, or if it is configured to be read only, or if the file or directory is not writable.


KAlarm author
staleym
Registered Member
Posts
3
Karma
0

Re: Cannot set alarms in KAlarm

Sun Sep 10, 2017 9:07 pm
Thanks for checking in with me!

As to the issues you raise:

AkonadiConsole shows Active Alarms, Archived Alarms and Alarm Templates as
"Ready". They do not show up in Calendars Box (there is nothing to activate).

1) Yes.
2) I did both. I attempted to add existing directory as
/home/[my directory]/.kde/share/apps/kalarm and existing file as
/home/[my directory]/.kde/share/apps/kalarm/calendar.ics. This made no change
and nothing was added to active. I tried this with Archived Alarms and Alarm
Templates and same result. Nothing added to activate.
3) See answer 2 above.
4) Report is as follows:
GetMachineid
AlarmTypes application/x-vnd.kde.alarm.active OStringList
DisplayName ActiveAlarms QString
MonitorFile true bool
Path file:///home/[my directory]
/.kde/share/apps/kalarm/calendar.ics~cs QString
ReadOnly false bool
UpdateStorageFormat false bool

The .kde directory, all subdirectories and file all have permissions set to
40700 (owner +rwx).

FWIW - When I switched out the .kde directory, subdirectories and files with
working copies from a test user and chowning to [my directory]:users, it works
fine, however, I lose ALL my Desktop settings. I would rather not have to try
and recreate all my desktop configurations.

Warmest regards,
Staley

djarvie wrote:If the calendars show as Ready in akonadiconsole, they certainly should show up in the Calendars box in KAlarm, even if they are not enabled there.

1) Can you confirm that in the Calendars box, you clicked the "Add..." button to add the alarm calendars when you saw that there were no Active Alarms calendars listed.

2) Which did you select after clicking Add: a "KAlarm Calendar File" or a "KAlarm Directory"?

3) Did you specify an existing alarm calendar file/directory when you configured the alarm calendar after clicking Add, or did you specify a new calendar file/directory?

4) In akonadiconsole, right click on Active Alarms (or one of the other active alarms calendars), and select Configure -> Remotely. Please report what is listed there.

As was stated in an earlier post, the File -> New, and the New button, menu option are greyed out if KAlarm thinks that there is no active alarm calendar configured, or if it is configured to be read only, or if the file or directory is not writable.
djarvie
KDE Developer
Posts
66
Karma
0
OS

Re: Cannot set alarms in KAlarm

Wed Sep 20, 2017 11:07 pm
I'm afraid I'm stumped! If, as you say, the calendars show up as KAlarm calendars in Akonadi, I can't think of why they wouldn't show up in KAlarm's Calendars pane. I can't reproduce the fault, so can't investigate it here. Unfortunately, it looks like one of those issues where without being able to play around on your system to investigate, it won't be possible to find a solution. I'm sorry.


KAlarm author
staleym
Registered Member
Posts
3
Karma
0

Re: Cannot set alarms in KAlarm

Thu Sep 21, 2017 5:04 am
Thanks for checking and the reply! From what you said, it looks like the problem cropped up when I restored my personal directory to a new machine via rsync. Most oyf the files transferred just right , yet there were some files corrupted. I have reinstalled the packages so the problem must be some where in my .kde directory. I'll keep working on it.

Warmest regards
Staley

djarvie wrote:I'm afraid I'm stumped! If, as you say, the calendars show up as KAlarm ng in Akonadi, I can't think of why they wouldn't show up in KAlarm's Calendars pane. I can't reproduce the fault, so can't investigate it here. Unfortunately, it looks like one of those issues where without being able to play around on your system to investigate, it won't be possible to find a solution. I'm sorry.

 
Reply to topic

Bookmarks



Who is online

Registered users: aitorpazos, Baidu [Spider], Bing [Bot], Capitain_Jack, dudoser, Exabot [Bot], ggael, Google [Bot], Majestic-12 [Bot], paolof, reinhardgelen, smankowski, Sogou [Bot], sspphheerraa, TheraHedwig, Yahoo [Bot]