Reply to topic

Kalarm doen't work at all

dargaud
Registered Member
Posts
22
Karma
0
OS

Kalarm doen't work at all

Fri Jul 08, 2016 8:52 am
Hello, hello,
after upgrading from kde4 to kde5, kalarm would crash (without quitting) every time an alarm would trigger. So in a sense it would still work.
But with the recent Ubuntu 16.04 upgrade, it now doesn't trigger at all and there are several other bugs (in version 2.11.4-5ak, KDE framework 5.18.0, Qt 5.5.1, xcb):

Image

First the bugs:
- the columns in the main window are no longer sizable
- there's no way to select 24-hour or 12-hour time, and since the columns are not sizable, it's hard to tell the difference between a 6am alarm and a 6pm one...
- the time zone (or daylight savings) is different in the main window and the alarm detail window (see screenshot above). The main window is WRONG.

Now for the part about "doesn't work at all":
Code: Select all
strace -f -o /tmp/kalarm.out -e open kalarm

Doesn't produce anything when an alarm is supposedly triggered.

Code: Select all
strace -f -o /tmp/kalarm.out -e 'trace=!poll' kalarm

Produces the following:
Code: Select all
read(7, 0x7ffe20733610, 16)       = -1 EAGAIN (Resource temporarily unavailable)
getcwd("/home/myusername", 4098)     = 14
stat("/etc/localtime", {st_mode=S_IFREG|0644, st_size=2971, ...}) = 0
stat("/etc/localtime", {st_mode=S_IFREG|0644, st_size=2971, ...}) = 0
stat("/etc/localtime", {st_mode=S_IFREG|0644, st_size=2971, ...}) = 0
stat("/etc/localtime", {st_mode=S_IFREG|0644, st_size=2971, ...}) = 0
stat("/etc/localtime", {st_mode=S_IFREG|0644, st_size=2971, ...}) = 0
stat("/etc/localtime", {st_mode=S_IFREG|0644, st_size=2971, ...}) = 0
stat("/etc/localtime", {st_mode=S_IFREG|0644, st_size=2971, ...}) = 0
stat("/etc/localtime", {st_mode=S_IFREG|0644, st_size=2971, ...}) = 0
stat("/etc/localtime", {st_mode=S_IFREG|0644, st_size=2971, ...}) = 0
stat("/etc/localtime", {st_mode=S_IFREG|0644, st_size=2971, ...}) = 0
stat("/etc/localtime", {st_mode=S_IFREG|0644, st_size=2971, ...}) = 0
stat("/etc/localtime", {st_mode=S_IFREG|0644, st_size=2971, ...}) = 0
stat("/etc/localtime", {st_mode=S_IFREG|0644, st_size=2971, ...}) = 0
stat("/etc/localtime", {st_mode=S_IFREG|0644, st_size=2971, ...}) = 0
getcwd("/home/myusername", 4098)     = 14
getcwd("/home/myusername", 4098)     = 14
getcwd("/home/myusername", 4098)     = 14
getcwd("/home/myusername", 4098)     = 14
getcwd("/home/myusername", 4098)     = 14
getcwd("/home/myusername", 4098)     = 14
getcwd("/home/myusername", 4098)     = 14
write(7, "\1\0\0\0\0\0\0\0", 8)   = 8
stat("/etc/localtime", {st_mode=S_IFREG|0644, st_size=2971, ...}) = 0
stat("/etc/localtime", {st_mode=S_IFREG|0644, st_size=2971, ...}) = 0
stat("/etc/localtime", {st_mode=S_IFREG|0644, st_size=2971, ...}) = 0
stat("/etc/localtime", {st_mode=S_IFREG|0644, st_size=2971, ...}) = 0
stat("/etc/localtime", {st_mode=S_IFREG|0644, st_size=2971, ...}) = 0
stat("/etc/localtime", {st_mode=S_IFREG|0644, st_size=2971, ...}) = 0
getcwd("/home/myusername", 4098)     = 14
stat("/etc/localtime", {st_mode=S_IFREG|0644, st_size=2971, ...}) = 0
stat("/etc/localtime", {st_mode=S_IFREG|0644, st_size=2971, ...}) = 0
getcwd("/home/myusername", 4098)     = 14
stat("/etc/localtime", {st_mode=S_IFREG|0644, st_size=2971, ...}) = 0
stat("/etc/localtime", {st_mode=S_IFREG|0644, st_size=2971, ...}) = 0
getcwd("/home/myusername", 4098)     = 14
stat("/etc/localtime", {st_mode=S_IFREG|0644, st_size=2971, ...}) = 0
stat("/etc/localtime", {st_mode=S_IFREG|0644, st_size=2971, ...}) = 0
getcwd("/home/myusername", 4098)     = 14
stat("/etc/localtime", {st_mode=S_IFREG|0644, st_size=2971, ...}) = 0
stat("/etc/localtime", {st_mode=S_IFREG|0644, st_size=2971, ...}) = 0
getcwd("/home/myusername", 4098)     = 14
stat("/etc/localtime", {st_mode=S_IFREG|0644, st_size=2971, ...}) = 0
stat("/etc/localtime", {st_mode=S_IFREG|0644, st_size=2971, ...}) = 0
stat("/etc/localtime", {st_mode=S_IFREG|0644, st_size=2971, ...}) = 0
recvmsg(8, 0x7ffe20733460, 0)     = -1 EAGAIN (Resource temporarily unavailable)
writev(4, [{"+\0\1\0", 4}], 1)    = 4
26978 futex(0x1e29788, FUTEX_WAIT_PRIVATE, 2, NULL <unfinished ...>
futex(0x1e29788, FUTEX_WAKE_PRIVATE, 1 <unfinished ...>
26978 <... futex resumed> )             = 0
<... futex resumed> )             = 1
26978 recvmsg(4,  <unfinished ...>
futex(0x7ffe20732cd4, FUTEX_WAIT_PRIVATE, 1, NULL <unfinished ...>
26978 <... recvmsg resumed> {msg_name(0)=NULL, msg_iov(1)=[{"\1\1q\6\0\0\0\0\f\0\300\6\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0", 4096}], msg_controllen=0, msg_flags=0}, 0) = 32
26978 futex(0x7ffe20732cd4, FUTEX_WAKE_OP_PRIVATE, 1, 1, 0x7ffe20732cd0, {FUTEX_OP_SET, 0, FUTEX_OP_CMP_GT, 1}) = 1
<... futex resumed> )             = 0
26978 futex(0x1e29788, FUTEX_WAKE_PRIVATE, 1 <unfinished ...>
futex(0x1e29788, FUTEX_WAKE_PRIVATE, 1 <unfinished ...>
26978 <... futex resumed> )             = 0
<... futex resumed> )             = 0
getcwd("/home/myusername", 4098)     = 14
getcwd("/home/myusername", 4098)     = 14
getcwd("/home/myusername", 4098)     = 14
writev(4, [{"&\0\2\0\370\2\0\0", 8}], 1) = 8
futex(0x7ffe20732204, FUTEX_WAIT_PRIVATE, 1, NULL <unfinished ...>
26978 recvmsg(4, {msg_name(0)=NULL, msg_iov(1)=[{"\1\1r\6\0\0\0\0\370\2\0\0\30\0`\3\230\6\372\3\230\6\372\3\20\0\0\0\0\0\0\0", 4096}], msg_controllen=0, msg_flags=0}, 0) = 32
26978 futex(0x7ffe20732204, FUTEX_WAKE_OP_PRIVATE, 1, 1, 0x7ffe20732200, {FUTEX_OP_SET, 0, FUTEX_OP_CMP_GT, 1}) = 1
<... futex resumed> )             = 0
futex(0x1e29788, FUTEX_WAKE_PRIVATE, 1) = 0
stat("/etc/localtime", {st_mode=S_IFREG|0644, st_size=2971, ...}) = 0
stat("/etc/localtime", {st_mode=S_IFREG|0644, st_size=2971, ...}) = 0
stat("/etc/localtime", {st_mode=S_IFREG|0644, st_size=2971, ...}) = 0
stat("/etc/localtime", {st_mode=S_IFREG|0644, st_size=2971, ...}) = 0
stat("/etc/localtime", {st_mode=S_IFREG|0644, st_size=2971, ...}) = 0
stat("/etc/localtime", {st_mode=S_IFREG|0644, st_size=2971, ...}) = 0
stat("/etc/localtime", {st_mode=S_IFREG|0644, st_size=2971, ...}) = 0
stat("/etc/localtime", {st_mode=S_IFREG|0644, st_size=2971, ...}) = 0
getcwd("/home/myusername", 4098)     = 14
stat("/etc/localtime", {st_mode=S_IFREG|0644, st_size=2971, ...}) = 0
stat("/etc/localtime", {st_mode=S_IFREG|0644, st_size=2971, ...}) = 0
stat("/etc/localtime", {st_mode=S_IFREG|0644, st_size=2971, ...}) = 0
stat("/etc/localtime", {st_mode=S_IFREG|0644, st_size=2971, ...}) = 0
getcwd("/home/myusername", 4098)     = 14
stat("/etc/localtime", {st_mode=S_IFREG|0644, st_size=2971, ...}) = 0
stat("/etc/localtime", {st_mode=S_IFREG|0644, st_size=2971, ...}) = 0
stat("/etc/localtime", {st_mode=S_IFREG|0644, st_size=2971, ...}) = 0
stat("/etc/localtime", {st_mode=S_IFREG|0644, st_size=2971, ...}) = 0
getcwd("/home/myusername", 4098)     = 14
stat("/etc/localtime", {st_mode=S_IFREG|0644, st_size=2971, ...}) = 0
stat("/etc/localtime", {st_mode=S_IFREG|0644, st_size=2971, ...}) = 0
stat("/etc/localtime", {st_mode=S_IFREG|0644, st_size=2971, ...}) = 0
stat("/etc/localtime", {st_mode=S_IFREG|0644, st_size=2971, ...}) = 0
getcwd("/home/myusername", 4098)     = 14
stat("/etc/localtime", {st_mode=S_IFREG|0644, st_size=2971, ...}) = 0
stat("/etc/localtime", {st_mode=S_IFREG|0644, st_size=2971, ...}) = 0
stat("/etc/localtime", {st_mode=S_IFREG|0644, st_size=2971, ...}) = 0
stat("/etc/localtime", {st_mode=S_IFREG|0644, st_size=2971, ...}) = 0
getcwd("/home/myusername", 4098)     = 14
writev(4, [{"\202\3\n\0\4\0 \6\f\0 \6\200\2\340\1\2\0?\0|\2\237\1\2\0?\0\30\2\0\0"..., 40}], 1) = 40
recvmsg(8, 0x7ffe20733460, 0)     = -1 EAGAIN (Resource temporarily unavailable)
read(7, "\1\0\0\0\0\0\0\0", 16)   = 8
stat("/etc/localtime", {st_mode=S_IFREG|0644, st_size=2971, ...}) = 0
stat("/etc/localtime", {st_mode=S_IFREG|0644, st_size=2971, ...}) = 0
stat("/etc/localtime", {st_mode=S_IFREG|0644, st_size=2971, ...}) = 0
stat("/etc/localtime", {st_mode=S_IFREG|0644, st_size=2971, ...}) = 0
recvmsg(8, 0x7ffe20733460, 0)     = -1 EAGAIN (Resource temporarily unavailable)
26978 recvmsg(4, {msg_name(0)=NULL, msg_iov(1)=[{"U\2s\6\250S\313\23\3\24\4\0\20\0\0\0\0\0\0\24\24\24\24\24\0\0\3\37%\2\0\0", 4096}], msg_controllen=0, msg_flags=0}, 0) = 32
26978 write(7, "\1\0\0\0\0\0\0\0", 8)   = 8
read(7, "\1\0\0\0\0\0\0\0", 16)   = 8
recvmsg(8, 0x7ffe20733460, 0)     = -1 EAGAIN (Resource temporarily unavailable)
djarvie
KDE Developer
Posts
66
Karma
0
OS

Re: Kalarm doen't work at all

Fri Jul 08, 2016 9:25 pm
KAlarm 2.11.5 from KDE applications 16.04.0, using KDE frameworks 21.0, works ok in most respects. To answer your points:

- the columns in the main window are indeed not sizeable. This needs to be fixed if possible. It's likely to be due to a change in behaviour in Qt or the KDE libraries.

- changing the time format setting in KDE system settings (systemsettings5) doesn't change the time format in KAlarm, but it doesn't change it in Dolphin either. So this looks like a KDE-wide problem.

- the time zone issue was fixed in KAlarm 2.11.5.

- On my system, KAlarm does trigger alarms, and did for version 2.11.4/KDE Applications 15.12.3/KDE frameworks 5.17 as well. Your issue seems likely to be an Ubuntu bug, and I suggest you raise a bug report with them. You don't say whether you are running a KDE/Plasma desktop - if not, it would be interesting to know whether you have the same crashes under a Plasma desktop.


KAlarm author
djarvie
KDE Developer
Posts
66
Karma
0
OS

Re: Kalarm doen't work at all

Fri Jul 08, 2016 9:45 pm
Actually, KAlarm in KDE 4.14 doesn't have resizeable columns in the main window either. The time and repetition columns are supposed to automatically resize to fit their contents, and only the Message, File or Command column resizes according to the window width. The issue then is that the time column doesn't actually resize properly to fit its contents.


KAlarm author
dargaud
Registered Member
Posts
22
Karma
0
OS

Re: Kalarm doen't work at all

Tue Jul 12, 2016 2:21 pm
Hello and thanks for the answers.
Yes, I am running Kubuntu. I haven't noticed problems with other kde apps. I have several KDE systems with similar configs, but I don't use kalarm on the others. I'll try.
dargaud
Registered Member
Posts
22
Karma
0
OS

Re: Kalarm doen't work at all

Wed Jul 13, 2016 12:21 pm
I checked on a different system and it's the same: alarms don't trigger.
dargaud
Registered Member
Posts
22
Karma
0
OS

Re: Kalarm doen't work at all

Mon Jul 18, 2016 9:53 am
OK, I experimented a bit and if I click on "Ignore timezone" then it works.
djarvie
KDE Developer
Posts
66
Karma
0
OS

Re: Kalarm doen't work at all

Fri Jul 29, 2016 7:04 pm
The time format not following the system time format has now been fixed, and will be in the KDE Applications 16.08 release.


KAlarm author
djarvie
KDE Developer
Posts
66
Karma
0
OS

Re: Kalarm doen't work at all

Fri Jul 29, 2016 7:07 pm
In relation to alarms not triggering, which desktop are you using (for all the systems affected)? Is it KDE Plasma, or if not, what?


KAlarm author

 
Reply to topic

Bookmarks



Who is online

Registered users: Bing [Bot], Clancularius, Exabot [Bot], Google [Bot], HealthWyze, Majestic-12 [Bot], metzman, nazarnirvana, nocin, schlabs, Sogou [Bot], somescrewslost, TheraHedwig, tosky, vpinon, westin, Yahoo [Bot]