Reply to topic

Gstreamer dependence

User avatar eemantsal
Registered Member
Posts
118
Karma
0
OS

Gstreamer dependence

Wed Jan 13, 2016 1:56 am
First message in this forum, so hi to all. :)

Well, I'm tryng to install Telepathy on my KDE 5/Plasma 5/KF 5/whatever setup, and I see it tries to install several Gstreamer related packages. I use VLC as sound backend, which seems to be the preferred, and my distro -Gentoo- uses as default, so I don't want to install things I don't really need. The "culprit" is Farstream, which depends on Gstreamer. If I install KTP without the farstream tag, said dependencies disappear, but I guess I will not can use audio nor video conference, will I? Is there any way to force Farstream to use VLC and have a fully functional installation?


Cheers.
detrout
Registered Member
Posts
8
Karma
0
OS

Re: Gstreamer dependence

Wed Jan 13, 2016 5:31 am
GStreamer is just being used as a multimedia processing library by telepathy and ktp-call-ui. They should work with whatever KDE backend you're using, and you can set your preferred backend iin the multimedia settings
User avatar eemantsal
Registered Member
Posts
118
Karma
0
OS

Re: Gstreamer dependence

Wed Jan 13, 2016 8:47 pm
detrout wrote:GStreamer is just being used as a multimedia processing library by telepathy and ktp-call-ui. They should work with whatever KDE backend you're using, and you can set your preferred backend iin the multimedia settings


I have installed it without the "farstream" compilation flag, and it seems to "work" but since I've only configured a Telegram account, and the Telegram plugin is at a very early stage -no multimedia at all, not even sending/receiving pictures- I haven't could test if conferences work; I guess they don't for it seems Farstream is unprescindible.
Well, I suppose KTP or PTP, or how it be called now, still needs some work.
Thanks for your help anyway. :)
detrout
Registered Member
Posts
8
Karma
0
OS

Re: Gstreamer dependence

Wed Jan 13, 2016 9:38 pm
Well without the fartsream flag what little KDE Telepathy multimedia support exists wont work at all. As far as I know only SIP and XMPP/Jingle have any hope for working, and that would require ktp-call-ui from git.
User avatar eemantsal
Registered Member
Posts
118
Karma
0
OS

Re: Gstreamer dependence

Wed Jan 13, 2016 11:08 pm
detrout wrote:Well without the fartsream flag what little KDE Telepathy multimedia support exists wont work at all. As far as I know only SIP and XMPP/Jingle have any hope for working, and that would require ktp-call-ui from git.

Oh, I thought it was only needed for conferencing ( http://www.freedesktop.org/wiki/Software/Farstream/ ). So, it seems we need Gstreamer, yes or yes, if we want fully functional chatting in KDE Telepathy. :-\
Thanks again.

 
Reply to topic

Bookmarks



Who is online

Registered users: alfredod, Baidu [Spider], bartoloni, Bing [Bot], boudewijn, Capitain_Jack, capslock, Exabot [Bot], formyfriday, gerdeg, Google [Bot], gui-m, jackdinn, La Ninje, Majestic-12 [Bot], Sogou [Bot], TheraHedwig, Tromzy, vpinon, Yahoo [Bot], zhanxw