Reply to topic

KDevelop issues on Neon

jchambers
Registered Member
Posts
1
Karma
0

KDevelop issues on Neon

Mon Nov 12, 2018 12:04 pm
Anyone else having issues doing an "apt-get upgrade" because of Kdevelop / heaptrack-gui on Neon?

james@james-VirtualBox:~$ uname -a
Linux james-VirtualBox 4.15.0-34-generic #37-Ubuntu SMP Mon Aug 27 15:21:48 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux
james@james-VirtualBox:~$ sudo apt-get upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies.
kdevelop : Depends: heaptrack-gui but it is not installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).
james@james-VirtualBox:~$ sudo apt --fix-broken install
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies...Starting pkgProblemResolver with broken count: 0
Starting 2 pkgProblemResolver with broken count: 0
Done
Done
Starting pkgProblemResolver with broken count: 0
Starting 2 pkgProblemResolver with broken count: 0
Done
The following packages were automatically installed and are no longer required:
discover discover-data libdiscover2 linux-headers-generic-hwe-16.04 linux-image-generic-hwe-16.04
Use 'sudo apt autoremove' to remove them.
The following additional packages will be installed:
heaptrack-gui
The following NEW packages will be installed
heaptrack-gui
0 to upgrade, 1 to newly install, 0 to remove and 367 not to upgrade.
1 not fully installed or removed.
Need to get 0 B/201 kB of archives.
After this operation, 1,017 kB of additional disk space will be used.
Do you want to continue? [Y/n] y
(Reading database ... 219150 files and directories currently installed.)
Preparing to unpack .../heaptrack-gui_1.2.0+p18.04+git20181107.1724-0_amd64.deb ...
Unpacking heaptrack-gui (1.2.0+p18.04+git20181107.1724-0) ...
dpkg: error processing archive /var/cache/apt/archives/heaptrack-gui_1.2.0+p18.04+git20181107.1724-0_amd64.deb (--unpack):
trying to overwrite '/usr/bin/heaptrack_gui', which is also in package heaptrack 1.2.0+p16.04+git20170317.0444-0
dpkg-deb: error: paste subprocess was killed by signal (Broken pipe)
Errors were encountered while processing:
/var/cache/apt/archives/heaptrack-gui_1.2.0+p18.04+git20181107.1724-0_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
james@james-VirtualBox:~$

Suggestions for a fix are very welcome!

Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], bartoloni, bcooksley, Bing [Bot], emilsedgh, Exabot [Bot], Google [Bot], RogueScholar, Sogou [Bot], tburke, Yahoo [Bot]