Reply to topic

Problemas para instalar QGis en KDE neon

sebastian05067
Registered Member
Posts
3
Karma
0
Hola compañeros,

Estuve intentando instalar QGis siguiente las instucciones de esta web https://qgis.org/es/site/forusers/alldownloads.html#debian-ubuntu.

1) Adicioné las siguientes líneas en /etc/apt/sources.list utilizando la configuración como si estuviera instalando en Ubuntu (tengo entendido que KDE neon es derivado de Ubuntu)
Code: Select all
deb     https://qgis.org/ubuntu     bionic main
deb-src https://qgis.org/ubuntu     bionic main


2) Actualicé utilizando:
Code: Select all
sudo aptitude update


3) Con el paso anterior me salia un error, el cual solucioné con el siguiente codigo tal como decia en la guía:
Code: Select all
wget -O - https://qgis.org/downloads/qgis-2017.gpg.key | gpg --importgpg --fingerprint CAEB3DC3BDF7FB45
gpg --export --armor CAEB3DC3BDF7FB45 | sudo apt-key add -


4) Repetí el paso dos y actualizó con normalida

5) Instalé los programas y sus dependencias utilizando este comando
Code: Select all
sudo apt-get install qgis python-qgis qgis-plugin-grass


6) La consola me da el siguiente error:
Code: Select all
Los siguientes paquetes tienen dependencias incumplidas:
 qgis : Depende: qgis-providers (= 1:3.4.0+28bionic) pero no va a instalarse
E: No se pudieron corregir los problemas, usted ha retenido paquetes rotos.


7) Luego intento instalar qgis-providers con
Code: Select all
sudo aptitude install qgis-providers


8) Con el paso anterior me da el siguiente error:
Code: Select all
No se satisfacen las dependencias de los siguientes paquetes:
 qgis-providers : Depende: qtbase-abi-5-9-5 el cual es un paquete virtual, proporcionado por:
                           - libqt5core5a (5.9.5+dfsg-0ubuntu1), pero 5.11.2+dfsg-0xneon+18.04+bionic+build47 está instalado


9) Intenté instalar libqt5core5a pero me dice: libqt5core5a ya está instalado en la versión solicitada (5.11.2+dfsg-0xneon+18.04+bionic+build47)

Alguna idea de como solucionar el problema? o es que KDE no es compatible con QGIS aunque en la página dice que se puede instalar en Ubuntu?

Saludos y gracias.

Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], Google [Bot], lueck, Majestic-12 [Bot], uyenb, Yahoo [Bot]