Reply to topic

Importing Persons from KAdressbook

User avatar ripper17
Registered Member
Posts
46
Karma
0
OS

Importing Persons from KAdressbook

Fri Mar 06, 2015 10:47 pm
Hi all,

I've had a look at the sourcecode from digikam and though I'm not even close of thinking I know what's going on, it seems like there is a section that is supposed to work wirh Akonadi and import the Persons that I have in KAdressbook / Kontact. Unfortunately the Person list is empty in digikam.

I'd love to use the persons from my adressbook to tag the photographs accordingly without having to re-enter all Persons in digikam. Is this a setup error? Do I need to enable something?
I'm running openSUSE 13.2 with digikam 4.6 (and I've tried installing 4.8 from OBS but the situation did not improve: no persons where imported). I asked on the openSUSE channel quite some time ago and they said that they are building digikam with akonadi-support, so it should be fine from that point of view.


openSUSE 13.2 x64, Platform Version 4.14.X, Kubuntu 14.04 (LTS), Platform Version 4.13.X
User avatar google01103
Manager
Posts
6668
Karma
25
Seems to work for me using the right panel -> Tags -> Captions/Tags, but strangely not from within the Tag Manager (even though there is a "Create Tag From Address Book" menu item). I don't do pics let alone tags so I can't offer any additional info

Image


OpenSuse Leap 42.1 x64, Plasma 5.x

User avatar ripper17
Registered Member
Posts
46
Karma
0
OS
Very strange :-)

Here's what I'm getting: when using the left panel (called "Personen" in the German version, so I guess "Persons" in English) there's only one person: "Unknown" (probably a dummy entry). If I'm trying to import a person (as can be seen in your screenshot, "Create Tag From AddressBook") I'm only getting "No address book entries found" (in English, there seems to be a missing translation, but that's really not important to me :-) )
On the right panel (Captions/Tags) I'm getting the exact same behaviour. The tag is also called "Personen" in German - not "names" (that would translate to "Namen" in German). Note that in both cases the Icon next to "Persons" is not the Kontact/KMail icon as in your screenshot but rather an icon that looks a bit like an empty clip-board - the "New Tag"-icon from your screenshot without the yellow star.

Did you do anything with your KAddressbook (sharing, public readable or something like that) or did you change some digikam setting? I'm guessing not, since you're not really using digikam/tags :-)


openSUSE 13.2 x64, Platform Version 4.14.X, Kubuntu 14.04 (LTS), Platform Version 4.13.X
User avatar google01103
Manager
Posts
6668
Karma
25
I did nothing special with Digikam (it was first time I played with Tags)

as to my contacts in my Akonadi resources I have 2 - Personal and Google (Personal is just a test entry) and the contacts from both resources show in Digikam.

I would suggest testing as a new user, maybe its a configuration issue

Another thing a bit different in my setup is that Kontacts was set up and populated this past October so that part is pretty new


OpenSuse Leap 42.1 x64, Plasma 5.x

User avatar ripper17
Registered Member
Posts
46
Karma
0
OS
Thanks for your ideas and input!

Unfortunately, even as a new user, I was not able to see any entries from my (freshly created, personal) addressbook in digikam. I also had to "add" a face-region first to one image in order for the tag "Persons" to show up at all.
Are you using the version from the "official" repos? According to our signature, you're on openSUSE 13.2, too (like me) so this is really weird. Are you using your system "in English"? Because mine is set to "German" and I'm starting to wondering if there could be a strange character encoding issue (or something similar). The new user, however, as well as my normal user name do not contain any special characters, and I also tried renaming the Personal addressbook to something without "Umlauts".
Neither the personal, nor the contacts from my Kolab-resource show up in digikam.


openSUSE 13.2 x64, Platform Version 4.14.X, Kubuntu 14.04 (LTS), Platform Version 4.13.X
User avatar google01103
Manager
Posts
6668
Karma
25
Nothing really unusual about my setup:
- Digikam and Kipi pkgs are from the KDE Extra repo
- Kontact is from the Updates repo

as Digikam tends to have its own support structure try irc #digikam or the mailing list https://mail.kde.org/mailman/listinfo/digikam-users


OpenSuse Leap 42.1 x64, Plasma 5.x

User avatar ripper17
Registered Member
Posts
46
Karma
0
OS
Ha, KDE:Extra has 4.8.0 while I was on 4.6.0 - in 4.8.0 it works, so I'm happy now :-)

Thanks for pointing it out, tittiatcoke @irc (#digikam)!


openSUSE 13.2 x64, Platform Version 4.14.X, Kubuntu 14.04 (LTS), Platform Version 4.13.X

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], Exabot [Bot], Google [Bot], hotzek, Sogou [Bot], Yahoo [Bot]