Reply to topic

Autostarted korganizer doesn't start akonadi server

Khym Chanur
Registered Member
Posts
17
Karma
0
OS
In ~/.config/autostart I have a korganizer.desktop file to start korganizer when I log in. However, korganizer always starts before akonadi is ready and tells me it can't do anything. Is there any way to delay korganizer until akonadi is ready?

If korganizer is started via a desktop entry in ~/.config/autostart then it won't automatically start akonadi, but it will automatically start akonadi is manually started.

Last edited by Khym Chanur on Sun Jan 03, 2016 3:11 pm, edited 1 time in total.
User avatar google01103
Manager
Posts
6668
Karma
25
you can try adding a delay with the sleep command

Code: Select all
sleep 20 && korganizer


other option would be to write a script that tests that Akonadi is up and running before starting Korkanizer, guessing you would test for akonadiserver running


OpenSuse Leap 42.1 x64, Plasma 5.x

Khym Chanur
Registered Member
Posts
17
Karma
0
OS
It seems that the korganizer.desktop file I was using for autostart was manually created and had something wrong with it (I can't remember why I did that). Replacing that with a soft link to /usr/share/applications/kde4/korganizer.desktop fixed the problem.

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], bartoloni, Bing [Bot], blogthetech, boudewijn, Google [Bot], gui-m, ipwizard, ramskulls, skylerjett, Sogou [Bot], YaCy [Bot]