Reply to topic

[BUG FILED] Start week on Monday

User avatar sparhawk
Registered Member
Posts
413
Karma
0
OS

[BUG FILED] Start week on Monday

Sat Jan 16, 2016 1:01 am
In week and month views, how can I start the week on a Monday? I seem to remember being able to change this in a previous version (a few months ago). However, I cannot find it in the settings any more.

Up-to-date Arch Linux
korganizer 15.12.1

Last edited by sparhawk on Sun Jan 17, 2016 2:57 am, edited 1 time in total.
User avatar google01103
Manager
Posts
6668
Karma
25

Re: Start week on Monday

Sat Jan 16, 2016 1:47 am
in KDE 4 was in systemsettings -> country/region & language -> calendar

I think it is this bug https://bugs.kde.org/show_bug.cgi?id=345378#c8


OpenSuse Leap 42.1 x64, Plasma 5.x

User avatar sparhawk
Registered Member
Posts
413
Karma
0
OS

Re: Start week on Monday

Sat Jan 16, 2016 2:17 am
Thanks google01103. However, I'm fairly sure that I had the option in Plasma 5 a month ago, or at least it was enabled by default. That linked bug seems related, but its fix was to provide the option in the time plasmoid, so I might just have to file a new one.

Is there another way to make this work in the meantime? Perhaps some config file?
User avatar google01103
Manager
Posts
6668
Karma
25

Re: Start week on Monday

Sat Jan 16, 2016 10:18 am
no idea, just started to actually use Plasma 5 this week, did note that 24 hr clock (referenced in the mentioned bug) is an option in digital clock settings (but not in analog clock so it might be plasmoid specific)

in KDE 4 the setting was it seems to be in ~/.kde[4]/share/apps/kdeglobals in the following section
Code: Select all
[Locale]
DateFormat=%a, %b %d
Language=en_US
WeekStartDay=1


but adding that section for me didn't fix it in Plasma 5


OpenSuse Leap 42.1 x64, Plasma 5.x

User avatar sparhawk
Registered Member
Posts
413
Karma
0
OS

Re: Start week on Monday

Sun Jan 17, 2016 2:56 am
Okay, thanks again. I've filed a bug.
User avatar sparhawk
Registered Member
Posts
413
Karma
0
OS
This is driving me crazy! I missed an appointment the other day, because I looked at the first column in week view, and presumed that it was Monday, not Sunday!

In the current Korganizer (5.1.1), when I select "Settings" > "Configure Date & Time…", it takes me to a pretty limited configuration page, which is identical to "System Settings" > "Regional Setttings".

I had a look at an old Korganizer install (4.14.10) that I had in a Virtual environment. When I select "Settings" > "Configure Date & Time…", it takes me to a much more configurable page named "Country/Region & Language". Here, in the "Calendar" tab, I could select what day the week started on.

Image

I couldn't find how to access to this page in either install, through System Settings. Is there another way to access this in the current Plasma?

EDIT
I also found a file at `~/.config/kdeglobals` and added the following, but that didn't work.
Code: Select all
[Locale]
WeekStartDay=1


I also grepped through ~/.config for "weekstartday", but couldn't find anything.
User avatar sparhawk
Registered Member
Posts
413
Karma
0
OS
I'll just bump this once, in case this is fixable through a config file. Otherwise, I'll have to go back to evolution. Missing appointments makes korganizer too dangerous for me! (Evolution has a bug where it freezes for 5–10 seconds after I modify an event, but that's less risky than this!)
User avatar sparhawk
Registered Member
Posts
413
Karma
0
OS
I've just noticed details of my locale.

Code: Select all
$ locale -ck LC_TIME
...
first_weekday=1
first_workday=2
...
$ locale
...
LC_TIME=en_AU.UTF-8
...


I messed around in `/usr/share/i18n/locales`, attempting to add `first_weekday 2` to the `LC_TIME` section, then restarting. However, this didn't seem to work. I tried to set LC_TIME to `en_GB.UTF-8` (via Plasma's System Settings > Personalisation > Regional Settings > Formats > Detailed Settings > Time), and this now makes the week start on a Monday!

However, one issue now is that time is 24 hours, instead of 12 hours (as it was in en_AU). Is there a way to propagate changes made in `/usr/share/i18n/locales` into Plasma's system settings? I also can't seem to see all the locales in the GUI, for example `en_DK` aka "Denmark - English" (which also has `first_weekday 2`) appears to be missing.

==EDIT==
More troubleshooting… I forgot to do `sudo locale-gen`, so I did this and restarted. Now the command line agrees that everything is correct.

Code: Select all
$ locale -ck LC_TIME
...
first_weekday=2
first_workday=2


And `cal` now shows Monday first. However, korganizer does not! It seems that korganizer is not reading the format from /usr/share/i18n/locales/en_AU for some reason. Do I need to reload it, or is it reading from somewhere else?

==EDIT2==
This is more of a system configuration question now with the locale, so I'm going to move this part of the question to a new post.

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], chaos42, Google [Bot], Majestic-12 [Bot], msdobrescu, zynex