Reply to topic

100% CPU usage when playing 1080p videos

goog
Registered Member
Posts
20
Karma
0
Hello all, I've been using KdeNlive for some time now with my older Sony handy cam and am loving it. Made my first Christmas DVD for family and sent it around already....

I purchased a new camcorder (Canon Vixia HF G10) and am recording it as AVCHD 1080P 24 fps. I can play these .mts files in other programs no problems (totem, vlc and also mplayer with vdpau enabled), but I am unable to play them in KdeNlive 0.8.3. The CPU usage for one core (kdenlive process) goes to 100% and the video does not play back. KdeNlive seems to hang for about 20-30 seconds and then the cpu usage drops. Even if I click in the video track area to position the cursor to an earlier point in the video, the CPU usage goes back to 100% and seems to hang for 20 secs or so. I do hear some audio, but video doesn't play, even though I do see whatever particular frame I happen to have clicked on last.

I am using Ubuntu 11.10 and am playing with a 5 sec video clip, recorded as 1080p 24 fps. I am using the pre-defined profile 1080p 23.98fps. I have tried disabling compiz and running the Ubuntu 2D profile. i have verified that vdpau is enabled and working with mplayer. My computer is an AMD phenom x4 965, 8 GB ram and Asus GTX 560 nvidia video card.

I would greatly appreciate any help, or links to further reading. I have to admit I am a newbie and hope I missed something simple, but I have been at this for many hours now and am not sure what else to try.

When I import an MTS file I get a reminder dialog that my clip does not match current profile. my clip size is 1920x1088, 23.9808 fps. Is this part of the problem?

Thanks in advance.

Goog
FishB8
Registered Member
Posts
53
Karma
0
It would be much easier to provide help if you made a small video sample available.


All 1080p video is shot at 1920x1088, but a marker is set to indicate that 8 pixels are to be cut off during the decode process. Either kdenlive is not reading the file correctly, or the camera fails to properly set that marker flag. (1088 is used because with this type of codec, the frame sizes that are encoded have to be multiples of 16)
moorsey
Registered Member
Posts
149
Karma
0
I think all what you mention is pretty normal for Kdenlive. I cannot play 1080 mts files properly in kdenlive either and I have a very good machine. Or maybe I have the same issue that FishB8 suggested!

You might want to try using proxy clips to work around this, start a new project, select the proxy clip option and that you want clips created for files over xxx resolution, OK on that screen and then add your files.

I use this to great success
Inprogress
Registered Member
Posts
9
Karma
0
There has been quite some discussion around this MTS format on two other forums specifically from Panasonic GH2 users. What you might want to try is batch transcode the MTS files to MP4 format (some even go for .mov) - I used Handbrake since it works and at the time I wasn't up for learning ffmpeg UI or terminal commands. Then I would try the proxy way to lessen strain on your pc even more - on that though, with 8.2.0 going the proxy way crashed.

Anyway, MTS is a relatively new format (please, I said relatively) and many editing software (including professional versions) are only now starting to integrate the codec as standard.
goog
Registered Member
Posts
20
Karma
0
OK, I'll upload a sample video. Will look for a site later tonight.

I've had great success with kdenlive and .mts video files from a panasonic digital camera, though they are 720 res.

I can get the video to "play", just not usable. Hoping I can get this working...
goog
Registered Member
Posts
20
Karma
0
First time sharing something through Ubuntu one...I think it works...

http://ubuntuone.com/1WC75P5gZI4mFRa3Pf5zFo

It's a 5 sec clip zipped up in the original folder structure.

Thanks for helping out...
normcross
Registered Member
Posts
300
Karma
0
Hi,

Just loaded your raw .MTS clip into Kdenlive and accepted the change in settings (different to my default). Created a Proxy and dragged it to the timeline. It played perfectly. Dragged another copy to the timeline and created a massive dissolve. It played through without a single stutter.

Now finish your breakfast.:)

I am using Kdenlive 8.3+ - Sunab's latest "BEWARE!" download.

Are you using Proxy clips as moorsey suggests? I would not waste my time trying to play .MTS clips without Proxy. It's a nightmare.

I did notice a problem with the clip monitor not showing the clip, but I noticed this yesterday. If you select Clip Properties it suddenly appears. This is a different issue though.
goog
Registered Member
Posts
20
Karma
0
Thanks a bunch, great news that it works, I'll look into the proxies..
goog
Registered Member
Posts
20
Karma
0
Proxies did not help me for this, as well as upgrading to the 8.4.3 sunab version. Problem still persisted. I remembered I had changed the threads options under settings > environment. I changed concurrent threads back to one (was at 4) and under MLT environment processing threads back to one (was at 3). Playback is perfectly normal now.

Thanks for everyone's help..
normcross
Registered Member
Posts
300
Karma
0
Yes, I had forgotten this one. I discovered this quite some time ago.

Important note to new users :- For the time being, leave these settings at their default positions.

Cheers

EDIT: Just checked, You can change the proxy threading, this works fine. I usually do three or four at a time. I like to leave one core free. :)

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], Google [Bot], jumpropethrowaway, markhm, valaquarus