Reply to topic

Transitions Weirdly Being Duplicated

smokinglizard
Registered Member
Posts
16
Karma
0
Well this is frustrating...and weird.

For some reason, when you select many clips at once and then move them at once, if the clips have transitions on them, Kdenlive duplicates the transitions and sticks them seemingly at random places along the timeline.

Anyone seen this before? Anyone have a work-around?
smokinglizard
Registered Member
Posts
16
Karma
0
OK...I got no replies to this thread but I figured out a solution and decided to post it here just in case someone else can benefit from it.

Turns out what I was doing was stupid. I was moving clips and transitions using the "hold down the CTRL key and then drag the mouse to select a bunch of stuff" method. Stupid. Do NOT do this. Kdenlive has a built-in "move" or "spacer" tool or whatever it's called. Just press the M key and your mouse icon will change to an arrow pointing right. Click the mouse and drag. Everything to the right of the click position will now nicely move as you move the mouse.

This is a much better and elegant solution than what I was doing. They should probably fix or remove the drag-and-select method, as it's obviously broken.

I'm so happy I figured out the move tool thing. Makes editing a snap when you have to insert something into a very complex timeline. Wow, I was dumb.
User avatar sammuirhead
Registered Member
Posts
52
Karma
0
OS
well, I wouldn't suggest that the shift click + drag function be removed - it's very useful in many situations, just grabbing a couple of clips in the middle of a sequence for example.
But yes, the spacer tool is certainly more suited to what you're doing. These weird effects seem to pop up a lot when moving multiple clips around - similar issues here (viewtopic.php?f=265&t=113126) and here (viewtopic.php?f=265&t=114502)


User avatar sammuirhead
Registered Member
Posts
52
Karma
0
OS
(the only workaround I've found is to restart kdenlive the moment I see any strange activity... things only get worse once you get one misbehaving transition or 'unable to move clip' issue)



 
Reply to topic

Bookmarks



Who is online

Registered users: AGB, Azzart, Baidu [Spider], Bing [Bot], Bingy, colomar, Exabot [Bot], garthecho, Google [Bot], google01103, GreatEmerald, jensreuterberg, jstaniek, kainz.a, koriun, Kver, La Ninje, lazyit, Majestic-12 [Bot], MSN [Bot], Nuc!eoN, psbot [Picsearch], rulet111, scummos, SecretCode, Tuukka, undoshmulhe, Uri_Herrera, Yahoo [Bot]