Reply to topic

Crash on pressing render button

pfong
Registered Member
Posts
18
Karma
0

Crash on pressing render button

Tue Sep 24, 2013 1:35 am
I've been using Kdenlive and rendering fine. Suddenly whenever I click the render button Kdenlive crashes.
This is similar to bug http://www.kdenlive.org/mantis/view.php?id=2861 but that was fixed in 0.9.4. I'm using 0.9.6. Also, the workaround of creating a new project with the "hdv 1440x1080i 25 fps" doesn't work. It still crashes.

It could also be bug http://www.kdenlive.org/mantis/view.php?id=2662. There's no tips on how to proceed though. Any ideas?

I'm using Kdenlive 0.9.6 on Ubuntu 12.10 with melt 0.8.8.

Last edited by ttguy on Tue Sep 24, 2013 9:49 am, edited 1 time in total.
Reason: bug numbers need to link to http://www.kdenlive.org/mantis
pfong
Registered Member
Posts
18
Karma
0

Re: Crash on pressing render button

Tue Sep 24, 2013 4:59 pm
I've tried downgrading to Kdenlive 0.9.2 and melt, libmlt5, libmlt-data 0.8.0-4. These are the versions in the Ubuntu Quantal repositories.
It still crashes. The crash report shows it's a floating point exception which makes me lean towards Bug #2662.

Any ideas? This makes Kdenlive useless.
Can I generate the script to render without opening the render dialog box somehow?
alex00
Registered Member
Posts
22
Karma
0

Re: Crash on pressing render button

Wed Sep 25, 2013 3:00 pm
Hi,
I had the same problem due to a corrupted project file.
I solved the problem by opening the project with an older version of kdenlive (0.8) - some things lost, but after reworked on the project rendering worked well.
User avatar GlennJerome
Registered Member
Posts
21
Karma
0
OS

Re: Crash on pressing render button

Wed Sep 25, 2013 3:53 pm
Try running kdenlive or kdenlive_render in a shell and see it they generate errors.
pfong
Registered Member
Posts
18
Karma
0

Re: Crash on pressing render button

Wed Sep 25, 2013 5:16 pm
Kdenlive crashes even if I start up and use the default profile or create a new project using the HDV 25 fps profile (workaround for bug 2861). So, I don't think it is related to my project file.

When run at the command line when I press render, it prints:
KCrash: Application 'kdenlive' crashing...
KCrash: Attempting to start /usr/lib/kde4/libexec/drkonqi from kdeinit
sock_file=/home/pfong/.kde/socket-ir-pftp/kdeinit4__0

What commandline do I use with kdenlive_render? I don't understand it's commandline parameters. Without any parameters it just prints it's help message.

I'm wondering if the custom render profile that I created is causing problems. Where are these stored? Can I reset this somehow?
User avatar GlennJerome
Registered Member
Posts
21
Karma
0
OS

Re: Crash on pressing render button

Wed Sep 25, 2013 8:26 pm
Hi pfong,

That KCrash error looks serious and like something in the KDE configuration is messed up. In the meanwhile maybe this work-a-round will help.

PRO TIP: Render Kdenlive Projects in Openshot

The video is over 18 months old and I haven't tried it myself but it sounds plausible. I hope this helps.

Glenn



pfong wrote:Kdenlive crashes even if I start up and use the default profile or create a new project using the HDV 25 fps profile (workaround for bug 2861). So, I don't think it is related to my project file.

When run at the command line when I press render, it prints:
KCrash: Application 'kdenlive' crashing...
KCrash: Attempting to start /usr/lib/kde4/libexec/drkonqi from kdeinit
sock_file=/home/pfong/.kde/socket-ir-pftp/kdeinit4__0

What commandline do I use with kdenlive_render? I don't understand it's commandline parameters. Without any parameters it just prints it's help message.

I'm wondering if the custom render profile that I created is causing problems. Where are these stored? Can I reset this somehow?
pfong
Registered Member
Posts
18
Karma
0

Re: Crash on pressing render button

Fri Sep 27, 2013 7:03 pm
Luckily I had generated a rendering script. Using the script to render works fine. This means kdenlive_render works fine. This is my work around to avoid using the render dialog.

Generating this script was the last successfully thing I did with the render dialog. I wonder if that's related.
pfong
Registered Member
Posts
18
Karma
0

Re: Crash on pressing render button

Tue Dec 31, 2013 7:17 pm
I just tried to work on a new project. Unfortunately, Kdenlive still crashes when I open the render dialog and I cannot use the render script I generated for the other project. I just get a video that says "INVALID".

I have found that when I run Kdenlive in a newly created user account, it does not crash when I open the render dialog. How do I reset the settings in my account? I've tried removing the .kde directory in my home directory and logging out and back in. The makes Kdenlive do the setup wizard again but it still crashes. What other files do I need to remove?
User avatar Steve Guilford
Registered Member
Posts
40
Karma
0

Re: Crash on pressing render button

Wed Jan 01, 2014 1:29 am
pfong wrote:I just tried to work on a new project. Unfortunately, Kdenlive still crashes when I open the render dialog and I cannot use the render script I generated for the other project. I just get a video that says "INVALID".

I have found that when I run Kdenlive in a newly created user account, it does not crash when I open the render dialog. How do I reset the settings in my account? I've tried removing the .kde directory in my home directory and logging out and back in. The makes Kdenlive do the setup wizard again but it still crashes. What other files do I need to remove?


Does the render screen come up at all?

We need more clues. Try this:
    Create a project
    Add a color clip to the project
    Add the color clip to the timeline
    Save the project
    Hit the render button.
User avatar bcooksley
Administrator
Posts
18556
Karma
83
OS

Re: Crash on pressing render button

Wed Jan 01, 2014 1:38 am
As Kdenlive uses the Melt / MLT framework looking for ~/.melt or ~/.mlt would be a good start, followed by files named "mlt" or "melt" below ~/.config or ~/.local.


System Settings and Device Actions KCM maintainer
Image
pfong
Registered Member
Posts
18
Karma
0

Re: Crash on pressing render button

Thu Jan 02, 2014 11:29 pm
Steve Guilford wrote:Does the render screen come up at all?

We need more clues. Try this:
    Create a project
    Add a color clip to the project
    Add the color clip to the timeline
    Save the project
    Hit the render button.


It crashes as soon as I press ctrl-r or click on the render button. I do not see the render dialog.

I tried:
1. Open kdenlive
2. Blank project is already there.
3. Add color clip
4. Add to timeline
5. Press render button. Crash.

It also crashes if I leave out steps 3 and 4.
pfong
Registered Member
Posts
18
Karma
0

Re: Crash on pressing render button

Thu Jan 02, 2014 11:33 pm
bcooksley wrote:As Kdenlive uses the Melt / MLT framework looking for ~/.melt or ~/.mlt would be a good start, followed by files named "mlt" or "melt" below ~/.config or ~/.local.


I did not find ~/.mlt or ~/.melt or any files with mlt or melt in the name under ~/.config or ~/.local. E.g. find .config/ -name "*mlt*" returns nothing.
User avatar bcooksley
Administrator
Posts
18556
Karma
83
OS

Re: Crash on pressing render button

Fri Jan 03, 2014 9:29 pm
I would suggest running Kdenlive under strace to determine the configuration files and other user specific data it is accessing.
Also, please verify that ~/.kde is the prefix used by KDE for user specific data, by running "kde4-config --localprefix" as it could be using ~/.kde4.


System Settings and Device Actions KCM maintainer
Image
User avatar Steve Guilford
Registered Member
Posts
40
Karma
0

Re: Crash on pressing render button

Sat Jan 04, 2014 1:19 am
pfong wrote:It crashes as soon as I press ctrl-r or click on the render button. I do not see the render dialog.

I tried:
1. Open kdenlive
2. Blank project is already there.
3. Add color clip
4. Add to timeline
5. Press render button. Crash.

It also crashes if I leave out steps 3 and 4.

Well, it's either in MainWindow::slotRenderProject() or within the RenderWidget::RenderWidget constructor which is called by slotRenderProject.

One of the possibly suspect lines within slotRenderProject could be:

QString projectfolder = m_activeDocument ? m_activeDocument->projectFolder().path(KUrl::AddTrailingSlash) : KdenliveSettings::defaultprojectfolder();

If your project folder or default project folder is buggered up this line may segfault out. Take a look and see if your project directory is valid when Kdenlive is running and upon it's settings page.

If you're adventurous you can gen up a freshly compiled copy of Kdenlive. Follow the instructions here http://www.kdenlive.org/user-manual/downloading-and-installing-kdenlive/installing-source under the section labeled Build Script to do so. Then, try to reproduce the problem w/ the freshly compiled version of Kdenlive. If the problem persists then we can add qDebug() statements to the aforementioned routines to narrow down the location of the error.
pfong
Registered Member
Posts
18
Karma
0

Re: Crash on pressing render button

Mon Jan 06, 2014 9:09 pm
"kde4-config --localprefix" confirms that the kde prefix is .kde

I posted my .kcrash in bug 2662. The backtrace does show it crashes in something the RenderWidget::RenderWidget constructor calls.

How do I see what the project directory is? The crash happens even if I load an existing project. Does it use the location of the project file as the project directory?

 
Reply to topic

Bookmarks



Who is online

Registered users: AGB, Azzart, Baidu [Spider], Bing [Bot], Bingy, colomar, Exabot [Bot], garthecho, Google [Bot], google01103, GreatEmerald, jensreuterberg, jstaniek, kainz.a, koriun, Kver, La Ninje, lazyit, Majestic-12 [Bot], MSN [Bot], Nuc!eoN, psbot [Picsearch], rulet111, scummos, SecretCode, Tuukka, undoshmulhe, Uri_Herrera, Yahoo [Bot]