Reply to topic

Stuttering during playback with 1080p video

User avatar Ranko Kohime
Registered Member
Posts
32
Karma
0
OS
I'm experiencing stuttering while previewing either a 1080p clip, or the timeline with a 1080p clip in it. For reference, these clips are avi-format video game recordings made with Fraps. My Googling has answered that this is an issue with Melt, BUT, I can trick the system into getting smooth playback, so it must be powerful enough. (Kdenlive uses about 80% of one CPU core while previewing)

The conditions under which it will NOT stutter, is if I have previously watched a segment, rewinded, and now with that segment of the clip already loaded into RAM, I watch it again, it will not stutter. This is not a drive issue, as the drive is used for recording, and playback of the avi in VLC on either Windows or Linux is quite doable without any stuttering.

Using a Ramdisk for the clip is not an option, as I have 8GB of RAM, and these clips are frequently 30-60GB in size. So, is there anything that I can tweak to alleviate this issue?
normcross
Registered Member
Posts
284
Karma
0
Most video editors will find it difficult to process and play HD video on a lower spec machine. So, Kdenlive uses a "Proxy"clip. Right click on the clip in the Project Tree, scroll down and select "Proxy. Kdenlive will render a low resolution copy of your clip which can be used from then on. When you finally render, it will render with the original HD clips.

If you find the proxy clip resolution too low, it can changed.
User avatar Ranko Kohime
Registered Member
Posts
32
Karma
0
OS
normcross wrote:Most video editors will find it difficult to process and play HD video on a lower spec machine. So, Kdenlive uses a "Proxy"clip. Right click on the clip in the Project Tree, scroll down and select "Proxy. Kdenlive will render a low resolution copy of your clip which can be used from then on. When you finally render, it will render with the original HD clips.

If you find the proxy clip resolution too low, it can changed.

Hmm... The Proxy Clip option seems to be greyed out when I right-click on my avi file...
User avatar GlennJerome
Registered Member
Posts
21
Karma
0
OS
>Project>Project Settings

Tick Proxy Clips
Tick Generate Proxy clips for videos larger than

I didn't like the resolution for my 1080i videos so I created a new proxy encoding profile

>Setting>Configure Kdenlive>Project Defaults> Encoding Profile (click the wrench)
Click the plus the + to create a new profile. I called mine MPEG 720x480. These are the setting I used.

Code: Select all
-f mpegts -acodec libmp3lame -ac 2 -ab 160k -ar 48000 -vcodec mpeg2video -g 5 -deinterlace -s 720x480 -vb 800k
User avatar Ranko Kohime
Registered Member
Posts
32
Karma
0
OS
GlennJerome wrote:>Project>Project Settings

Ahh, that worked! Thank you. ;D

 
Reply to topic

Bookmarks



Who is online

Registered users: alake, Alexa [Bot], Baidu [Spider], Bing [Bot], blue_bullet, chicken2jail, claydoh, colomar, Exabot [Bot], garthecho, ghevan, Google [Bot], google01103, Hans, inhiway, kainz.a, koriun, La Ninje, lazyit, Majestic-12 [Bot], mmistretta, nezumi, pedrorodriguez, private_lock, robinh, scummos, Tuukka, urgo, Uri_Herrera, wolfi323, Yahoo [Bot]