Reply to topic

Composites Resizing After Changing Project Size?

smokinglizard
Registered Member
Posts
16
Karma
0
Help!

This is weird.

I have a project that I originally rendered as 1080p. I have a customer who wants it at 720p. So I so, OK, no problem. I just went in to Kdenlive and saved a copy of the project, then changed the project settings to 720p and re-render, right?

Well, oddly, when I change project settings from 1080p to 720p, Kdenlive changes the size (not the duration) of my composites to 150%! What the heck?!

Anyone know what's going on and how I stop this from happening?

Thanks...Norm
User avatar TheDiveO
Registered Member
Posts
150
Karma
0
Tripped on this also quite some time ago, as far as I remember this is a "feature" for more than two years now. I got it the other way round when I switched a project from 720p to 1080p and then had to touch all the composite transitions. I never found a way to avoid this.


TheDiveO on YouTube: diving videos and aerial (quadcopter) videos, all made with Kdenlive.
TheDiveO Blog: know-how about Protune-grading in Kdenlive, GoPro HD Hero 3, DJI Phantom Quadcopter, full face mask diving, and some more...
capslock
Registered Member
Posts
290
Karma
0
OS
You can render your 1080p project to 720p (and any other format or size) without creating a new project. You will also find a resize option in the render dialog.
klaatu
Registered Member
Posts
13
Karma
0
I would not change the project settings itself; you still want your source to be in the original format. Ergo, if you shot in 1080p then work in 1080p.

Simply render it from native 1080p to 720p in the Render dialogue window, or else export full 1080p in some lossless format such as HuffYUV or similar and then down-size with ffmpeg or similar.

Changing project settings is usually not something an NLE expects you to do unless you are using proxy media. If you think about it, "changing" the composite sizes to 150% isn't exactly what happened; the composites stayed the same, it's just that their point of reference shrunk.

You should be able to re-size your composites back to 100% by going into their settings and reducing the size, and then copying and pasting that attribute onto all other composites. But it just seems the wrong way to go about it to me.

 
Reply to topic

Bookmarks



Who is online

Registered users: apater, areid, Baidu [Spider], Bing [Bot], braystacey, edmael, einar, Exabot [Bot], garthecho, Google [Bot], google01103, ivan, jensreuterberg, joaob, jpwhiting, jstaniek, La Ninje, lazyit, Majestic-12 [Bot], mmistretta, MSN [Bot], pedrorodriguez, salvochea, scottpetrovic, scummos, SeaJey, SecretCode, slangkamp, slawekk, Sogou [Bot], SysGhost, TheraHedwig, tienhung, Tioz, VP1986, Yahoo [Bot], šumski