Reply to topic

Shortcuts stopped working

kardn
Registered Member
Posts
12
Karma
0

Shortcuts stopped working

Sat Feb 08, 2014 3:42 pm
Up until now I have been a happy and proud user of kdenlive for well over a year. And everything worked just fine yesterday when I closed the program. Today, however, for some reason all the shortcuts inside the program do not respond. Ctrl+R, Ctrl+Z, doesn't matter which. I tried removing and installing the program, but it didn't fix the issue. Does anyone have any idea what could be wrong? As far as I know nothing changed between yesterday and today... Any help is appreciated. Thanks in advance.
User avatar Steve Guilford
Registered Member
Posts
46
Karma
0

Re: Shortcuts stopped working

Sat Feb 08, 2014 4:51 pm
kardn wrote:Up until now I have been a happy and proud user of kdenlive for well over a year. And everything worked just fine yesterday when I closed the program. Today, however, for some reason all the shortcuts inside the program do not respond. Ctrl+R, Ctrl+Z, doesn't matter which. I tried removing and installing the program, but it didn't fix the issue. Does anyone have any idea what could be wrong? As far as I know nothing changed between yesterday and today... Any help is appreciated. Thanks in advance.


Sounds like your keyboard definition/setup got scrambled.

Did you do anything that could have altered the keyboard setup in any way?

Do you notice the same problem in other programs?

Try rebooting your machine.
kardn
Registered Member
Posts
12
Karma
0

Re: Shortcuts stopped working

Sat Feb 08, 2014 5:25 pm
Rebooting didn't work. So far I haven't seen this problem in other programs, only in kdenlive. As for what I did... The only thing I can think of is opening the zorg file, but I closed it without making any changes.
User avatar Steve Guilford
Registered Member
Posts
46
Karma
0

Re: Shortcuts stopped working

Sat Feb 08, 2014 9:26 pm
kardn wrote:Rebooting didn't work. So far I haven't seen this problem in other programs, only in kdenlive. As for what I did... The only thing I can think of is opening the zorg file, but I closed it without making any changes.


What's a 'zorg' file?

Do normal shortcut keys like alt-f4, alt-f etc. work? How about copy and paste w/ ctrl-c/v?

Go to Settings->Configure Shortcuts. Does everything look correct? You can try the restore defaults button. Test the shortcuts listed on this page.
kardn
Registered Member
Posts
12
Karma
0

Re: Shortcuts stopped working

Sat Feb 08, 2014 9:39 pm
/etc/x11/zorg.conf

None of the shortcuts work (except Alt+F4) even copy/paste. Not sure what Alt+F is supposed to do, but nothing happens. Everything in the settings is fine, I have never touched the defaults, but I restored them anyway. Still no luck.
capslock
Registered Member
Posts
290
Karma
0
OS

Re: Shortcuts stopped working

Sat Feb 08, 2014 10:09 pm
Between closing a working kdenlive and opening a wrecked up one - did you install any updates to your system? If yes, they might be the case. If you think updates are not the reason, you can try to delete the kdenlive config file ~/.kde4/share/config/kdenliverc and start kdenlive.
kardn
Registered Member
Posts
12
Karma
0

Re: Shortcuts stopped working

Sun Feb 09, 2014 12:21 pm
No, I haven't installed any updates. I did install some, but that was while kdenlive was still working. Just in case, how can I see what was installed and possibly remove it?

Also, I tried deleting the config file, but nothing changes.
User avatar Steve Guilford
Registered Member
Posts
46
Karma
0

Re: Shortcuts stopped working

Sun Feb 09, 2014 5:48 pm
kardn wrote:No, I haven't installed any updates. I did install some, but that was while kdenlive was still working. Just in case, how can I see what was installed and possibly remove it?

Also, I tried deleting the config file, but nothing changes.


We need to eliminate any user-setup variables. Create a new Linux user and try running KdenLive under that user account.
kardn
Registered Member
Posts
12
Karma
0

Re: Shortcuts stopped working

Sun Feb 09, 2014 7:31 pm
That was it. After opening kdenlive in the new user, everything was working just fine. Do I need to remove my current user and use a new one? I really do have a lot of stuff in it and I'd like to keep it. How can the issue be narrowed down further?

Thanks for all the help, I greatly appreciate it.
User avatar Steve Guilford
Registered Member
Posts
46
Karma
0

Re: Shortcuts stopped working

Sun Feb 09, 2014 9:12 pm
kardn wrote:That was it. After opening kdenlive in the new user, everything was working just fine. Do I need to remove my current user and use a new one? I really do have a lot of stuff in it and I'd like to keep it. How can the issue be narrowed down further?

Thanks for all the help, I greatly appreciate it.

Good deal.

Since you've already canned the kdenliverc file maybe there's another config file that's buggering up the works. Take a look at the other files in your existing user's .kde/share/config directory. On a one-by-one basis make a backup copy of your new user's file and replace it w/ the corresponding file from your existing user and test KdenLive. I'd also test your existing kdenliverc file w/ your new user just for laughs if the previous tests don't reveal anything.
kardn
Registered Member
Posts
12
Karma
0

Re: Shortcuts stopped working  Topic is solved

Mon Feb 10, 2014 7:02 am
Actually, something else fixed it. I said the only thing I remember doing that could affect settings was opening the zorg.conf file, although I closed it without saving, right? So yesterday late at night, I decided to open it again, just because. After exiting without saving, the shortcuts are now working. Go figure. I really have no idea what happened or why...

Thanks for all the help again, I am sorry it was something so silly.
User avatar Steve Guilford
Registered Member
Posts
46
Karma
0

Re: Shortcuts stopped working

Mon Feb 10, 2014 4:20 pm
kardn wrote:Actually, something else fixed it. I said the only thing I remember doing that could affect settings was opening the zorg.conf file, although I closed it without saving, right? So yesterday late at night, I decided to open it again, just because. After exiting without saving, the shortcuts are now working. Go figure. I really have no idea what happened or why...

Thanks for all the help again, I am sorry it was something so silly.

No need to be sorry. Silly is having tech support tell you to turn your caps-lock key off... :)

 
Reply to topic

Bookmarks



Who is online

Registered users: alake, Baidu [Spider], Bing [Bot], boudewijn, colomar, edmael, Exabot [Bot], garthecho, Google [Bot], google01103, Hans, jitseniesen, ken300, koriun, mayankasthana, mgraesslin, mixoff, mmistretta, pedrorodriguez, scummos, SeaJey, SecretCode, Sentynel, Sogou [Bot], urgo, Yahoo [Bot]