Reply to topic

version 0.9.8 kdenlive released

User avatar ttguy
Moderator
Posts
823
Karma
4
OS

version 0.9.8 kdenlive released

Fri May 16, 2014 7:16 am
Exciting news folks version 0.9.8 of kdenlive stable release is out.

Does this mean the next version is version 1.0 :) ?

release notes: http://kdenlive.org/discover/0.9.8

Changes:

Fades: timeline shortcut now applies to video on clips containing video and audio
Copy proxies with 'move project'
Remove the MLT processing threads option that never really worked
Clean encoding profiles using MLT presets and profiles
Support a custom suffix for FFmpeg binaries (mostly for packagers)
Make audio align work asynchronously
Add support for JogShuttle on newer systems, make shuttle device selection more straightforward, add ProV2 keys

Bugs fixed:

Fix warnings from gcc, cppcheck, clang, scan-build: fixes many crashs & leaks
Code cleanup (use const ref, fix includes, mem leaks, optimize...)
Fix keyframing messed up for some effects
Fix timeline corruption when trying to move clip before 0
Fix crash when closing title widget
Fix thumbnails for image clips in timeline
Fix crash on quick undo/redo (#3240)
Fix multithreading (# 3186)
Fix some problems with transitions keyframes
Fix scopes (#3052)

Anouncement from vpinon http://kdenlive.org/node/9179

Source code
http://download.kde.org/stable/kdenlive ... mirrorlist
Edit: ver 0.9.8 is now available in Sunabs stable release PPA - thanks Sunab !!!
User avatar TheDiveO
Registered Member
Posts
203
Karma
2

Great!

Tue May 20, 2014 6:25 pm
Kdenlive 0.9.8 has finally arrived in Sunab's stable release PPA. Installation is fair on Kubuntu 14.04 64bit, this is a usable release. Still several quirks (composite transition color space errors) and crashes, but all in all quite usable. Support for the ShuttlePRO seems to have improved considerably: Kdenlive now works around the swallowed event bug of the ShuttelPRO series devices. Shuttling around works great and makes finding cut points so much more convenient.

A big thank you to the developers!

This release came just in time for me as I returned from a dive weekend in Austria with awesome footage from the Green Lake... ;D


TheDiveO on YouTube: diving videos and aerial (quadcopter) videos, all made with Kdenlive.
TheDiveO Blog: know-how about Protune-grading in Kdenlive, GoPro HD Hero 3, DJI Phantom Quadcopter, full face mask diving, and some more...
User avatar TheDiveO
Registered Member
Posts
203
Karma
2

Re: version 0.9.8 kdenlive released

Tue May 20, 2014 7:13 pm
Well ... there are some ugly bugs, such as clip references being borked and effects being undeletable and effect settings getting lost.


TheDiveO on YouTube: diving videos and aerial (quadcopter) videos, all made with Kdenlive.
TheDiveO Blog: know-how about Protune-grading in Kdenlive, GoPro HD Hero 3, DJI Phantom Quadcopter, full face mask diving, and some more...
User avatar TheDiveO
Registered Member
Posts
203
Karma
2

Avoid 0.9.8

Fri May 23, 2014 6:14 pm
The more I work with 0.9.8 the less I would recommend using it! In a new project created with 0.9.8 the curves effects do not work anymore. Whichever curve I set, no result or everything turning into a single color. Proxy generation gets mixed up and interferes with working with clips. Clip references borked so the timeline now references wrong clips.

A second new projects shows similar issues, even with newest version from Sunab's stable.

I won't recommend using Kdenlive 0.9.8.


TheDiveO on YouTube: diving videos and aerial (quadcopter) videos, all made with Kdenlive.
TheDiveO Blog: know-how about Protune-grading in Kdenlive, GoPro HD Hero 3, DJI Phantom Quadcopter, full face mask diving, and some more...
User avatar ttguy
Moderator
Posts
823
Karma
4
OS

Re: version 0.9.8 kdenlive released

Fri May 23, 2014 11:29 pm
Sounds bad Diveo. Have you reported these to mantis ? I have installed it but not really used it.
User avatar TheDiveO
Registered Member
Posts
203
Karma
2

Re: version 0.9.8 kdenlive released

Sat May 24, 2014 12:18 pm
I haven't reported yet as I want to gather more information about the issues I'm seeing. I basically recreated the project I was working on ... and as I didn't experienced the same issues I have the impression that the first 0.9.8 release was severely broken. It corrupted my project beyond repair. For instance, some effects didn't worked inside this project but in new projects. Timeline references were destroyed and then referenced the wrong clip.

The current 0.9.8 release from Sunab's stable repo seems to work better. Still several issues but none that borks projects so far. Dieing proxy generation don't touch kdenlive as the project view and the clip viewer exhibit their own life and heavily interfere with whatever you want to do.

I'm not clear why the developers call 0.9.8 a stable release. I seriously beg to differ. Luckily, this was a small project that I had to recreate, just three minutes of thirty takes, cuts, and so.


TheDiveO on YouTube: diving videos and aerial (quadcopter) videos, all made with Kdenlive.
TheDiveO Blog: know-how about Protune-grading in Kdenlive, GoPro HD Hero 3, DJI Phantom Quadcopter, full face mask diving, and some more...
User avatar ttguy
Moderator
Posts
823
Karma
4
OS

Re: version 0.9.8 kdenlive released

Sun May 25, 2014 5:58 am
Diveo,
What date did you first intall 0.9.8. ?

I am just wondering if there is any evidence that there has been more than one 0.9.8 version in Sunabs ppa?

You anounced May 20, 2014 7:25 pm (I guess this is East Australia time) that sunabs PPA has ver 0.9.8 (here) and sunabs ppa gives 2014-05-20 as the time stamp for the current 0.9.8 build.
My installed version is from the 2014-05-20 build in the PPA at this time. And it is reported by my package manager as 0.9.8-1ubuntu1~sunab~trusty4.
I am guessing that the -1 in the 0.9.8-1 is version 1 of 0.9.8 (Was there a version zero?)

So I don't think there has been more than one version of the 0.9.8 release in the sunab ppa.

You mention that your second instal works better. What are the current issues you have ?
User avatar ttguy
Moderator
Posts
823
Karma
4
OS

Re: version 0.9.8 kdenlive released

Sun May 25, 2014 11:07 am
I have just edited a small amount of HD video (1920 x 1080p from a GoPro).
Proxy clips are working fine for me.
No timeline coruption for me.
No crashing.
Renders just fine.
So I like this version.
User avatar TheDiveO
Registered Member
Posts
203
Karma
2

Re: version 0.9.8 kdenlive released

Sun May 25, 2014 3:47 pm
Olivier's repo shows kdenlive as 0.9.8-1ubuntu1~sunab~trusty4, dating from 20th of May. My post is also from the same day, but from the back of my memory I know that I upgraded to the ~trusty4 version not before friday evening. So when first posting I was on an earlier 0.9.8~trustyX ... and that version severly borked my project file. I still have this broken project file. It gets loaded without problems, but afterwards several effects won't work.

Alas, I could finish two tiny projects with 0.9.8-1ubuntu1~sunab~trusty4, which is more stable and doesn't bork my project files. However, it has issues with proxy generation. It's not the generation itself, but instead the clip monitor switches clips every time one proxy has been generated. I've filed a bug report on this specific issue with the Kdenlive mantis bug tracker.

Still seeing a lot of other crashes while working on my projects. Unfortunately, barely reproducibly; opening audio clips, applying effects, et cetera.


TheDiveO on YouTube: diving videos and aerial (quadcopter) videos, all made with Kdenlive.
TheDiveO Blog: know-how about Protune-grading in Kdenlive, GoPro HD Hero 3, DJI Phantom Quadcopter, full face mask diving, and some more...
User avatar Ubu the Tech Guru
Registered Member
Posts
65
Karma
0
OS

Re: version 0.9.8 kdenlive released

Sat Jun 07, 2014 4:08 pm
trying to record using monitor record from my webcam works at first but when i click stop, kdenlive freezes. other than that it appears to be working. Here's what the terminal shows when attempting to record a second time, now it doesn't work at all. The first time I tried it, it did work, it showed my face within the record monitor
[video4linux2 @ 0x7fe4436776a0] Cannot find a proper format for codec_id 0, pix_fmt -1.
[video4linux2 @ 0x7fe4436776a0] Cannot open video device video4linux2:/dev/video0?width:1280&height:720&frame_rate:30 : No such file or directory
[video4linux2 @ 0x7fe443678a40] Cannot find a proper format for codec_id 0, pix_fmt -1.
[video4linux2 @ 0x7fe443678a40] Cannot open video device video4linux2:/dev/video0?width:1280&height:720&frame_rate:30 : No such file or directory
[video4linux2 @ 0x7fe443678980] Cannot find a proper format for codec_id 0, pix_fmt -1.
[video4linux2 @ 0x7fe443678980] Cannot open video device video4linux2:/dev/video0?width:1280&height:720&frame_rate:30 : No such file or directory
[video4linux2 @ 0x7fe443680e00] Cannot find a proper format for codec_id 0, pix_fmt -1.
[video4linux2 @ 0x7fe443680e00] Cannot open video device video4linux2:/dev/video0?width:1280&height:720&frame_rate:30 : No such file or directory
[video4linux2 @ 0x7fe443680d60] Cannot find a proper format for codec_id 0, pix_fmt -1.
[video4linux2 @ 0x7fe443680d60] Cannot open video device video4linux2:/dev/video0?width:1280&height:720&frame_rate:30 : No such file or directory
[video4linux2 @ 0x7fe4436829c0] Cannot find a proper format for codec_id 0, pix_fmt -1.
[video4linux2 @ 0x7fe4436829c0] Cannot open video device video4linux2:/dev/video0?width:1280&height:720&frame_rate:30 : No such file or directory
[video4linux2 @ 0x7fe4436829c0] Cannot find a proper format for codec_id 0, pix_fmt -1.
[video4linux2 @ 0x7fe4436829c0] Cannot open video device video4linux2:/dev/video0?width:1280&height:720&frame_rate:30 : No such file or directory
[video4linux2 @ 0x7fe443683aa0] Cannot find a proper format for codec_id 0, pix_fmt -1.
[video4linux2 @ 0x7fe443683aa0] Cannot open video device video4linux2:/dev/video0?width:1280&height:720&frame_rate:30 : No such file or directory
[video4linux2 @ 0x7fe4436839e0] Cannot find a proper format for codec_id 0, pix_fmt -1.
[video4linux2 @ 0x7fe4436839e0] Cannot open video device video4linux2:/dev/video0?width:1280&height:720&frame_rate:30 : No such file or directory


400+ Videos on YouTubehttp://www.youtube.com/ubuntuaddicted
Support me directly on Patreon http://www.patreon.com/ubuntuaddicted
Follow me on Twitter http://www.twitter.com/ubuntuaddicted
User avatar bcooksley
Administrator
Posts
19743
Karma
84
OS

Re: version 0.9.8 kdenlive released

Mon Jun 09, 2014 8:17 am
Does the device /dev/video0 exist, and do you have read/write permissions over it?
It should look something like this:
Code: Select all
crw-rw----+ 1 root video 81, 0 Jun  9 17:59 /dev/video0


System Settings and Device Actions KCM maintainer
Image

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], claydoh, davidemme, drosca, Exabot [Bot], Google [Bot], google01103, jlarrieux, jmf, koriun, La Ninje, mat000111, MSNbot Media, nylnook, smankowski, Speedwagon, wolfi323, Yahoo [Bot]