Reply to topic

kdenlive Your FFmpeg / Libav installation does not support

valeriopachera
Registered Member
Posts
4
Karma
0
Hi, I'm running debian wheezy.
I've been building kdenlive 0.97 version by the automatic script.
More than anything I wanted to try the screen capture function.
When I select 'screen capture' I get the message
"Your FFmpeg / Libav installation does not support screen grab".

It should have all the depences it needs.
Why does it bother with this?
User avatar ttguy
Moderator
Posts
902
Karma
4
OS
In theory you need ffmpeg / libav complied with --enable-x11grab option.

ffmpeg -version

will reveal the config that it was compiled with
eg it might say "configuration: --enable-x11grab"

However, my experince was that this did not matter - I still had issues with screen capture.

I have given up on kdenlive's screen capture and are using kazam screencaster.

Discussed at mantis 2643
valeriopachera
Registered Member
Posts
4
Karma
0
Code: Select all
cd /home/user/kdenlive/20140527/bin/
./ffmpeg -version
ffmpeg version N-63468-ge64e079
built on May 27 2014 13:30:32 with gcc 4.7 (Debian 4.7.2-5)
configuration: --prefix=/home/valerio/kdenlive/20140527 --disable-doc --disable-network --disable-ffserver --enable-gpl --enable-version3 --enable-shared --enable-debug --disable-stripping --enable-pthreads --enable-runtime-cpudetect --enable-libtheora --enable-libvorbis --enable-libmp3lame --enable-libx264 --enable-libvpx
libavutil      52. 87.100 / 52. 87.100
libavcodec     55. 65.100 / 55. 65.100
libavformat    55. 41.100 / 55. 41.100
libavdevice    55. 13.101 / 55. 13.101
libavfilter     4.  5.100 /  4.  5.100
libswscale      2.  6.100 /  2.  6.100
libswresample   0. 19.100 /  0. 19.100
libpostproc    52.  3.100 / 52.  3.100


There is no --enable-x11grab option.
I'm going to edit the scirpt 'build-kdenlive.sh' at line 460
Code: Select all
from
CONFIG[0]="./configure --prefix=$FINAL_INSTALL_DIR --disable-doc --disable-network ...
to
CONFIG[0]="./configure --prefix=$FINAL_INSTALL_DIR --enable-x11grab --disable-doc --disable-network ...


just for comparison with defalt debian version

Code: Select all
ffmpeg -version
ffmpeg version 0.8.10-6:0.8.10-1, Copyright (c) 2000-2013 the Libav developers
  built on Feb  5 2014 03:52:19 with gcc 4.7.2
*** THIS PROGRAM IS DEPRECATED ***
This program is only provided for compatibility and will be removed in a future release. Please use avconv instead.
ffmpeg 0.8.10-6:0.8.10-1
libavutil    51. 22. 2 / 51. 22. 2
libavcodec   53. 35. 0 / 53. 35. 0
libavformat  53. 21. 1 / 53. 21. 1
libavdevice  53.  2. 0 / 53.  2. 0
libavfilter   2. 15. 0 /  2. 15. 0
libswscale    2.  1. 0 /  2.  1. 0
libpostproc  52.  0. 0 / 52.  0. 0


Code: Select all
avconv -version
avconv version 0.8.10-6:0.8.10-1, Copyright (c) 2000-2013 the Libav developers
  built on Feb  5 2014 03:52:19 with gcc 4.7.2
avconv 0.8.10-6:0.8.10-1
libavutil    51. 22. 2 / 51. 22. 2
libavcodec   53. 35. 0 / 53. 35. 0
libavformat  53. 21. 1 / 53. 21. 1
libavdevice  53.  2. 0 / 53.  2. 0
libavfilter   2. 15. 0 /  2. 15. 0
libswscale    2.  1. 0 /  2.  1. 0
libpostproc  52.  0. 0 / 52.  0. 0
User avatar ttguy
Moderator
Posts
902
Karma
4
OS
Yeah. I think the ffmpeg version from the libav package does not report how it was complied when you supply the -version script. Only the ffmpeg from the ffmpeg part of the forked project does that.
But it looks like the build script does not build ffmpeg with the --enable-x11grab option. So - yes your change might to the trick.

I just revisited this on my new 0.9.6 on ubuntu 14.04 64 bit version and screen capture does work.

This version of ubuntu is running avconv version 9.13-6:9.13-0ubuntu0.14.04.1+fdkaac and has no ffmpeg - the libav team have been true to their word in "This program is only provided for compatibility and will be removed in a future release."

But maybe sunabs ppa has build me a genuine ffmpeg - because I see that kdenlive config points me to /usr/bin/ffmpeg. This is different from the inital install of kdenlive which comes ith 14.04 of ubuntu (which was pointing to avconv).
valeriopachera
Registered Member
Posts
4
Karma
0
Editing the script with '--enable-x11grab' screen capture works but it creashes!

Note: I had to use the option '--disable-asm' for x264 because building was failing for an old lib in debian.
Code: Select all
  # x264
  CONFIG[4]="./configure --prefix=$FINAL_INSTALL_DIR --disable-asm ...


The crash occure when I press stop recording.
Versione 0.9.7 (rev. v0.9.6.1-120-gffba7dd)
User avatar ttguy
Moderator
Posts
902
Karma
4
OS
Have you tried the 0.9.8 version of Kdenlive ?
User avatar Ubu the Tech Guru
Registered Member
Posts
65
Karma
0
OS
i'm running Xubuntu 14.04 64bit and I just installed kdenlive 0.9.8 and when I try to do screen capture it says
Failed to start the capture application:
/usr/bin/ffmpeg
i guess i'll have to use an external app like SSR or ScreenStudio to record my desktop


400+ Videos on YouTubehttp://www.youtube.com/ubuntuaddicted
Support me directly on Patreon http://www.patreon.com/ubuntuaddicted
Follow me on Twitter http://www.twitter.com/ubuntuaddicted

 
Reply to topic

Bookmarks



Who is online

Registered users: arucard, Baidu [Spider], Bing [Bot], davidemme, Exabot [Bot], Google [Bot], google01103, gtrip, Hans, La Ninje, marcuskjeldsen, markg85, metzman, n-i-c-l-a-s, nharmony, rumangerst, scottpetrovic, slangkamp, TheraHedwig, veqz, yabid, Yahoo [Bot]