Reply to topic

Kdenlive 15.12 for Fedora 23 Mate

MrNIce
Registered Member
Posts
23
Karma
0
OS

Re: Kdenlive 15.12 for Fedora 23 Mate

Sat Jan 02, 2016 11:58 am
Still
Code: Select all
Icon theme "oxygen" not found.
Icon theme "oxygen" not found.
Error: standard icon theme "oxygen" not found!
QWidget::setMaximumSize: (/QToolButton) Negative sizes (2,-2) are not possible
QWidget::setMaximumSize: (/QToolButton) Negative sizes (2,-2) are not possible
QWidget::setMaximumSize: (/QToolButton) Negative sizes (2,-2) are not possible
Could you provide the list of qt5 you have
I installed qt5-style-oxygen but nothing better
vpinon
KDE Developer
Posts
582
Karma
3
OS
How do you start your installed binary? Do you use the script that sets XDG_DATA_DIRS?
Do you have breeze icon theme installed?
MrNIce
Registered Member
Posts
23
Karma
0
OS
I start it in a terminal in the date directory (/Kdenlive/20160102) with
Code: Select all
 ./start-kdenlive

Do you use the script that sets XDG_DATA_DIRS?

No, nothing like that here https://community.kde.org/Kdenlive/Development/KF5#A_build_script

Edit:
The script ./start-kdenlive has
Code: Select all
export XDG_DATA_DIRS=$INSTALL_DIR/share:$XDG_DATA_DIRS
User avatar ttguy
Moderator
Posts
1151
Karma
6
OS
vpinon wrote:Do you have breeze icon theme installed?
MrNIce
Registered Member
Posts
23
Karma
0
OS
Code: Select all
 dnf list installed | grep breeze
breeze-cursor-theme.noarch            5.5.0-1.fc23                 @updates     
breeze-icon-theme.noarch              5.17.0-1.fc23                @updates     

I tried plasma-breeze-common and kde-style-breeze, nothing better
MrNIce
Registered Member
Posts
23
Karma
0
OS
So I repeat the error message I get
Code: Select all
./start-kdenlive
Way to run = Normal
running kdenlive
Icon theme "oxygen" not found.
Icon theme "oxygen" not found.
Error: standard icon theme "oxygen" not found!
QWidget::setMaximumSize: (/QToolButton) Negative sizes (2,-2) are not possible
QWidget::setMaximumSize: (/QToolButton) Negative sizes (2,-2) are not possible
QWidget::setMaximumSize: (/QToolButton) Negative sizes (2,-2) are not possible
QWidget::setMaximumSize: (/QToolButton) Negative sizes (2,-2) are not possible
QWidget::setMaximumSize: (/QToolButton) Negative sizes (2,-2) are not possible
Now I need help, all my try failed.
Thank you in advance
User avatar ttguy
Moderator
Posts
1151
Karma
6
OS
besides those messages what other symptoms are there?

Because we do get error messages in the terminal that are non-fatal. So I am not sure those messages are actually symptomatic of a problem. They might be. They might not.

You could try deleting the settings file for kdenlive which will make it run the config wizard again - in case your settings are screwed up.
delete
~/.kde/share/config/kdenliverc
MrNIce
Registered Member
Posts
23
Karma
0
OS
I removed kdenliverc file, still the same
What are the symptoms:
- No icon
- No colour
- No button
I didn't tried more

Edit:
Code: Select all
$ dnf list installed | grep oxygen
oxygen-fonts.x86_64                   5.4.3-1.fc23                 @updates     
oxygen-fonts-common.noarch            5.4.3-1.fc23                 @updates     
oxygen-icon-theme.noarch              1:5.17.0-1.fc23              @updates     
oxygen-mono-fonts.noarch              5.4.3-1.fc23                 @updates     
oxygen-sans-fonts.noarch              5.4.3-1.fc23                 @updates     
qt5-style-oxygen.x86_64               5.5.1-1.fc23                 @updates     
Should I install something else or is it a path issue?
MrNIce
Registered Member
Posts
23
Karma
0
OS
The error message I posted 7 days ago didn't get any fix. So, I'd guess there is no way to fix that, consequently, Kdenlive 15.12 can't be installed and run with the script on Fedora 23 Mate.
Note that there is no way ether to install it from rpm, see thread https://forum.kde.org/viewtopic.php?f=265&t=130422

For reference and maybe for a future packager, below the list of packages I had to install to run the scripts (Edit : not version 25 but version 26) then version 27.

LOG: About to run command: cmake -DCMAKE_INSTALL_PREFIX:PATH=/home/jp/Kdenlive/20151228
./build-kdenlive.sh: line 296: cmake: command not found
====>>>> Install cmake
configure.ac:35: error: must install xorg-macros 1.8 or later before running autoconf/autogen.
====>>>> Install xorg-x11-util-macros
configure: error: Package requirements (fftw3) were not met:
====>>>> Install fftw-devel version 3.x
configure: error: Package requirements (eigen3) were not met:
====>>>> Install eigen3-devel
LOG: About to run command: ./configure --prefix=/home/jp/Kdenlive/20151229 --disable-doc --disable-ffserver --enable-gpl --enable-version3 --enable-shared --enable-debug --disable-stripping --enable-pthreads --enable-runtime-cpudetect --enable-libtheora --enable-libvorbis --enable-libmp3lame --enable-libx264 --enable-libvpx
ERROR: libtheora not found
====>>>> Install libtheora-devel
ERROR: libvorbis not found
====>>>> Install libvorbis-devel
LOG: About to run command: cd src/modules
LOG: MLTDISABLED <b>jackrack</b> :
LOG: MLTDISABLED <b>qt</b> :
LOG: MLTDISABLED <b>resample</b>
LOG: MLTDISABLED <b>sox</b> :
LOG: MLTDISABLED <b>swfdec</b> :
LOG: MLTDISABLED <b>xml</b> :
====>>>> Install libsamplerate-devel
sox-dev
libxml2-devel
qt5-qtscript-devel
qt5-qtsvg-devel
gambas3-gb-qt5-opengl
Other are optional
factory.c:22:21: fatal error: gdk/gdk.h: No such file or directory
====>>>> Install gtk2-devel-2.24.29-1.fc23.x86_64 : Development files for GTK+
Note that gtk3-devel was installed
CMake Error at /usr/share/cmake/Modules/FindKDE4.cmake:111 (message):
ERROR: cmake/modules/FindKDE4Internal.cmake not found in
====>>>> Install extra-cmake-modules
CMake Error at /usr/lib64/cmake/Qt5/Qt5Config.cmake:26 (find_package):
Could not find a package configuration file provided by "Qt5Quick" with any
of the following names:
Qt5QuickConfig.cmake
qt5quick-config.cmake
====>>>> Install qtdeclarative5-devel
====>>>> Install qt5-qtwebkit-devel
CMake Warning at /usr/share/ECM/find-modules/FindKF5.cmake:74 (find_package):
Could not find a package configuration file provided by "KF5FileMetaData"
(requested version 5.15) with any of the following names:
KF5FileMetaDataConfig.cmake
kf5filemetadata-config.cmake
====>>>> Install kf5-kfilemetadata-devel
CMake Warning at /usr/share/ECM/find-modules/FindKF5.cmake:74 (find_package):
Could not find a package configuration file provided by "KF5Plotting"
(requested version 5.15) with any of the following names:
KF5PlottingConfig.cmake
kf5plotting-config.cmake
CMake Warning at /usr/share/ECM/find-modules/FindKF5.cmake:74 (find_package):
Could not find a package configuration file provided by "KF5NotifyConfig"
(requested version 5.15) with any of the following names:
KF5NotifyConfigConfig.cmake
kf5notifyconfig-config.cmake
====>>>> Install kf5-knotifyconfig-devel
====>>>> Install kf5-kplotting-devel
CMake Warning at /usr/share/ECM/find-modules/FindKF5.cmake:74 (find_package):
Could not find a package configuration file provided by "KF5NewStuff"
(requested version 5.15) with any of the following names:
KF5NewStuffConfig.cmake
kf5newstuff-config.cmake
====>>>> Install kf5-knewstuff-devel

With script version 27
LOG: About to run command: kf5-config -v
./build-kdenlive.sh: line 297: kf5-config: command not found
ERROR: Unable to run kf5-config
====>>>> Install kf5-kdelibs4support-devel

Then run
./start-kdenlive
Way to run = Normal
running kdenlive
Icon theme "oxygen" not found.
Icon theme "oxygen" not found.
Error: standard icon theme "oxygen" not found!
qrc:/qml/kdenliveclipmonitor.qml:2:1: module "QtQuick.Controls.Styles" is not installed
qrc:/qml/kdenliveclipmonitor.qml:1:1: module "QtQuick.Controls" is not installed
qrc:/qml/kdenliveclipmonitor.qml:2:1: module "QtQuick.Controls.Styles" is not installed
qrc:/qml/kdenliveclipmonitor.qml:1:1: module "QtQuick.Controls" is not installed
./start-kdenlive: line 117: 9176 Segmentation fault (core dumped) kdenlive "${kdenlive_args[@]}"
=====>>>> Install qt5-qtquickcontrols
=====>>>> Install qt5-qttools

I hope this will help maybe to get Kdenlive 15.12 in few months.
So I'll remove all useless packages an go back to version 0.9.10-1 from official repo. :(
Thanks anyway for your help

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], Google [Bot], lueck, Mamarok, Sogou [Bot]