Reply to topic

Changed a setting, accidentally broke Kdenlive! Help!

tomnottom
Registered Member
Posts
3
Karma
0
Hey, so I use Kdenlive as my primary video editing software on Windows. However, I changed a setting due to my audio not correctly playing, and then I got an error and my Kdenlive hasn't worked since. I've tried changing the setting back, which leads to Kdenlive crashing, and I've also tried completely reinstalling Kdenlive, which did not work either.

I changed the setting 'Audio Driver" to OSS, while before it was on Automatic.

If anyone can help me it would be greatly appreciated! I make videos for my YouTube channel all the time and my productivity is currently crippled!

Here's the error:

Could not create the video preview window.
There is something wrong with your Kdenlive install or your driver settings, please fix it.


Thanks for the help!
Stetsbequem
Registered Member
Posts
123
Karma
-1
The Open Sound System (OSS) is an interface for making and capturing sound in Unix and Unix-like operating systems: https://en.wikipedia.org/wiki/Open_Sound_System
Erasing Kdenlive won't help, the Kdenlive settings are in your user directory, which must be removed if necessary.


Either you choose the right job for the tool, or the right tool for the job.
tomnottom
Registered Member
Posts
3
Karma
0
Stetsbequem wrote:The Open Sound System (OSS) is an interface for making and capturing sound in Unix and Unix-like operating systems: https://en.wikipedia.org/wiki/Open_Sound_System
Erasing Kdenlive won't help, the Kdenlive settings are in your user directory, which must be removed if necessary.


Gotcha... would you mind giving me a tutorial on removing the settings? I'm not the most tech-savvy person...
Stetsbequem
Registered Member
Posts
123
Karma
-1
Sorry, my last Windows was WfW 3.11.
Perhaps you need to find a directory that looks like this and delete it?
C:\Users\*your name*\AppData\Local\kdenlive

Alternatively:
kdenlive --help
--config <config> Set a custom config file name


Either you choose the right job for the tool, or the right tool for the job.
tomnottom
Registered Member
Posts
3
Karma
0
Stetsbequem wrote:Sorry, my last Windows was WfW 3.11.
Perhaps you need to find a directory that looks like this and delete it?
C:\Users\*your name*\AppData\Local\kdenlive

Alternatively:
kdenlive --help
--config <config> Set a custom config file name


After deleting files which seemed to be the ones you are talking about, I was still left with the same error. However, I was unable to figure out the alternative. Could you elaborate on that?

"kdenlive --help
--config <config> Set a custom config file name"

EDIT: Ah, never mind. I found it. For anyone who may be looking into this issue from the future and is confused by this, just make sure you can see hidden files when you are in C:\Users\*name*\, otherwise you won't find the Appdata folder. From there, go to Local, and search Kdenlive. I just deleted everything related to Kdenlive, but I would assume there is a specific file that should be deleted.
User avatar unfa
Registered Member
Posts
34
Karma
0
I had the same error message on Linux Mint 18.3 (with PlasmaDesktop).

The preview window would be solid green and after trying to play back anything Kdenlive would crash.

When I made sure PulseAudio is running - everything went back to normal.
wano
Registered Member
Posts
2
Karma
0
I am experiencing the same error on Ubuntu with Kdenlive 20.04.

Code: Select all
Could not create the video preview window.
There is something wrong with your Kdenlive install or your driver settings, please fix it.


I installed PulseAudio and Kdenlive threw this error.

Things I've tried.

1) Accessed /home/user/snap/kdenlive/current/.config and renamed the files and folders
Each time kdenlive is started the files are recreated but the error persists.
2) Uninstalled and purged kdenlive and PusleAudio(since the issue started by installing PulseAudio), removed old snaps and cleaned the cache.
3) Re-installed and the error persists.

I'm not sure what to do here. Any advice would be helpful.

Thanks.
User avatar bartoloni
Moderator
Posts
907
Karma
2
OS
tomnottom wrote:Could not create the video preview window.
There is something wrong with your Kdenlive install or your driver settings, please fix it.
Thanks for the help!

Image

delete these files/folders to have a completely "fresh" installation of Kdenlive

wano wrote:I am experiencing the same error on Ubuntu with Kdenlive 20.04.
Code: Select all
Could not create the video preview window.
There is something wrong with your Kdenlive install or your driver settings, please fix it.

Thanks.


please not follow "unfa" reply.. this is was off topic 2 years ago... the original post is about hidden settings on Kdenlive for Windows...
i suggest you to open a new thread on "Installation" sub forum (and not general) asking help for you precise issue... probably Linux users can solve this.

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], beerislife, Bing [Bot], Google [Bot], Majestic-12 [Bot], pasis, Sogou [Bot], YaCy [Bot]