Reply to topic

Guides are not moving with clip

berndmj
Registered Member
Posts
45
Karma
0

Guides are not moving with clip

Wed Sep 23, 2020 3:12 pm
I am using kdenlive 20.08.1 on Windows 1, and in my workflow use guides to easily identify sections or scene changes etc. When I make cuts, delete or insert clips, move stuff around the guides do not move with the clips where they were created. Is that by design? If so, I am wondering why and what the advantage is to keep them in their position in the timeline as opposed to move them with the frame where they were created.
If this is not by design shall I open a bug notification?
Thanks.
User avatar bartoloni
Moderator
Posts
907
Karma
2
OS

Re: Guides are not moving with clip

Thu Sep 24, 2020 6:02 am
Guides are TIMELINE related... these guides can't change position "automatically" when doing changes to clips or spaces deletion .. this because GUIDES are used to be sure to place clips or contents at a specific time.. if you want to have something that can be moved automatically you have to use MARKERS.
berndmj
Registered Member
Posts
45
Karma
0

Re: Guides are not moving with clip

Thu Sep 24, 2020 3:07 pm
bartoloni wrote:Guides are TIMELINE related... these guides can't change position "automatically" when doing changes to clips or spaces deletion .. this because GUIDES are used to be sure to place clips or contents at a specific time.. if you want to have something that can be moved automatically you have to use MARKERS.


Ok, understood. Thanks, bartoloni! Seems to be a question of workflow.

Interestingly, there is a keyboard shortcut "*" for quickly inserting a marker/guide. Depending on whether you are working in the timeline (watching the project monitor) or on the specific clip (watching the clip monitor) pressing "*" creates a guide (project monitor) or a marker (clip monitor). As I am more working with the timeline - I drop all clips on the timeline and then examine and cut there - and the project monitor (second monitor) I am wondering whether this can be changed through config/setting, i.e. I can determine that pressing "*" always sets a marker in the clip that is playing in the project or clip monitor.
I tried to change this in the keyboard shortcut settings dialog but there is something wrong with the display: I can select the action and also press the new key assignment but there is no OK or Cancel button. It seems the window is partially hidden. Also, deleting a key press sends kdenlive into a long period of "not responding". As a result I cannot modify the keyboard shortcuts (tested with kdenlive nightly (20.11.70) on Windows 10 64-bit).
User avatar bartoloni
Moderator
Posts
907
Karma
2
OS
berndmj
Registered Member
Posts
45
Karma
0

Re: Guides are not moving with clip

Thu Sep 24, 2020 7:11 pm
bartoloni wrote:i think this is your issue: https://invent.kde.org/multimedia/kdenlive/-/issues/763

Thanks for your reply, but not quite. I tried latest nightly built on Windows 10, and also 20.04.0 under Linux (Modicia).
Under Windows the freeze resolves itself but the change is not saved. The dialog box seems cut off. I would expect an OK and Cancel button to save the new key combination but that is simply not there. The dialog box's frame is interrupted which leads me to believe the dialog box is not drawn correctly.
https://www.dropbox.com/s/f650rga5u38ss90/kdenlive_configure_shortcuts.png?dl=0

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], Google [Bot], kde-cfeck, Sogou [Bot]