Reply to topic

kdenlive build error ,REQUIRED packages could NOT be located

guzhijie1981
Registered Member
Posts
4
Karma
0
hi all :

my OS information is as follows:

public@public:~/work/Kdenlive/kdenlive/build$ uname -a
Linux public 3.8.0-26-generic #38-Ubuntu SMP Mon Jun 17 21:46:08 UTC 2013 i686 i686 i686 GNU/Linux


when i type :
cmake .. -DCMAKE_INSTALL_PREFIX=/usr

the error message is :
Current Kdenlive Git revision is v0.9.4-425-gab67e05
-- Found Qt-Version 4.8.4 (using /usr/bin/qmake)
-- Found X11: /usr/lib/i386-linux-gnu/libX11.so
-- Found KDE 4.10 include dir: /usr/include
-- Found KDE 4.10 library dir: /usr/lib
-- Found the KDE4 kconfig_compiler preprocessor: /usr/bin/kconfig_compiler
-- Found automoc4: /usr/bin/automoc4
-- Found Qt-Version 4.8.4 (using /usr/bin/qmake)
-- Found X11: /usr/lib/i386-linux-gnu/libX11.so
-- Found MLT++: /usr/lib/i386-linux-gnu/libmlt++.so

-----------------------------------------------------------------------------
-- The following external packages were located on your system.
-- This installation will have the extra features provided by these packages.
-----------------------------------------------------------------------------
* KDELibs - KDE core libraries
* libv4l - Collection of video4linux support libraries
* GLEW - OpenGL Extension Wrangler Library (GLEW)
* QtOpenGL - Qt bindings for the OpenGL library
* QtScript - Qt module providing core scripting facilities
* Nepomuk - Support for the Nepomuk semantic desktop system
* QJson - Qt-based library that maps JSON data to QVariant objects

-----------------------------------------------------------------------------
-- The following REQUIRED packages could NOT be located on your system.
-- You must install these packages before continuing.
-----------------------------------------------------------------------------
* MLT (0.9.0 or higher) <http://mltframework.org>
Multimedia framework and video playout server for TV broadcasting

-----------------------------------------------------------------------------

any one can help me ,thanks
User avatar bcooksley
Administrator
Posts
19744
Karma
85
OS
To function, Kdenlive uses a library known as MLT, which is not installed on your system.
On my system, the package you need is called "libmlt++-devel" - which can be installed using your package manager (although it may be named differently).


KDE Sysadmin
[img]http://forum.kde.org/content/bcooksley_sig.png[/img]

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Bequimao, Bing [Bot], crystallord, Deevad, Exabot [Bot], Google [Bot], hugo.pereira@free.fr, LordTermor, Majestic-12 [Bot], mcorteel, metzman, nharmony, rumangerst, sebastianputz, Sogou [Bot], supaiku, veqz, Yahoo [Bot]