Reply to topic

Feedback about Kdenlive for Mac OS X

jmpoure_drupal
Registered Member
Posts
735
Karma
0
Please make your feedback here:
jmpoure_drupal
Registered Member
Posts
735
Karma
0
Looking at this screenshot, I am asking myself wether the monitor can be displayed or not?


ddennedy
Registered Member
Posts
1306
Karma
0
I am sorry. I do not understand the question. The screenshot is encouraging.
I have reorganized the hard disk partitions and made much more space on my MacBook Pro, and I plan to take a look at kdenlive on OS X.




jmpoure_drupal
Registered Member
Posts
735
Karma
0
Thanks for your reports. The md5sum error shows that you are not working on the SVN repository of MacPorts. I published more detailed information on http://kdenlive.org/user-manual/downloading-and-installing-kdenlive/pre-compiled-packages/macports-packages-macosx
ddennedy
Registered Member
Posts
1306
Karma
0
I did not use the SVN HEAD of the MacPorts, but according to the SVN web view the md5sum of kdelibs4 is still wrong for me. To workaround, I made a local version of the kdelibs4 Portfile and changed the md5sum to the value I computed after manually downloading the tarball. Then, the icons did not appear, so I installed kdebase4-runtime, but that failed due to missing dependency on phonon. Installing phonon resolved that and then everything is working. Now, I am at the same state as JMP with kdenlive running on OS X.


jmpoure_drupal
Registered Member
Posts
735
Karma
0
I don't have any access to a Mac OS X machine any longer.

I saw your bug reports, thanks:
http://trac.macports.org/ticket/19960

Adding a patch to your file would fasten things.
jmpoure_drupal
Registered Member
Posts
735
Karma
0
Kde4 was fixed in MacPorts SVN.

To upgrade:
%% sudo port -d selfupdate
Now MacPorts will look for portfiles in the working copy.

Upgrade installed packages
%% sudo port upgrade outdated

Install Kdenlive
%% sudo port install kdenlive

Did anyone succeed building automatically from MacPorts?
anaximander
Registered Member
Posts
18
Karma
0
Some days ago I successfully built kdenlive from macports, without having any macports packages installed.

The built went fine except that building the frei0r plugins did not find the bundle1.o file from the Apple Developer Tools. Is this a local problem?

Starting kdenlive brings up the wizard which seems to work fine. After the last wizard step nothing happens. I do not get any kdenlive window nor do I get any error.

a kdenlive process still runs but nothing happens. I suppose this is because I am using a PowerBook with a ppc processor.
jmpoure_drupal
Registered Member
Posts
735
Karma
0
Could you upgrade all your ports to see what happens with the latest version of MacPorts SVN.

%% sudo port -d selfupdate
Now MacPorts will look for portfiles in the working copy.

Upgrade installed packages
%% sudo port upgrade outdated

Install Kdenlive
%% sudo port install kdenlive
jmpoure_drupal
Registered Member
Posts
735
Karma
0
You also lack icons. Do you have kdebase4-runtime installed? I think Dave mentioned this requirement. Could you install kdebase4-runtime and tell us if this fixes the issue. Then I will post a patch on MacPorts.
anaximander
Registered Member
Posts
18
Karma
0
After upgrading all my macports packages the behaviour slightly changed.

After proceeding from the last step of the wizard a emtpy window shows up and kdenlive crashes with SIGSEGV. The backtrace provided by the kde crash application is attached.

Tell me if you need more information or if I should file a bug Image
jmpoure_drupal
Registered Member
Posts
735
Karma
0
make sure you are pointing to the SVN repository.

%% sudo port -d selfupdate
Now MacPorts will look for portfiles in the working copy.

Upgrade installed packages
%% sudo port upgrade outdated

Install Kdenlive
%% sudo port install kdebase4-runtime
%% sudo port install kdenlive

Can you try to debug using gdb:
gdb kdenlive

What version of MaxOsX?
Can you run melt from the command line?
melt foo.avi

Kind regards,
JMP
anaximander
Registered Member
Posts
18
Karma
0
I already had the most recent versions of the mentioned packages.
I think debugging kdenlive does not make much sense since I found that running melt in the Command line results in a segmentation fault.

What i get by running melt MELT.MPG is:

2009-06-21 00:33:29.940 melt[45338:813] Warning once: This application, or a library it uses, is using NSQuickDrawView, which has been deprecated. Apps should cease use of QuickDraw and move to Quartz.
+-----+ +-----+ +-----+ +-----+ +-----+ +-----+ +-----+ +-----+ +-----+
|1=-10| |2= -5| |3= -2| |4= -1| |5= 0| |6= 1| |7= 2| |8= 5| |9= 10|
+-----+ +-----+ +-----+ +-----+ +-----+ +-----+ +-----+ +-----+ +-----+
+---------------------------------------------------------------------+
| H = back 1 minute, L = forward 1 minute |
| h = previous frame, l = next frame |
| g = start of clip, j = next clip, k = previous clip |
| 0 = restart, q = quit, space = play |
+---------------------------------------------------------------------+

Program received signal EXC_BAD_ACCESS, Could not access memory.
Reason: KERN_INVALID_ADDRESS at address: 0x486b48d9
[Switching to process 45338 thread 0x4503]
0x91e14254 in pthread_mutex_lock ()

I am running Mac OsX 10.5.7(ppc) on an PowerBook G4.
ddennedy
Registered Member
Posts
1306
Karma
0
I (MLT developer) am aware that ppc does not work, but I do not have a ppc machine, nor really the bandwidth at the moment to attempt debugging remotely. I can only accept patches to get ppc working. I think this situation applies to Linux as well. So, it might happen that someone submits ppc patches; it has happened for me with Kino in the past.


ddennedy
Registered Member
Posts
1306
Karma
0
I did some research into what it will take to embed the player window on OS X. It is far from trivial, and no simple example. I have to do some combination of SDL-GL and QGLWidget. The Qt Phonon Quicktime backend source code provides some help. In any case, it is something I will continue to work on periodically.



 
Reply to topic

Bookmarks



Who is online

Registered users: apater, areid, Baidu [Spider], Bing [Bot], braystacey, edmael, einar, Exabot [Bot], garthecho, Google [Bot], google01103, ivan, jensreuterberg, joaob, jpwhiting, jstaniek, La Ninje, lazyit, Majestic-12 [Bot], mmistretta, MSN [Bot], pedrorodriguez, salvochea, scottpetrovic, scummos, SeaJey, SecretCode, slangkamp, slawekk, Sogou [Bot], SysGhost, TheraHedwig, tienhung, Tioz, VP1986, Yahoo [Bot], šumski