Reply to topic

Kdenlive 0.9.10 Installation On Ubuntu 12.04? (SOLVED)

Kdenlive-diamond
Registered Member
Posts
41
Karma
0
Installed from sunab repository. Never stops rendering 5 seconds .mov? Why missing DV module? I have libdv4 & libdv4-dev installed and I have tons of old DVs. How to return to 0.9.8 ? P.S. Rendering dialogs are strange?
Xubuntu 12.04

Last edited by Kdenlive-diamond on Thu Dec 11, 2014 12:30 pm, edited 1 time in total.
User avatar ttguy
Moderator
Posts
1152
Karma
6
OS
Backout instructions are here
User avatar ttguy
Moderator
Posts
1152
Karma
6
OS
Doco on new render dialog - here

Why missing DV module you ask? Hmmm. I have that flagged as missing too (ubuntu 14.04) in the config wizard that runs on first install ( Installed modules tab). But you will also note it says "required to work with dv files if avformat module is not installed". And on my install the line above in the config wizard it says for me Avformat module - Tick - yes installed. So based on that I should be able to use DV format files and I can.

What is your situation? Is Avformat module installed. And have you tried rendering DV files?
vpinon
KDE Developer
Posts
699
Karma
6
OS

Sun Oct 26, 2014 8:25 pm
hello
libdv has been disabled in MLT as libavcodec/format now include everything that libdv used to provide (and maybe more?).
we just should update the wizard to avoid the false warning.
(MLT mailing list is a good source of info in general, and especially these times: they are cleaning things and this induces notable changes)
Kdenlive-diamond
Registered Member
Posts
41
Karma
0
Sorry. I 've been away. I got shocked perhaps because of that wizard and I did not check that DV. But .movs to mpeg4 rendering crashed always on 0.9.10. Now back on 0.8.2.1 without problems, but I will make test again with 0.9.10.
Kdenlive-diamond
Registered Member
Posts
41
Karma
0
Now back on 9.10. It renders nothing to nothing. Mov or wmv or .. to any format. Why? Can this be fault of videocard? I cannot render, time goes to zero but it gives a 48k file only and never terminates.
User avatar Steve Guilford
Registered Member
Posts
207
Karma
0
Kdenlive-diamond wrote:Now back on 9.10. It renders nothing to nothing. Mov or wmv or .. to any format. Why? Can this be fault of videocard? I cannot render, time goes to zero but it gives a 48k file only and never terminates.


Probably not. There's a lot of moving parts involved in making Kdenlive work. Therefore, it's easy to get things out of synch. Ubuntu kinda FUBAR'd things by integrating LibAV instead of FFMpeg into the distro. This causes all sorts of problems.

If you can build 0.9.10 from source using the build script found on the MLT website that's the best way to go. Works well w/ Ubuntu 14.04 LTS.
Kdenlive-diamond
Registered Member
Posts
41
Karma
0
I cannot build it : Process has finished. Reason: FAILURE Some kind of error occured: Unable to git pull sources for x264

Edit: back to 0.8.2 I can at least render something again.
vpinon
KDE Developer
Posts
699
Karma
6
OS
How did you install Kdenlive & MLT : through sunab PPA?
When you have time, can you test exporting through a script, running it from a terminal, and examinate the output?
Kdenlive-diamond
Registered Member
Posts
41
Karma
0
I have tried sunabs and build scripts. Perhaps later I try to export by script. Now I have to work with this old version haaa.
User avatar Steve Guilford
Registered Member
Posts
207
Karma
0
Kdenlive-diamond wrote:I cannot build it : Process has finished. Reason: FAILURE Some kind of error occured: Unable to git pull sources for x264

Edit: back to 0.8.2 I can at least render something again.


"Unable to git pull sources for x264" - that seems to be the problem.

Did you do the following before trying to use the build script:

Code: Select all
sudo apt-get install git automake autoconf libtool intltool g++ yasm libmp3lame-dev libgavl-dev libsamplerate-dev libxml2-dev ladspa-sdk libjack-dev libsox-dev libsdl-dev libgtk2.0-dev liboil-dev libsoup2.4-dev libqt4-dev libexif-dev libvdpau-dev libdv-dev libtheora-dev libvorbis-dev subversion cmake kdelibs5-dev libqjson-dev libqimageblitz-dev recordmydesktop dvgrab dvdauthor genisoimage xine-ui libeigen3-dev xutils-dev libegl1-mesa-dev libfftw3-dev


You need to provide more information that will tell us why the build script was unable to get the x264 sources. Maybe 'git' is not installed on your system. Copy and paste the last few lines of the build script's output when it fails. That will help.
Kdenlive-diamond
Registered Member
Posts
41
Karma
0
Hi! Yes I installed those packages before using the build script . Yes I have git on Ubuntu. I Checked the script again but now after reinstalling 0.8.2 I may not have all the packages anymore?

LOG: Pulling git sources for x264
LOG: About to run command: git reset --hard
warning: unable to unlink common/aarch64/asm.S: Permission denied
warning: unable to unlink common/aarch64/dct-a.S: Permission denied...

WARNING: gnome-keyring:: couldn't connect to: /tmp/keyring-bcjiXc/pkcs11: No such file or directory

From git://git.videolan.org/x264
* branch master -> FETCH_HEAD
error: The following untracked working tree files would be overwritten by merge:
common/aarch64/asm.S
common/aarch64/dct-a.S
common/aarch64/dct.h
common/aarch64/deblock-a.S
common/aarch64/mc-a.S
common/aarch64/mc-c.c
common/aarch64/mc.h
common/aarch64/pixel-a.S
common/aarch64/pixel.h
common/aarch64/predict-a.S
common/aarch64/predict-c.c
common/aarch64/predict.h
common/aarch64/quant-a.S
common/aarch64/quant.h
Please move or remove them before you can merge.
Aborting
ERROR: Unable to git pull sources for x264
LOG: Process has finished. Reason: FAILURE Some kind of error occured: Unable to git pull sources for x264
User avatar Steve Guilford
Registered Member
Posts
207
Karma
0
warning: unable to unlink common/aarch64/asm.S: Permission denied
warning: unable to unlink common/aarch64/dct-a.S: Permission denied...


Why does the OS not want to delete these files? You may have to sudo in w/ root privs to scratch the x264 directory. Try that and report back.
Kdenlive-diamond
Registered Member
Posts
41
Karma
0
Ok! I changed the install dir to kdenlive2 and installed yasm 1.2.. Everything compiled ok. Rendering seems to work ok! I hope that everything Works now. Thanks.

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], boospy007, ericjs, gammazoid, Google [Bot], taha_mcp, Yahoo [Bot]