Reply to topic

Cannot launch kdenlive on opensuse leap 42.1

ipanteliemon
Registered Member
Posts
4
Karma
0
After a fresh install of opensuse leap 42.1 KDE and installing kdenlive 15.08.1, it does not start at all. The same on opensuse gnome DE.
What I should have done? Thank you.
User avatar qubodup
Registered Member
Posts
140
Karma
0
OS
We could use more info.

Open a terminal (aka console) and type in `kdenlive &> ohno.txt` and press enter.

You can then either copy-paste the content of the new text file into another post between [ code ] [ /code] tags here or upload it to http://pastebin.ca/upload.php (if it's too long?) and post a link here.
ipanteliemon
Registered Member
Posts
4
Karma
0
Icon theme "breeze" not found.
Icon theme "oxygen" not found.
Error: standard icon theme "oxygen" not found!
No LADSPA plugins were found!

Check your LADSPA_PATH environment variable.
ipanteliemon
Registered Member
Posts
4
Karma
0
After fixing the issues, mentioned in the ohno.txt, now the command you mention gives an empty file.
The only issue is after running the "kdenlive &> ohno.txt" a message appears in the console "segfault".
After all kdenlive still does not start.
P.S. The computer is a Fujitsu Celsius H710

Last edited by ipanteliemon on Thu Nov 05, 2015 3:56 pm, edited 1 time in total.
wolfi323
Registered Member
Posts
1125
Karma
11
OS
The problem is that libmlt in Leap is built against Qt4 by mistake.
(caused by the fact that Leap 42.1 has a lower version number in our buildsystem than 13.2, because it is partly based on SUSE Linux Enterprise 12 which got released before 13.2).
But kdenlive 15.08.1 is the KF5 based version, and uses Qt5. Qt5 applications just crash when they try to load Qt4...

As a workaround, try to install kdenlive 0.9.10 from here:
http://download.opensuse.org/repositori ... Leap_42.1/

And you probably should file a bug report at http://bugzilla.opensuse.org/, but I think we can handle this in https://bugzilla.opensuse.org/show_bug.cgi?id=930616 as well, which I will reopen in a minute.
ipanteliemon
Registered Member
Posts
4
Karma
0
Thank you Wolfy323! This worked!
Looking forward for the fix with the kdenlive 15.08.1!
wolfi323
Registered Member
Posts
1125
Karma
11
OS
ipanteliemon wrote:Thank you Wolfy323! This worked!

Great! :)

Looking forward for the fix with the kdenlive 15.08.1!

I already prepared "fixed" libmlt and frei0r-plugins packages, but I still have to wait until they have been built successfully before I can submit them.

I hope it will be possible to release them as update for Leap 42.1 then (I'm not sure yet about the update policy), but you should be able to get them anyway via Packman (with full codec support) once I submitted them.
wolfi323
Registered Member
Posts
1125
Karma
11
OS
PS: Packman does have a libmlt built against Qt5 already since a few hours.
So if you use that, you should switch back to kdenlive 15.08.1 again now.

One caveat though: frei0r-plugin as shipped with Leap (which is not hosted by Packman) will still cause a crash.
You can just uninstall it though for now if you have it installed, it is only a "recommended" package.

As mentioned, I will submit an update for Leap (for both packages), but this will take about a week until it is released.
User avatar ttguy
Moderator
Posts
1151
Karma
6
OS
No frie0r though will mean you will miss a bunch of effects and transitions.
wolfi323
Registered Member
Posts
1125
Karma
11
OS
ttguy wrote:No frie0r though will mean you will miss a bunch of effects and transitions.

Of course, but that's better than kdenlive crashing on startup... ;)

Anyway, the updated frei0r-plugins are available in the update test repo already, if you need the plugins install the package from here:
http://download.opensuse.org/update/leap/42.1-test/

You can take libmlt either from Packman, or from the same update test repo.
wolfi323
Registered Member
Posts
1125
Karma
11
OS
FYI, the updates to libmlt and frei0r-plugins have been released today.
So everything should work fine now with the standard packages, also when frei0r-plugins is installed.

The updated libmlt is even built with ffmpeg support now (you still need the uncrippled ffmpeg from Packman though for full codec support).

You might still prefer Packman's libmlt version though, this will be kept updated and comes with vidstab support as well (which is missing in the standard package due to legal uncertainties).

Oh, and a kdenlive (and in fact the whole KDE Applications) update to 15.08.3 has been released as well for Leap 42.1 today.

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], bartoloni, Belliric, Bing [Bot], Google [Bot], jmacleod, Kresimir, Majestic-12 [Bot]