Reply to topic

[ubuntu] KDEnlive crashing in certain conditions

gabmus
Registered Member
Posts
5
Karma
0
I don't know what's wrong, for some reason KDEnlive crashes every time I put a composite or affine transitions (probably the same with everything transparency related) between two clips along with a crop, scale & position effect on the top one. This was happening with my old MacBook running 13.04 before, and 13.10 later; and it's happening again on my new PC running 13.10. There are some things these PCs share: they both have NVidia graphic cards, with latest driver and latest X.Org server from the well known X.Org Edgers PPA. I don't think this may compromise kdenlive functionality, but who knows?
Anyway, here is a screenshot, note that it crashes when watch that piece of video with the transition.

http://i.imgur.com/2e7PTwL.jpg

Thank you in advance!
User avatar bcooksley
Administrator
Posts
18607
Karma
83
OS
Is it just Kdenlive which crashes, or does the whole desktop crash (and end up returning you to the login screen)?


System Settings and Device Actions KCM maintainer
Image
gabmus
Registered Member
Posts
5
Karma
0
Just kdenlive, but consider i use unity as de.
Then the kde bug tracker app pops up.
User avatar bcooksley
Administrator
Posts
18607
Karma
83
OS
Okay, I would suggest you check the other topics in this forum concerning the version of MLT you have installed on your system, and the source of your version of Kdenlive, as that may offer further information to solving the issue.


System Settings and Device Actions KCM maintainer
Image
gabmus
Registered Member
Posts
5
Karma
0
I don't see the point :\
Anyway, I am using KDEnlive version 0.9.6 and libmlt5 version 0.8.8 (that should be the latest stable one).
I can't figure out how to compile mlt 0.9.0, otherwise I would have done it. I'm quite familiar with compiling stuff, but when I get just a bit off the standard road, I fail.
Maybe I need mlt version 0.9.0? I'm looking for some tutorials on how to compile it.
gabmus
Registered Member
Posts
5
Karma
0
UPDATE: I tried to install mlt from this page, downloading the .deb files, but it needs libsox1b >=14.3.1. I checked in synaptic, apparently I have installed libsox2 14.4.1. Assuming it is the same package (is it?), it has for some reason a different name.
bodover
Registered Member
Posts
7
Karma
0
Having experienced similar problems, suggest you uninstall both kdenlive & mlt, then reinstall.
Fixed my problems.
gabmus
Registered Member
Posts
5
Karma
0
bodover wrote:Having experienced similar problems, suggest you uninstall both kdenlive & mlt, then reinstall.
Fixed my problems.

Doesn't work for me.
klaatu
Registered Member
Posts
13
Karma
0
I guess some more standard advice here...

    Uninstall kdenlive and mlt.
    Make sure Ubuntu is entirely up to date with an apt-get update and so on.
    Reinstall kdenlive and mlt

Also, what video driver are you using? If the application is crashing when attempting a composite, perhaps it's a video driver issue.

And finally, have you tried adding these same effects to different types of footage? in different projects with different project settings?

Also, what are the specs of your machine? (RAM, GPU, CPU, etc)

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], Dimitrios, Exabot [Bot], Google [Bot], hagabaka, Hans, koriun, La Ninje, lesterwaltz, Majestic-12 [Bot], mohali, msdobrescu, Steve Guilford, vascobasque, whatthefunk, Yahoo [Bot]