Reply to topic

Transition creates green tint on image

promis
Registered Member
Posts
4
Karma
0
Most obvious when using grayscale images. Not only on dissolve transition, but on any as well. When using composite transition changing alpha channel operation from "Over" to "And" or "Or" makes green tint disappear. The value of the opacity is not important, it could be zero, and as soon the transition reach its end point the green tint is gone. Some image examples:
Normal image:
Image
With dissolve transition
Image
It is annoying, when I just need simple dissolve I have to animate composite transition and change the alpha channel operation. Green tint is not just on project monitor it is there on rendered video too.


Kdenlive, Version 0.9.6 from sunab PPA
Ubuntu Studio 12.04
ttguy
Moderator
Posts
562
Karma
0
This is probably this bug http://kdenlive.org/mantis/view.php?id=2759
Which is actually a MLT bug http://sourceforge.net/p/mlt/bugs/198/
Apparently fixed in a recent version of MLT .

But noone has reported into mantis bug tracker if the new MLT version has fixed it
User avatar TheDiveO
Registered Member
Posts
150
Karma
0
My experience is that it hasn't been properly fixed, albeit this may actually a bug related to luma calculation for different alpha operations. But since I'm unsure, I didn't report to mlt ... I think this still is an mlt issue.


TheDiveO on YouTube: diving videos and aerial (quadcopter) videos, all made with Kdenlive.
TheDiveO Blog: know-how about Protune-grading in Kdenlive, GoPro HD Hero 3, DJI Phantom Quadcopter, full face mask diving, and some more...

 
Reply to topic

Bookmarks



Who is online

Registered users: Artmessiah, Baidu [Spider], Bing [Bot], Buddlespit, Exabot [Bot], garthecho, Google [Bot], Hans, koriun, La Ninje, valoriez, whatthefunk, Yahoo [Bot]