Reply to topic

Motion tracking bug or I'm doing something wrong ?

zabastodwa
Registered Member
Posts
20
Karma
0
Hello,

In my first words I want to thank you Kdenlive Team for Your great work!

In my video https://www.youtube.com/watch?v=8VbJgPFadJc&t=51&wide I used few points of Composite transition to get tracking effect for names VIDEO and PHOTO. For moving in straight lines elements it is sufficient way, but is quite inconvenient if the object is moving much more.

I found and read http://userbase.kde.org/Kdenlive/Manual ... /Auto_Mask and I have seen https://www.youtube.com/watch?v=2R2igZXKl-U and I decided to test it immediately.

I set Auto Mask, I set parameters and did Analyse... and bluring-mosaicking area working properly. I created Title clip with Affine transition and Import keyframes and then the problems started. All keyframes are moved on right side - left top corner of every keyframe is aligned to left top corner of mask - so my title clip goes off screen.

There is video: https://www.youtube.com/watch?v=oSMHxzOzN7w&wide

Image

Is it Kdenlive bug or I'm doing something wrong ?

Kdenlive 0.9.6 on Debian 7 wheezy

Have a nice day
Piotr


edit 1: I tried to use position effect for title clip but it is not best solution - if move too much on left title clip is cropped and disappears.
edit 2: Not tested yet, but I think after Analyse I can edit source file and move to up and left every keyframes by the value of top left space of first keyframe, but it is not way.


zabastodwa
Registered Member
Posts
20
Karma
0
In clip I found export/import options :) I wrote simple PHP parser for fix exported vectors file, next import fixed file to clip. Next import from clip to transiton.

video step by step: https://www.youtube.com/watch?v=YNcofmkpakE
final sample: https://www.youtube.com/watch?v=umjnb51e7N4


But the question is open - is it normal that after Analyse in Auto Mask always all my keyframes are moved to right, like on my videos?


User avatar ttguy
Moderator
Posts
818
Karma
4
OS
I had the same issue. So I think it is standard. You solve it by putting the title in the top right left corner of the title window.

Last edited by ttguy on Mon Mar 31, 2014 12:08 pm, edited 1 time in total.
Reason: i mean left
zabastodwa
Registered Member
Posts
20
Karma
0
Thanks, I test it.

In script I put position of first keyframe to variable, next first frame is changed to top/left 0, next rest keyframes one by one are changed - current top/left position minus position of top/left of first keyframe.


User avatar ttguy
Moderator
Posts
818
Karma
4
OS
Whoops. I should have said top left corner.
zabastodwa
Registered Member
Posts
20
Karma
0
of course left. I am looking for Auto Mask effect explain - is there manual, what exactly Auto Mask macroblock and max distance means

If clip have keyframes, after next, and next Analize there is only Merge and Add, why there is not Update/Overwrite existing?


User avatar ttguy
Moderator
Posts
818
Karma
4
OS
"why there is not Update/Overwrite existing"
Yeah. This could be a feature request. The work around is to delete tracking data from the clip properties dialog -
http://userbase.kde.org/Kdenlive/Manual ... cking_Data
zabastodwa
Registered Member
Posts
20
Karma
0
I found Export / Import / Remove metadata options [1:58] in Clip Properties but I am not sure that I right understood Auto Mask effect at first time. Maybe Update is not necessary. I clicked unnecessarily on the Analyse button everytime when Auto Mask effect was not satisfactory, instead only change position of yellow rectangle.

I should press Analyse only when I need to use later clip vectors as keyframes? is it right?


User avatar ttguy
Moderator
Posts
818
Karma
4
OS
I think it is kinda an all or nothing situation. But I might be wrong. I only played with it once to make my demo video.

I think you hit analyze and it does its stuff to try and track the object you drew your rectangle around the rest of the footage. This tracking data is stored with the clip. As I recall it - if you want a second bite of the cherry you need to delete the tracking data and run the analyse again. I seem to recall problems if you ran the analyse a second time without deleting the original data. But I am only going on memory. Maybe you can report your results.

 
Reply to topic

Bookmarks



Who is online

Registered users: andreas_k, Baidu [Spider], Bing [Bot], davidemme, Google [Bot], koriun, M4he, Majestic-12 [Bot], MSNbot Media, rv8ter, supaiku, Yahoo [Bot]