Reply to topic

Audio Sync Segmentation Fault

rsd
Registered Member
Posts
12
Karma
0

Audio Sync Segmentation Fault

Mon Aug 03, 2015 8:11 pm
Hello,

I am having a lot of audio sync issues after I upgrade to KDE5/Kubuntu 15.04.
Basically I can sync small clips, But when I start to work on very long one (1h45, 2h) it crashes.

I quick look into the backtrace it seems that all operations related to syncing is from kdenlive itself and not a 3rd library.

So, What I would like to know is,

Are you (anyone) doing Audio Sync without a probem?
If so, What are the size of the clips? Source and Reference, time length and file size, formats.
What version of kdenlive, kde and distribution?

Any other relevant information.

Thanks,

-rsd
vpinon
KDE Developer
Posts
652
Karma
5
OS

Re: Audio Sync Segmentation Fault

Tue Aug 04, 2015 9:49 am
Hello,
Did you post your backtrace on bugzilla or can you send a pastebin link?
Are you using Ubuntu Vivid repos (Kdenlive 0.9.10, MLT 0.9.2) or alternate source?
Was it working with similar files on other setup? (I don't think this part of the code has changed for long)
rsd
Registered Member
Posts
12
Karma
0

Re: Audio Sync Segmentation Fault

Tue Aug 04, 2015 3:47 pm
vpinon wrote:Hello,
Did you post your backtrace on bugzilla or can you send a pastebin link?
Are you using Ubuntu Vivid repos (Kdenlive 0.9.10, MLT 0.9.2) or alternate source?
Was it working with similar files on other setup? (I don't think this part of the code has changed for long)


https://bugs.kde.org/show_bug.cgi?id=350717

I am using vivid's kubuntu-backport, which might be the problem.
Used kdenlive from vivid (backport), sunab's stable and svn.

0.9.10 does not even start, probably because of -backport.

I am about to start some lxc containers (14.04, 14.10 and a clean 15.04) to test each.
But, FWICS, the audio sync wouldn't need an external lib, right?

-rsd
vpinon
KDE Developer
Posts
652
Karma
5
OS

Re: Audio Sync Segmentation Fault

Wed Aug 05, 2015 9:40 am
Hello,
When switching between Kdenlive 15.04 (Qt5) and Kdenlive 0.9.10 (Qt4), you must also switch libmlt package because it must be built with the same Qt version.
To have both installed at the same time I keep the distro Qt4 and manually build the Qt5 mlt+kdenlive as explained here:
https://community.kde.org/Kdenlive/Development/KF5

I think the problem is how we use dynamic allocation for sound samples that fail with so long vectors.
I should look for a safer approach...

BR,

Vincent
rsd
Registered Member
Posts
12
Karma
0

Re: Audio Sync Segmentation Fault

Wed Aug 05, 2015 9:29 pm
vpinon wrote:Hello,
I think the problem is how we use dynamic allocation for sound samples that fail with so long vectors.
I should look for a safer approach...


Any tips for a sound preprocessing that would make it safer for use in kdenlive?
vpinon
KDE Developer
Posts
652
Karma
5
OS
Except splitting your clips into <1h chunks I don't see for now
andreyneshta
Registered Member
Posts
20
Karma
0
OS

Re: Audio Sync Segmentation Fault

Tue Oct 27, 2015 8:05 pm
I can confirm - only pieces less than 1 hour can be set as reference. My external audio recorder configured for auto split every 55 mins - for Kdenlive 15.04 this works, but after upgrading to 15.08.02 I have this damned 'Segmentation fault' when I try to 'set as reference'. For now it's no matter how long is the piece of audio/video track, the program crashes every time. It is very disappointing me - a lots of videos need to be synced... Any ideas?
vpinon
KDE Developer
Posts
652
Karma
5
OS

Re: Audio Sync Segmentation Fault

Wed Oct 28, 2015 8:56 am
Hello,
Do you have a backtrace of this crash (running "gdb kdenlive", then "bt" after the crash)?
Thanks
andreyneshta
Registered Member
Posts
20
Karma
0
OS

Re: Audio Sync Segmentation Fault

Wed Oct 28, 2015 9:23 am
If I did all in the right way, then... http://pastebin.com/nrFZJ9qx

Last edited by andreyneshta on Wed Oct 28, 2015 10:53 am, edited 1 time in total.
vpinon
KDE Developer
Posts
652
Karma
5
OS

Re: Audio Sync Segmentation Fault

Wed Oct 28, 2015 10:18 am
Thanks, good!
This is a new problem introduced in commit 6462c3 (Jan 24, merged in 15.08), wrong argument to AudioEnvelope call.
I will try to fix it this evening, then you will have to build the code (instructions here)
andreyneshta
Registered Member
Posts
20
Karma
0
OS

Re: Audio Sync Segmentation Fault

Thu Oct 29, 2015 6:33 am
What code I need to build? MLT or Kdenlive? I'm not so good in it.
vpinon
KDE Developer
Posts
652
Karma
5
OS

Re: Audio Sync Segmentation Fault

Thu Oct 29, 2015 10:37 am
If you were already running Kdenlive 15.8, your MLT version is already OK; you only need to build Kdenlive.
I know it is not the easiest way, I will see with sunab if he can update his ppa, + I'm planning to look at other ways to deliver fresh packages (open build service) but it will wait for few days/weeks, maybe 15.8.3 will come earlier in your repo.
andreyneshta
Registered Member
Posts
20
Karma
0
OS

Re: Audio Sync Segmentation Fault

Thu Oct 29, 2015 11:49 am
Thanks, Vincent! Now it's OK with Audio Sync in manually built Kdenlive. Now waiting for official updates in repos.

UPD: It's OK in fresh 15.11

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], cylverbak, Don B. Cilly, funkyskywalker, gfielding, Google [Bot], ineuw, ipwizard, Majestic-12 [Bot], mawoka, maxmu, MRK0017, Sogou [Bot], sylvainrousseau, Yahoo [Bot]