Reply to topic

melt eats all memory after (or while) rendering a video

sebastians
Registered Member
Posts
1
Karma
0
I have debian wheezy on a 3GHz Core2Duo with 6 GB RAM and installed kdenlive (0.9.2) from the wheezy repository. Yesterday i made a video (3 minutes, 50 seconds) out of a bunch of mts files from my cam. Finally i rendered a 1080p 25fps .m2t file which worked without any problems!

Today i made some minimal changes in the timeline and then wanted to render a video again, but now melt seems to be crazy: It first renders the whole movie in perfect quality. At the moment the video is finished melt starts eating up all memory until the process is killed by the kernel due to out of memory. Kdenlive gives me a perfect video and a
Code: Select all
Rendering of /home/asdf/kdenlive/qwer.m2t crashed
[wav @ 0x7fd066fa95c0] max_analyze_duration reached
[wav @ 0x7fd06709f4c0] max_analyze_duration reached
[wav @ 0x7fd066f65b20] max_analyze_duration reached
[wav @ 0x7fd066f66280] max_analyze_duration reached
[wav @ 0x7fd06790dee0] max_analyze_duration reached
[wav @ 0x7fd0691fe240] max_analyze_duration reached
[wav @ 0x7fd06c792b80] max_analyze_duration reached
[wav @ 0x7fd06c7932c0] max_analyze_duration reached
[h264 @ 0x7fd079df3060] reference picture missing during reorder [h264 @ 0x7fd079df3060] Missing reference picture
[h264 @ 0x7fd084a6a880] reference picture missing during reorder [h264 @ 0x7fd084a6a880] Missing reference picture
[h264 @ 0x7fd090030180] reference picture missing during reorder [h264 @ 0x7fd090030180] Missing reference picture
[h264 @ 0x7fd084361240] reference picture missing during reorder [h264 @ 0x7fd084361240] Missing reference picture
[h264 @ 0x7fd07ed4a820] reference picture missing during reorder [h264 @ 0x7fd07ed4a820] Missing reference picture
[h264 @ 0x7fd08af1d000] reference picture missing during reorder [h264 @ 0x7fd08af1d000] Missing reference picture
[h264 @ 0x7fd0957e4060] reference picture missing during reorder [h264 @ 0x7fd0957e4060] Missing reference picture
[h264 @ 0x7fd0801591a0] reference picture missing during reorder [h264 @ 0x7fd0801591a0] Missing reference picture


You may say this is not a problem, because i get my videos rendered, but for me the out-of-memory is always very annoying. My first "workaround" was a "swapoff -a" before rendering. This makes the out-of-memory less painfull (because no crazy swapping-orgy will happen).

I then tried a more recent version (0.9.7 (rev. v0.9.6-134-g1f0072e)) that compiled with the "build-kdenlive.sh" on the first try! But with this version it was not possible to add any of my .mts files to a kdenlive project without remuxing it before (with 'ffmpeg -i MY.MTS -f mpegts -acodec copy -vcodec copy fixed_MY.MTS'). In addition rendering my project with this version is completely impossible. Melt starts eating all memory from the first moment. Only the first 15 seconds of my video are rendered until melt is killed by the kernel due to out-of-memory.

Any ideas what's going wrong here?
User avatar dode
Registered Member
Posts
78
Karma
0
OS
I remember having the memory issue you describe with some earlier Kdenlive version as well. I am not sure any more, but I think I had set "Processing threads >1" in "Configure->Environment", and setting it back to 1 solved the problem. I think it even was a confirmed bug in MLT.

However I know for sure that I don't have this problem with 0.9.7 even with "Processing threads >1" and rendering a lot of different projects, among them some using 1080p 50fps .mts video clips.

So I suppose that something is wrong with your 0.9.7 build (which version of MLT is it using?). Can't you use some .deb files to install the current version of Kdenlive?

 
Reply to topic

Bookmarks



Who is online

Registered users: alake, Baidu [Spider], Bing [Bot], brand, cylverbak, dgraf, Exabot [Bot], garthecho, glepore70, Google [Bot], google01103, Hans, jensreuterberg, kainz.a, koriun, Kver, La Ninje, mcaceres, MrGlaceon, MSNbot Media, nezumi, pbCyanide, pedrorodriguez, SecretCode, starbuck, Steve T, tparrott, Yahoo [Bot], šumski