Reply to topic

Transcoding projects / rendering timeline in DNxHD

User avatar sammuirhead
Registered Member
Posts
52
Karma
0
OS
Currently I'm trying to provide somebody else with my raw footage from a shoot which involved many interviews (h.264 1080p video, with a separate 16-bit wav audio track from the lavalier microphone). But rather than only give them the original unsynched files I thought I would also transcode the synched and tidied up answers from the interviewees as one DNxHD .mov file that they can edit on their Mac/FCP system.
I didn't transcode or use proxies for my edit, and I have the original synch clip saved as another version of my project. What I would like to do is import the earlier project (jugendhackt english interviews.kdenlive) into my current project (jugendhackt.kdenlive) and then right click on the imported project and choose >Transcode>DNxHD 1080p 25fps 185Mbs. But .kdenlive is not a supported filetype for transcoding.
So then I went back into project jugendhackt english interviews.kdenlive and decided to just render the timeline as DnxHD.
There's no DNxHD option as standard for rendering, so I created a new profile, DNxHD, with the extension mov and the same parameters (-s 1920x1080 -r 25 -vb 185000k -threads 2 -vcodec dnxhd -acodec copy) as the Transcode option.

Rendering sample sections of my timeline with these parameters produced very pixely results. (adding -mbd rd, for example, changed nothing) Is something wrong with my settings? or is there another way I could go about achieving this?

here's my finished video, by the way - it's about kids hacking with open data:
Young Rewired State in Berlin: Jugend Hackt (http://www.youtube.com/watch?v=gVSFyGU8gRk)
turn on captions if you don't speak German!


olive
Registered Member
Posts
12
Karma
0
Hi sammuirhead!

The appropriate parameters for rendering DNxHD185M (Pal/25p) should be:

f=mov mlt_profile=atsc_1080p_25 vb=185M vcodec=dnxhd acodec=pcm_s16le ar=48000k ac=2

or if you want to make a plain copy of your audio codec this should work:

f=mov mlt_profile=atsc_1080p_25 vb=185M vcodec=dnxhd acodec=copy

Cheers
olive
User avatar sammuirhead
Registered Member
Posts
52
Karma
0
OS
Hi Olive, thanks for your help!
With both of these options I receive an error message: unsupported audio codec = pcm or unsupported audio codec = copy
do you know what might be causing this? rendering without audio works fine.


olive
Registered Member
Posts
12
Karma
0
Hi sammuirhead!

In the Kdenlive settings (first page) you have to tick "Bypass codec verification", then it should work.

Cheers and good luck

olive
User avatar sammuirhead
Registered Member
Posts
52
Karma
0
OS

 
Reply to topic

Bookmarks



Who is online

Registered users: Alexa [Bot], Baidu [Spider], Bing [Bot], bshah, Exabot [Bot], Google [Bot], grubaugh, Hans, Naver Yeti [Spider], onesandzeros, orbmiser, pedrorodriguez, pvonz, qwach, searchfgold6789, Uri_Herrera, Yahoo [Bot]