Reply to topic

rendering crashes +system freeze only when using transitions

jmortimer
Registered Member
Posts
4
Karma
0
Hi, I can't get my project to render - and it seems to only happen when I add a disolve / wipe (I haven't tried other effects). Before I apply them rendering works fine. With them not a single profile will render properly. Instead the whole system freezes, the rendering never starts (stays at "Waiting") and after minutes or sometimes hours it aborts with the following message: "Rendering of (filename) aborted, resulting video will probably be corrupted." No further error message anywhere. The file is usually just 2,1MB in size or smaller, no matter how long rendering took.

Some facts: I'm on Kubuntu 13.10; Kdenlive 0.9.6; all updates installed. Does anyone have any ideas?

Thanks!
capslock
Registered Member
Posts
406
Karma
0
OS
Which repositories did you use for installing kdenlive and dependencies?
Can you start kdenlive from command line - what does kdenlive write out?
jmortimer
Registered Member
Posts
4
Karma
0
Thanks for helping, capslock.

When rendering successfully I get this:
Code: Select all
kdenlive %i -caption "%c" %u
QWidget::insertAction: Attempt to insert null action
QWidget::insertAction: Attempt to insert null action
"/org/freedesktop/UDisks2/drives/VBOX_CD_ROM_VB2_01700376" : property "Drive" does not exist
"/org/freedesktop/UDisks2/drives/VBOX_HARDDISK_VBca6b89bc_15e0fef3" : property "Drive" does not exist
"/org/freedesktop/UDisks2/drives/VBOX_HARDDISK_VBca6b89bc_15e0fef3" : property "DeviceNumber" does not exist
"/org/freedesktop/UDisks2/drives/VBOX_HARDDISK_VBca6b89bc_15e0fef3" : property "Device" does not exist
//STARTING RENDERING:  true , false , "/usr/bin/melt" , "hdv_1080_50i" , "avformat" , "-" , "/tmp/kde-adminuser/kdenliveSU1994.mlt" , "/home/adminuser/kdenlive/untitled.m2t" , () , ("f=mpegts", "acodec=mp2", "ab=384k", "ar=48000", "ac=2", "vcodec=mpeg2video", "s=1440x1080", "vb=25000k", "g=12", "trellis=1", "mlt_profile=hdv_1080_25p", "an=1", "threads=1", "real_time=-1") , -1 , -1
Started render process:  "/usr/bin/melt"   "/tmp/kde-adminuser/kdenliveSU1994.mlt -profile hdv_1080_50i -consumer avformat:/home/adminuser/kdenlive/untitled.m2t progress=1 f=mpegts acodec=mp2 ab=384k ar=48000 ac=2 vcodec=mpeg2video s=1440x1080 vb=25000k g=12 trellis=1 mlt_profile=hdv_1080_25p an=1 threads=1 real_time=-1"
Rendering of  "/home/name/kdenlive/untitled.m2t"  finished

When I render my project with the transitions it displays the same (but no last line "Rendering of "/home/name/kdenlive/untitled.m2t" finished"). It just stays there, system freezes. When the error ("Rendering ... aborted") comes my systems is responsive again. The "Rendering ... aborted" line shows up in command line, too, but nothing else.

My repositories are:
Code: Select all
deb http://us.archive.ubuntu.com/ubuntu/ saucy main restricted
deb-src http://us.archive.ubuntu.com/ubuntu/ saucy main restricted
deb http://us.archive.ubuntu.com/ubuntu/ saucy-updates main restricted
deb-src http://us.archive.ubuntu.com/ubuntu/ saucy-updates main restricted
deb http://us.archive.ubuntu.com/ubuntu/ saucy universe
deb-src http://us.archive.ubuntu.com/ubuntu/ saucy universe
deb http://us.archive.ubuntu.com/ubuntu/ saucy-updates universe
deb-src http://us.archive.ubuntu.com/ubuntu/ saucy-updates universe
deb http://us.archive.ubuntu.com/ubuntu/ saucy multiverse
deb-src http://us.archive.ubuntu.com/ubuntu/ saucy multiverse
deb http://us.archive.ubuntu.com/ubuntu/ saucy-updates multiverse
deb-src http://us.archive.ubuntu.com/ubuntu/ saucy-updates multiverse
deb http://us.archive.ubuntu.com/ubuntu/ saucy-backports main restricted universe multiverse
deb-src http://us.archive.ubuntu.com/ubuntu/ saucy-backports main restricted universe multiverse
deb http://security.ubuntu.com/ubuntu saucy-security main restricted
deb-src http://security.ubuntu.com/ubuntu saucy-security main restricted
deb http://security.ubuntu.com/ubuntu saucy-security universe
deb-src http://security.ubuntu.com/ubuntu saucy-security universe
deb http://security.ubuntu.com/ubuntu saucy-security multiverse
deb-src http://security.ubuntu.com/ubuntu saucy-security multiverse
deb http://extras.ubuntu.com/ubuntu saucy main
deb-src http://extras.ubuntu.com/ubuntu saucy main

Thanks!
capslock
Registered Member
Posts
406
Karma
0
OS
Well - I hope this output might help some (k)ubuntu users to help you. I am on archlinux and never used ubuntu.
Ubuntu users report the sunab ppa to be a good source for kdenlive - there are lots of hints here when you search for "sunab".
jmortimer
Registered Member
Posts
4
Karma
0
I see, indeed the user manual does suggest only using the Sunab repository. Right now there's no repository for 13.10 for some reason. I'll ask in the correct forum again. Thanks for helping, capslock!
jmortimer
Registered Member
Posts
4
Karma
0
One final note: Switching from the depreciated ubuntu repositories to Sunab's alternative repository solved this problem.

 
Reply to topic

Bookmarks



Who is online

Registered users: abhishekshah, alex-l, andersdalen, andreas_k, Baidu [Spider], Bing [Bot], boudewijn, capslock, cglwdm, claydoh, dinosath, Exabot [Bot], fneu, Google [Bot], google01103, jburnt, jmf, jpalacios, jstaniek, lazyit, liwaszkiewicz, Majestic-12 [Bot], MakoBasuri, revelmo2, subdiff, supaiku, TheraHedwig, tienhung, veqz, Yahoo [Bot]