Reply to topic

2-pass is unavailable? blurriness in slideshows?

emmanuelt
Registered Member
Posts
3
Karma
0
after upgrading my distribution I got a new kdenlive and now 2-pass rendering is constantly disabled.
I think it may be connected to CBR profiles not being available anymore: viewtopic.php?f=272&t=133300 (although I find that very confusing since I would think 2-pass rendering makes only sense with VBR).
Anyway I'm seeing I think too poor quality for slideshow clips (excessive blurriness I think), and I would like to try two-pass rendering. I've tried to make a CBR enabled render profile but the 2-pass checkbox is still grayed.
How could I get back the 2-pass option? Any other reason for perceived blurriness in slideshow clips?

EDIT: generated with the 'lossless' h264 profile and I still find the slideshows blurry.
emmanuelt
Registered Member
Posts
3
Karma
0
this is what I talk about when I say blurriness:
https://www.dropbox.com/s/tmurb8c4ter1d ... r.png?dl=0

NOTE: I'm using pan and zoom.
emmanuelt
Registered Member
Posts
3
Karma
0
OK I tracked it down. "pan and zoom, low-pass" is the problem. "Pan and zoom" is OK.
fighting a couple of bugs with edition of slideshow clips in 16.04.2 btw. Have to remove and re-add the clips for changes in configuration to have effect.

I would still be interested about the 2-pass settings though, I mean it really should allow better quality shouldn't it?
Pander
Registered Member
Posts
3
Karma
0
See also https://bugs.kde.org/show_bug.cgi?id=357722 for getting 2 pass enabled again.
Nox Diesque
Registered Member
Posts
5
Karma
0
OS
The linked bug is not resolved! The last two comments say 2-pass can still not be selected. And this is also what I experience with Version 18.08.0 under openSUSE Leap 15.0.
ghlargh
Registered Member
Posts
2
Karma
0
I searched for an hour for a solution to this problem with no luck but finally solved it by looking at the settings in an old version of kdenlive.

2 pass encoding works but there is no default profile included that supports it any more. You have to create a rendering profile with "pass=%passes" in it to activate 2-pass. You also cannot have the constant quality encoding mode (crf) but need the constant bandwidth mode (vb).

One more quirk is that you cannot render two files with the same name after each other, if you do you will end up with a file with no video.

Below is the string i mostly stole from an old version of kdenlive and that seems to work fine. To add this to a profile click on Render in the main window, select MP4, click "Create new profile" and swap out the text field. You may need to close and open the settings window for it to change to displaying "video bitrate" instead of "video quality"

properties=x264-medium f=mp4 vcodec=libx264 acodec=aac vb=%bitrate+'k' ab=%audiobitrate+'k' pass=%passes

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], boospy007, dhealey, Exabot [Bot], Google [Bot], jmaxwell, mx, retnev, tymond, UglyDog, Yahoo [Bot]