Reply to topic

High quality rendering

mitakeet
Registered Member
Posts
6
Karma
0

High quality rendering

Sun Jan 20, 2019 2:25 pm
I've filmed a feature (or, rather, the DP filmed it) using a Canon EOS C100 EF Cinema Camera. The raw imagery looks lovely, yet every time I render it, no matter what I've selected, I get tons of compression artifacts. Here is the information on an example of the raw file:

ffprobe version 2.8.15-0ubuntu0.16.04.1 Copyright (c) 2007-2018 the FFmpeg developers
built with gcc 5.4.0 (Ubuntu 5.4.0-6ubuntu1~16.04.10) 20160609
configuration: --prefix=/usr --extra-version=0ubuntu0.16.04.1 --build-suffix=-ffmpeg --toolchain=hardened --libdir=/usr/lib/x86_64-linux-gnu --incdir=/usr/include/x86_64-linux-gnu --cc=cc --cxx=g++ --enable-gpl --enable-shared --disable-stripping --disable-decoder=libopenjpeg --disable-decoder=libschroedinger --enable-avresample --enable-avisynth --enable-gnutls --enable-ladspa --enable-libass --enable-libbluray --enable-libbs2b --enable-libcaca --enable-libcdio --enable-libflite --enable-libfontconfig --enable-libfreetype --enable-libfribidi --enable-libgme --enable-libgsm --enable-libmodplug --enable-libmp3lame --enable-libopenjpeg --enable-libopus --enable-libpulse --enable-librtmp --enable-libschroedinger --enable-libshine --enable-libsnappy --enable-libsoxr --enable-libspeex --enable-libssh --enable-libtheora --enable-libtwolame --enable-libvorbis --enable-libvpx --enable-libwavpack --enable-libwebp --enable-libx265 --enable-libxvid --enable-libzvbi --enable-openal --enable-opengl --enable-x11grab --enable-libdc1394 --enable-libiec61883 --enable-libzmq --enable-frei0r --enable-libx264 --enable-libopencv
libavutil 54. 31.100 / 54. 31.100
libavcodec 56. 60.100 / 56. 60.100
libavformat 56. 40.101 / 56. 40.101
libavdevice 56. 4.100 / 56. 4.100
libavfilter 5. 40.101 / 5. 40.101
libavresample 2. 1. 0 / 2. 1. 0
libswscale 3. 1.101 / 3. 1.101
libswresample 1. 2.101 / 1. 2.101
libpostproc 53. 3.100 / 53. 3.100
Input #0, mpegts, from '018_C_2.MTS':
Duration: 00:02:37.66, start: 0.496578, bitrate: 23710 kb/s
Program 1
Stream #0:0[0x1011]: Video: h264 (High) (HDMV / 0x564D4448), yuv420p, 1920x1080 [SAR 1:1 DAR 16:9], 23.98 fps, 23.98 tbr, 90k tbn, 47.95 tbc
Stream #0:1[0x1100]: Audio: pcm_bluray (HDMV / 0x564D4448), 48000 Hz, stereo, s16, 1536 kb/s


Here's the head of the .kdenlive file:

<?xml version='1.0' encoding='utf-8'?>
<mlt LC_NUMERIC="en_US.UTF-8" title="Anonymous Submission" version="6.0.0" producer="main bin" root="/home/xxx">
<profile progressive="1" sample_aspect_num="1" display_aspect_den="9" frame_rate_num="24000" description="HD 1080p 23.98 fps" colorspace="709" frame_rate_den="1001" sample_aspect_den="1" width="1920" height="1080" display_aspect_num="16"/>


Even when I render with "properties=lossless/H.264" I still get lots of artifacts (the typical blocky look of mpeg). Here's an example screen grab of the raw:

http://keithalanwriter.com/TreasHu/Screenshot_raw.png

And the supposed lossless (not quite the same exact frame, but very close):

http://keithalanwriter.com/TreasHu/Scre ... ssless.png

I would like to render the entire flick (64 minutes) in the highest quality, ideally preserving the original imagery as much as possible, and only then worry about shrinking it to fit for various end products.

What settings can I use to accomplish this goal? And, once done, which are the best settings to get DVD and Bluray compression?

Version 15.12.3
Using:
KDE Frameworks 5.18.0
Qt 5.5.1 (built against 5.5.1)
The xcb windowing system

Thanks!

Mitakeet
Merlimau
Registered Member
Posts
599
Karma
5

Re: High quality rendering

Sun Jan 20, 2019 4:25 pm
It’s a bit difficult to say. The Canon EOS C100 saves 8bit color space, so it fits to MLT/Kdenlive. It could be a mismatch between the version of FFMPEG and Kdenlive (15.12.3?) and Ubuntu (16.04.1). If this happens I suggest updating Ubuntu to the actual status and downloading the current Kdenlive AppImage 18.12.1b and make a test with your footage.

Settings for DVD -> MPEG.
Settings for Bluray -> MP4.
mitakeet
Registered Member
Posts
6
Karma
0

Re: High quality rendering

Sun Jan 20, 2019 7:31 pm
Thanks @Merlimau, the appimage produced a beautiful render, lossless as well as mp4 (I'm trying the mpg now). The only wrinkle: the static jpg images I have render as just white squares. They show up in the timeline, but not in the render. Any suggestions? I suppose I could try rendering those portions with the old version (I have probably a half dozen instances of static images, jpg and png).

I really appreciate the fast response!
Merlimau
Registered Member
Posts
599
Karma
5

Re: High quality rendering

Sun Jan 20, 2019 7:47 pm
Glad to hear it works. Yes, JPG rendering is an issue under the Windows version but should be solved with the 18.12.1b version under Linux.

To solve that you can do 3 things:
- Run the Appimage from the terminal (press CTRL + ALT + T). Move to the AppImage folder and run the .AppImage: ./Kdenlive*.AppImage.
- update your distro to the actual status.
- If this still not solves the problem convert the JPG to PNG. PNG should render.
mitakeet
Registered Member
Posts
6
Karma
0

Re: High quality rendering

Sun Jan 20, 2019 7:52 pm
I'll try png, that's easy. I just started to render my whole project, but it's been sitting there 'waiting' now for probably 20 minutes. Something called 'melt' is running, sucking up a whole CPU, so I guess I should just wait, but the old version started actual rendering within a minute or two.
mitakeet
Registered Member
Posts
6
Karma
0

Re: High quality rendering

Sun Jan 20, 2019 7:54 pm
Never mind, it finally started to render. The estimate is over 4 hours (mp4), but if it produces beautiful output like it did on the sample, it'll be worth it.

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], boudewijn, camoore, Exabot [Bot], Google [Bot], joshiravi, Majestic-12 [Bot], Yahoo [Bot]