Reply to topic

Let me turn off the taskbar shadow!

thorbsd
Registered Member
Posts
20
Karma
0

Let me turn off the taskbar shadow!

Thu Jun 12, 2014 8:16 pm
I use the taskbar on the left side of the screen and I HATE that damn shadow that gets placed over the active window! The shadow is totally unobtrusive when the taskbar is on the bottom of the screen, but it's a horrible distraction when the taskbar is on the left.

PLEASE let me turn the taskbar shadow off in this new version of KDE!
User avatar Hans
Administrator
Posts
3304
Karma
23
OS
Rather than making an option for it, would it help if the shadow of vertical panels was tweaked to be less distracting?


Problem solved? Please click on "Accept this answer" below the post with the best answer to mark your topic as solved.

10 things you might want to do in KDE | Open menu with Super key | Mouse shortcuts
User avatar scummos
Global Moderator
Posts
1134
Karma
7
OS
Should there be a shadow at all? I don't think you ever want shadows which go over windows which have focus ...


I'm working on the KDevelop IDE.
luebking
Karma
0
try
Code: Select all
xprop -remove _KDE_NET_WM_SHADOW
, then click the panel with the '+' shape cursor.

Clipping the active window from shadows would be possible, but very quickly destroy the 3D/Layer illusion (the shadow would be no shadow, but just some weird outline) - especially because the active window can be occluded by other windows (but not their shadows ...)

My personal preference on panel shadows is to have them on the desktop/layer (what works visually until one moves a window below the panel)
thorbsd
Registered Member
Posts
20
Karma
0
Hans wrote:Rather than making an option for it, would it help if the shadow of vertical panels was tweaked to be less distracting?


My opinion is that when the panel is vertical, any shadow is distracting if it's covering the window I'm currently working in (no matter how small that shadow might be). It seems like such a small thing to be bothered by, but it really bothered me in KDE 4 :p

However you guys want to set your defaults is totally fine, I would just really like it if there was an option to turn it off.

luebking wrote:try
Code: Select all
xprop -remove _KDE_NET_WM_SHADOW
, then click the panel with the '+' shape cursor.


No more shadow! That's perfect! (I'm using Plasma Beta 2)
User avatar Hans
Administrator
Posts
3304
Karma
23
OS
thorbsd wrote:
Hans wrote:Rather than making an option for it, would it help if the shadow of vertical panels was tweaked to be less distracting?


My opinion is that when the panel is vertical, any shadow is distracting if it's covering the window I'm currently working in (no matter how small that shadow might be). It seems like such a small thing to be bothered by, but it really bothered me in KDE 4 :p

However you guys want to set your defaults is totally fine, I would just really like it if there was an option to turn it off.


Thing is, more options is not always the answer:
- It adds clutter to the configuration dialog, which makes it harder to find the relevant options.
- It adds code complexity and is just another thing to maintain.

In this case it sounds like something that should be fixed rather than provided as an option. I don't use any panels with shadows so I don't know how it looks like, but maybe it would be better to not show shadows for vertical panels at all, as mentioned above.

Come to think about it, I think I've seen similar complaints for panels place at the top. It makes sense that the shadow would fall on the window since technically the panel is above the window (if you move the window over the panel it'll go below), but this definitely sounds like something that the Visual Design Group should take a look at. I personally think that "minor" annoyances like this one matters a lot for the overall user experience.


Problem solved? Please click on "Accept this answer" below the post with the best answer to mark your topic as solved.

10 things you might want to do in KDE | Open menu with Super key | Mouse shortcuts
thorbsd
Registered Member
Posts
20
Karma
0
Well, if it's something that comes down to the shadow staying or going, it should absolutely go.

The shadow is unobtrusive only when the panel is along the bottom. If the panel is located along any other edge (top, left, or right), the shadow casts itself on top of the full screen active window and is very distracting. You can make the argument that the panel is technically "on top", but this is a case where being technically correct leaves you with something that just doesn't look good. Maybe I could also try to win this by saying that when I'm using my computer, it should be assumed that the light that is illuminating my desktop should be assumed to be directly overhead which would mean that no shadow would be cast anyway.

Please get rid of the shadow! Lol...
thorbsd
Registered Member
Posts
20
Karma
0
luebking wrote:try
Code: Select all
xprop -remove _KDE_NET_WM_SHADOW
, then click the panel with the '+' shape cursor.


Is it possible to pass mouse coordinates to this command so that I don't have to manually click on the panel and instead just make this a script that runs when I log in?
luebking
Karma
0
Nope, but the WId. You'll have to grab it out of "xwininfo -root -tree":

Code: Select all
for WID in `xwininfo -root -tree | sed '/"plasma-desktop": ("Plasma" "Plasma")/!d; s/^  *\([^ ]*\) .*/\1/g'`; do
   xprop -id $WID -remove _KDE_NET_WM_SHADOW
done
thorbsd
Registered Member
Posts
20
Karma
0
luebking wrote:Nope, but the WId. You'll have to grab it out of "xwininfo -root -tree":

Code: Select all
for WID in `xwininfo -root -tree | sed '/"plasma-desktop": ("Plasma" "Plasma")/!d; s/^  *\([^ ]*\) .*/\1/g'`; do
   xprop -id $WID -remove _KDE_NET_WM_SHADOW
done


This is PERFECT! I smile every time I see that shadow disappear!

Thank you.
savedario
Registered Member
Posts
1
Karma
0
Hi there,

I know this is an old thread, but just to help someone like me that uses the main panel at the top.
I'm not a Mac-fan, just lazy.
I find that since 90% of the menus are at the top of the screen, placing the main panel at the bottom forces me to go back and forth.

Anyway:

- All shadows disappear when "Desktop Effects" are disabled.
- This answer: http://askubuntu.com/questions/194001/remove-panel-shadow-in-kde-4-8 shows how to duplicate a chosen Desktop Theme and remove shadows.
lokeshj
Registered Member
Posts
1
Karma
0
luebking wrote:Nope, but the WId. You'll have to grab it out of "xwininfo -root -tree":

Code: Select all
for WID in `xwininfo -root -tree | sed '/"plasma-desktop": ("Plasma" "Plasma")/!d; s/^  *\([^ ]*\) .*/\1/g'`; do
   xprop -id $WID -remove _KDE_NET_WM_SHADOW
done



This was not working for me. After a bit of troubleshooting I found that the window information seems to have changed in the subsequent versions. The following code worked for me:

Code: Select all
for WID in $(xwininfo -root -tree | sed '/"Plasma": ("plasmashell" "plasmashell")/!d; s/^  *\([^ ]*\) .*/\1/g'); do
   xprop -id $WID -remove _KDE_NET_WM_SHADOW
done
luebking
Karma
0
The window class changed between KDE 4 and KDE 5, yes.

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], cmb, emonhaque, farid, Google [Bot], offpics, pasis, vperez, Yahoo [Bot]