Reply to topic

Tools Docker taking too much space in 2.9.

cestarian
Registered Member
Posts
88
Karma
0
OS
I hate this width to no end:

Image

In Krita 2.8 I had one vertical column with all of the tools, in 2.9 things just turned messy, there's a mountain of wasted space down there.

And it annoys me to death that I cannot fix this inefficiency. :( This might just be an OCD thing, but I really hate how the tools are taking up more pixel width of what could have been my canvas than they really need to.
User avatar boudewijn
KDE Developer
Posts
4635
Karma
19
OS
Weirdly enough, on Linux I can still go back to one column, but on Windows, if the laptop is sufficiently high-res the minimum seems to be three columns. It's irritating as hell, and I've spent at least two days trying to figure out what was going on before dropping the issue in favourof fixing a bunch of crash bugs.

What I'd like to do is drop the entire custom layout code and go to something where the user manually selects the grid size, and then use Qt's layout code to keep everything sane. That, or move away from a custom toolbox and just use ordinary toolbars.
User avatar boudewijn
KDE Developer
Posts
4635
Karma
19
OS
Oh. It's a style issue, figures. With the oxygen style, it's fine, with plastique (which is the default on Windows and OSX, and used on Linux if oxygen isn't installed), the size hint is broken.
User avatar boudewijn
KDE Developer
Posts
4635
Karma
19
OS
I've got sort of a patch, but it only works if you resize the docker really quickly for some reason. Otherwise, plastique's window titlebar decoration (the grab dots) keep it big.
User avatar mmolch
Registered Member
Posts
20
Karma
0
My guess on this is that the docker titlebar is responsible for that. I think it should always report 0 for the minimum width.

Something like
QSize KoDockWidgetTitleBar::minimumSizeHint() const
{
return QSize(0, sizeHint().height());
}
should solve it.

I always ended up with a 2 column toolbar after restarting krita when I still had the titlebars and it seems that it is a widely spread problem (look e.g. at the toolbar in the image here e.g. http://www.cgchannel.com/2015/02/krita-2-9-ships/ . I think I've never seen a screenshot in a review where the toolbar was nicely lined up on the left.)

Kind regards
cestarian
Registered Member
Posts
88
Karma
0
OS
Thanks for looking into this boudewijn 8)

I was on Linux, but using Enlightenment 19 as a desktop environment. My GUI style is set to GTK+ to make the theme match my GTK application settings. Oxygen is not available by default it would seem (I'd have to install it separately)

I downloaded the latest git source, I still cannot minimize the width of the tool bar.

And for the above post, I have had my tool bar nicely lined up on the left in 2.8, not sure if I have any screenshots lying around though.

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], claydoh, franzhall, Google [Bot], Jice, raul_l, Snudl, vinnywright