Reply to topic

plasmashell high CPU load

ndc333
Registered Member
Posts
16
Karma
0

Re: plasmashell high CPU load

Thu Dec 08, 2016 4:59 pm
aordev wrote:Unfortunately i can only confirm that the bug still present in plasmashell 5.7.4. Running on fully updated Debian Stretch,

The bug occurs every time when a file is being copied using Dolphin. Copying of 4Gb movie loads one of 4 cpu cores. Same problem on my 2(4) cores laptop -- copying or setting up wifi eats up CPU. Let me know if I can provide additional info.


the modification of /usr/share/apps/plasma/plasmoids/org.kde.notifications/contents/ui/NotificationIcon.qml as suggested by digitalone solves this.
bashar
Registered Member
Posts
2
Karma
0

Re: plasmashell high CPU load

Sat Jan 28, 2017 2:48 pm
Same problem here.
Plasma: 5.5.5
Ubuntu 16.04.1
For me it happens only when i run for a long time vms using VMWare Workstation.
bashar
Registered Member
Posts
2
Karma
0

Re: plasmashell high CPU load

Sun Jan 29, 2017 1:50 pm
It seems i solved my problem.
I applied the solution with the modification of /usr/share/apps/plasma/plasmoids/org.kde.notifications/contents/ui/NotificationIcon.qml
but also in Vmware Workstation i disabled any use of a tray icon. When tray icon was enabled and i opened vmware, 2 icons appeared, one blank square and the normal vmware icon.
Don't know which one solved the high cpu load of plasmashell but the problem is solved, 24+h of running virtual machines, copying stuff etc and plasmashell under 2% most of the time.
mindaugasc
Registered Member
Posts
4
Karma
0

Re: plasmashell high CPU load

Fri Feb 10, 2017 2:51 pm
Same here. KDE Plasma version 5.9.1, KDE Neon. This thread was opened in June 2014. Now February 2017 and the problem isn't fixed yet. How could that be possible? :< So, i applied the solution with the modification of /usr/share/apps/plasma/plasmoids/org.kde.notifications/contents/ui/NotificationIcon.qml
I found a workaround here: https://bugs.kde.org/show_bug.cgi?id=311799.
Open file /usr/share/plasma/plasmoids/org.kde.plasma.notifications/contents/ui/NotificationIcon.qml
Search for line "running: visible" in "PlasmaComponents.BusyIndicator" section and change it in "running: false".
That seems to work for me. Now 1-2% cpu load for plasmashell process with cpu and network monitor on right bar in Plasma Desktop.

and my problem solved.
Griz
Registered Member
Posts
2
Karma
0

Re: plasmashell high CPU load

Sun Apr 09, 2017 10:56 pm
Can confirm, Ubuntu 16.10 with plasma-workspace Version: 4:5.8.5-0ubuntu2~ubuntu16.10~ppa2

Changed file
Code: Select all
/usr/share/plasma/plasmoids/org.kde.plasma.notifications/contents/ui/NotificationIcon.qml



Code: Select all

        PlasmaComponents.BusyIndicator {
            anchors.fill: parent

            visible: jobs ? jobs.count > 0 : false
            running: active
        }

to:

Code: Select all

        PlasmaComponents.BusyIndicator {
            anchors.fill: parent

            visible: jobs ? jobs.count > 0 : false
            running: false
        }



After setting PlasmaComponents.BusyIndicator's "running" flag from active to false and restarting plasma:
Code: Select all
kquitapp5 plasmashell && kstart plasmashell
usage dropped from 300% to 2%. (8 cores). Most notably, the CPU fan stopped going spastic, and my desk stopped shaking, win! :)
Griz
Registered Member
Posts
2
Karma
0

Re: plasmashell high CPU load

Tue Apr 11, 2017 4:44 am
Griz wrote:Can confirm, Ubuntu 16.10 with plasma-workspace Version: 4:5.8.5-0ubuntu2~ubuntu16.10~ppa2

Changed file
Code: Select all
/usr/share/plasma/plasmoids/org.kde.plasma.notifications/contents/ui/NotificationIcon.qml



Spoke too soon.. It's the next day, and usage isn't as high, but it's using two cores.. one 95% another 40%.

Restarting plasma fixed it again.. I'm thinking changing that file did nothing, but restarting plasma seems to work. Might schedule a restart every 24 hours or something.
npeters
Registered Member
Posts
2
Karma
0

Re: plasmashell high CPU load

Sun May 14, 2017 4:18 pm
I'm having a similar issue and have spent weeks trying to solve the high CPU with plasmashell problem!

CPU usage starts at 2-3% and gradually climbs until the system is sluggish, and the CPU usage is typically from 20% to 150%.

The only thing that I've found that helps is restarting plasmashell.

I've updated and cleaned everything I can think of, and tried all the various "fixes" that were offered by others, but nothing seems to solve the issue.

I've read dozens of reports of this same issue occurring with plasmashell (over many years) and wonder if there is not some sort of definitive way to diagnose and potentially solve this very common issue?

I'm a big fan of KDE and would hate to have to abandon it because of this seemingly intractable problem :(

Anyone with ideas on how to solve this issue please let me know?
User avatar compatico
Registered Member
Posts
58
Karma
0
OS

Re: plasmashell high CPU load

Fri May 19, 2017 2:02 am
npeters wrote:I'm having a similar issue and have spent weeks trying to solve the high CPU with plasmashell problem!
CPU usage starts at 2-3% and gradually climbs until the system is sluggish, and the CPU usage is typically from 20% to 150%.

This is a known bug in Plasmashell that should be fixed in Plasma 5.8.6 which is now live. I just updated today and so far it seems better. But copying a large file from one drive to another still causes 1 CPU core to peg at 100% until the operation finishes, so I don't think they fixed it yet.
npeters
Registered Member
Posts
2
Karma
0

Re: plasmashell high CPU load

Wed May 24, 2017 7:04 pm
compatico wrote:
npeters wrote:I'm having a similar issue and have spent weeks trying to solve the high CPU with plasmashell problem!
CPU usage starts at 2-3% and gradually climbs until the system is sluggish, and the CPU usage is typically from 20% to 150%.

This is a known bug in Plasmashell that should be fixed in Plasma 5.8.6 which is now live. I just updated today and so far it seems better. But copying a large file from one drive to another still causes 1 CPU core to peg at 100% until the operation finishes, so I don't think they fixed it yet.


I'm running 5.8.6 and the issue is still there. I also have another newly setup kubuntu system where plasmashell keeps gobbling ram until the point my system basically freezes.

Restarting plasmashell seems to solve the issue, but Xorg is still using over 1.2GB of ram and it looks like a reboot will be needed to solve that problem.

I see there are hundreds of similar reports about plasmashell with "unresolved" RAM and CPU issues -- over many years :(

Is this product ever going to be fixed or is it time to look for another desktop?
User avatar compatico
Registered Member
Posts
58
Karma
0
OS

Re: plasmashell high CPU load

Thu May 25, 2017 2:45 am
npeters wrote:I'm running 5.8.6 and the issue is still there. I also have another newly setup kubuntu system where plasmashell keeps gobbling ram until the point my system basically freezes.
Restarting plasmashell seems to solve the issue, but Xorg is still using over 1.2GB of ram and it looks like a reboot will be needed to solve that problem.
I see there are hundreds of similar reports about plasmashell with "unresolved" RAM and CPU issues -- over many years :(
Is this product ever going to be fixed or is it time to look for another desktop?

I had constant problems with Neon and this bug, and the too frequent updates forced me to ditch it and go back to Kubuntu. I did a clean install of 16.04 a few months ago and as long as Boinc Manager is not running (the Boinc app runs in the background just fine) I don't seem to have any issues beyond high CPU usage such as file transfers. I don't need to copy big files that often so some high CPU usage here and there isn't a serious issue (8xCPU) as it doesn't really affect user performance. As it stands, Kubuntu with Plasma 5.8.6 is usable for me...but this bug has been around far too long and needs to be squashed.
treczoks
Registered Member
Posts
1
Karma
0

Re: plasmashell high CPU load

Thu May 25, 2017 9:36 pm
This plasma shell CPU hogging is also getting on my nerves. Kubuntu 16.04, Plasma Shell 5.5.5, and it currently eats 75 to 80%. System is basically unusable.
User avatar compatico
Registered Member
Posts
58
Karma
0
OS

Re: plasmashell high CPU load

Thu May 25, 2017 11:20 pm
treczoks wrote:This plasma shell CPU hogging is also getting on my nerves. Kubuntu 16.04, Plasma Shell 5.5.5, and it currently eats 75 to 80%. System is basically unusable.

Have you tried updating to a newer Plasma version? Version 5.5.5 is pretty old in the Linux world and they may have improved it with newer code. It's not fixed in 5.8.6 but Plasma improves a fair bit with each point update.
User avatar juan-lutz
Registered Member
Posts
7
Karma
0

Re: plasmashell high CPU load

Tue Jun 06, 2017 12:00 pm
I have realized similar behavior since the update to KDE Plasma 5.10.2 with QT 5.9 ...
CPU usage over 100% and the temperature rises also over 80°C ...! Fan is loud and worked trying to keep the temperature low.
I am a user of OS Leap 42.2. and a linux user since decades.
This kind of problem I didn't face it in the past nor for any old KDE versions.
Anyhow, after many test and trials, .... I found the CPU usage jump out of range after I activate any desktop wallpaper effects like "diashow" or "hunyango" ...
I didn't find any effect related with any widget I am using.
So to have a quite system I disabled this effect.

Last edited by juan-lutz on Mon Jun 19, 2017 12:02 pm, edited 1 time in total.
nathanol
Registered Member
Posts
2
Karma
0

Re: plasmashell high CPU load

Thu Jun 15, 2017 9:12 am
Same issue here with a CPU at > 80% for plasmashell.
kwin_x11 is also at > 50% even when doing nothing.
Xorg is the third CPU high usage process zith > 40%.
I am running KDE 5.10.2, Qt 5.9.0, Linux 9.9.31-1-lts, Archlinux (64-bits).

I have tried to change the values of the Notification qml file and restarted but it did not change anything for me.
User avatar juan-lutz
Registered Member
Posts
7
Karma
0

Re: plasmashell high CPU load

Thu Jun 15, 2017 2:08 pm
nathanol wrote:Same issue here with a CPU at > 80% for plasmashell.
kwin_x11 is also at > 50% even when doing nothing.
Xorg is the third CPU high usage process zith > 40%.
I am running KDE 5.10.2, Qt 5.9.0, Linux 9.9.31-1-lts, Archlinux (64-bits).

I have tried to change the values of the Notification qml file and restarted but it did not change anything for me.


Hello, So after other little problems I realized with KDE Plasma 5.10 ( i.e. icons disappeared in the systray ... for instance Thunderbird ), I downgrade it to the LTS version KDE PLASMA 5.8. and QT 5.6
The system run now without any High CPU load.
I could even re-activate the diashow wallpaper without any problem.
I will wait with an upgrade of KDE or better wait for the next LEAP Version !
Have fun and a happy day.

 
Reply to topic

Bookmarks



Who is online

Registered users: Bing [Bot], Exabot [Bot], Google [Bot], jackdinn, kde-cfeck, La Ninje, lueck, ramdanifajar, slumpgod, Sogou [Bot], Yahoo [Bot]