Reply to topic

Plasma 5/Qt5 applications keep crashing

workoft
Registered Member
Posts
94
Karma
1
Hi everyone,
This problem may or may not be KDE specific.
With no particular reason, plasma 5 applications started to keep crashing today. KWin kept crashing, drkonqi kept crashing at the same time, so I couldn't get a backtrace of the crash. Plasmashell crashed occasionally. I could sometimes calm them down by killing and launching KWin from the console. Then I had to be careful not to launch any KF5 based applications or it would start all over again. So I decided to just rename all config files and try again. Now at least the session starts with a few crashes, but by itself. Systemsettings only crashes on exit. Yakuake works again, but Konsole crashes. Kinfocenter crashes. Otter crashes, but it used to crash quite often anyway. Just normally not on startup. Anything that isn't Qt5 based seems to work fine, but even when I was running emerge a couple of reboots ago it would quit saying "interrupted".
Although drkonqi still crashes most of the time, I managed to get a backtrace of systemsettings crashing:
Code: Select all
Application: System Settings (systemsettings), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[KCrash Handler]
#6  0x00007f2719664451 in QHashData::free_helper (this=0x7f27198a33d0 <QListData::shared_null>, node_delete=0x7f271a464090 <QHash<QWindow*, QGuiApplicationPrivate::SynthesizedMouseData>::deleteNode2(QHashData::Node*)>) at tools/qhash.cpp:492
#7  0x00007f271a45a20f in freeData (this=<optimized out>, x=<optimized out>) at ../../include/QtCore/../../src/corelib/tools/qhash.h:600
#8  ~QHash (this=0x1acba60, __in_chrg=<optimized out>) at ../../include/QtCore/../../src/corelib/tools/qhash.h:310
#9  QGuiApplicationPrivate::~QGuiApplicationPrivate (this=0x1acb960, __in_chrg=<optimized out>) at kernel/qguiapplication.cpp:1298
#10 0x00007f271abc5ec9 in QApplicationPrivate::~QApplicationPrivate() () from /usr/lib64/libQt5Widgets.so.5
#11 0x00007f27198218d6 in cleanup (pointer=<optimized out>) at ../../include/QtCore/../../src/corelib/tools/qscopedpointer.h:62
#12 ~QScopedPointer (this=0x7fff2a7065d8, __in_chrg=<optimized out>) at ../../include/QtCore/../../src/corelib/tools/qscopedpointer.h:109
#13 QObject::~QObject (this=<optimized out>, __in_chrg=<optimized out>) at kernel/qobject.cpp:880
#14 0x00007f271abc7712 in QApplication::~QApplication() () from /usr/lib64/libQt5Widgets.so.5
#15 0x00000000004107e7 in main ()

All I can think of is that I just re-emerged qtwidgets yesterday because of USE Flag changes.

edit: this is what I get when I run KDE-applications from the command line:
Code: Select all
KCrash: Application 'konsole' crashing...
KCrash: Attempting to start /usr/lib64/libexec/drkonqi from kdeinit
sock_file=/var/run/user/1000/kdeinit5__0

Otter just says "Segmentation fault"

edit2: If I start the applications as root they only crash on exit

edit3: It seems it's everything that's using qtwidgets5. plasmashell runs fine until I right-click somewhere and hover the appearing menu, kwin the same.

edit4: so I just moved ALL my user configuration and then applications just crashed on exit, just like they do when run as root. The real problem seems to be somewhere else.

edit5:
here's another backtrace. The crash of the first backtrace occured on exit, just after I moved my configuration, this one is what happens right after starting applications.
Code: Select all
#0  0x00007ffff46d29ce in QAbstractEventDispatcherPrivate::releaseTimerId(int)
    () from /usr/lib64/libQt5Core.so.5
#1  0x00007ffff46d3379 in QBasicTimer::stop() ()
   from /usr/lib64/libQt5Core.so.5
#2  0x00007ffff5ab9962 in QApplication::notify(QObject*, QEvent*) ()
   from /usr/lib64/libQt5Widgets.so.5
#3  0x00007ffff46d5acd in QCoreApplication::notifyInternal(QObject*, QEvent*)
    () from /usr/lib64/libQt5Core.so.5
#4  0x00007ffff534f592 in sendSpontaneousEvent (event=0x7fffffffd860,
    receiver=<optimized out>)
    at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:240
#5  QGuiApplicationPrivate::processActivatedEvent (e=0x851f80)
    at kernel/qguiapplication.cpp:1907
#6  0x00007ffff534f8e5 in QGuiApplicationPrivate::processWindowSystemEvent (
    [email protected]=0x851f80) at kernel/qguiapplication.cpp:1537
#7  0x00007ffff5335e88 in QWindowSystemInterface::sendWindowSystemEvents (
    flags=...) at kernel/qwindowsysteminterface.cpp:579
#8  0x00007fffeb12e540 in userEventSourceDispatch (source=<optimized out>)
    at eventdispatchers/qeventdispatcher_glib.cpp:78
#9  0x00007fffef6e28d4 in g_main_context_dispatch ()
   from /usr/lib64/libglib-2.0.so.0
#10 0x00007fffef6e2b18 in ?? () from /usr/lib64/libglib-2.0.so.0
#11 0x00007fffef6e2bbc in g_main_context_iteration ()
   from /usr/lib64/libglib-2.0.so.0
#12 0x00007ffff472ebbc in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQt5Core.so.5
#13 0x00007ffff46d390b in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQt5Core.so.5
#14 0x00007ffff46db31f in QCoreApplication::exec() ()
   from /usr/lib64/libQt5Core.so.5
#15 0x00000000004107cd in main (argc=1, argv=<optimized out>)
    at /var/tmp/portage/kde-base/systemsettings-5.0.0/work/systemsettings-5.0.0/app/main.cpp:55
workoft
Registered Member
Posts
94
Karma
1
Ok, this was the wrong place to look for an answer. It turns out, it was distribution specific:
https://bugs.gentoo.org/show_bug.cgi?id=518262

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], Google [Bot], llarruda, palnik, rblackwell