Reply to topic

"KDEInit could not launch /usr/bin/..."

workoft
Registered Member
Posts
94
Karma
1
Hi,

A while ago a problem started appearing. I can reproduce the same message and the same behaviour with different applications in several ways:
I launch ktp-contactlist from kickoff or via Alt+F2. Ktp-contactlist launches, just like I expected (it doesn't log in, but I guess that's a different problem. It's the KF5 based version from git). At the same time, depending on where I launched it from, either plasmashell (when launched from kickoff) or that little popup window on top) become unresponsive and stay open while they are supposed to close. All other application keep working, including ktp-contactlist. When I close ktp-contactlist, the message "KDEInit could not launch /usr/bin/ktp-contactlist" pops up and everything works normally again.
The other way is that kate is already open with some random text document and I open another text document from dolphin. The new text document opens in a new tab, just like it is supposed to, but dolphin seemingly freezes. It returns back to normal as soon as that specific document is closed in kate. The message is again "KDEInit could not launch /usr/bin/kate".
There is no suspicious command line output in either case. I suppose messages that would help diagnosing are elsewhere to be found?

Cheers,
Malte
User avatar einar
Administrator
Posts
3400
Karma
7
OS
This is a known issue with some KF5 apps, can you check whether this has been reported on bugs.kde.org? Recently something like this was fixed in rekonq, and if the Kate developers are made aware of this issue, perhaps they can use the same strategy.


"Violence is the last refuge of the incompetent."
Image
Plasma FAQ maintainer - Plasma programming with Python
dvillamil
Registered Member
Posts
5
Karma
0
This has been happenning to me as well.
I can't assure the actual sequence of the Dolphin-Kate breakage, I did have both of them breaking constantly.
On the "KDE init could not launch..." issue, as appears in this bug -> (https://bugs.launchpad.net/kubuntu-ppa/+bug/1375619)
A temporary fix is...
$ sudo ln -s /usr/bin/kdesudo /usr/bin/kdesu

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], gfielding, Google [Bot], hiteshshah, lucianosalomoni, Majestic-12 [Bot], pseco, Sentinel, TheBeheader, Yahoo [Bot]