Reply to topic

plasma 5 on centos 7

sketchymandan
Registered Member
Posts
7
Karma
0

plasma 5 on centos 7

Sun Feb 15, 2015 12:49 pm
I saw that there wasn't a download for plasma 5 on centos 7, does this mean i should download from source and compile it to get it running on centos 7? If so, is there a guide or some instructions on how to do that?

Cheers
Dan
User avatar progdan
KDE Developer
Posts
68
Karma
0
OS

Re: plasma 5 on centos 7

Tue Feb 17, 2015 12:00 pm
Hi,

we don't support CentOS/RHEL 7 because currently the version of cmake available on RHEL7 is too old (2.8.11, we need 2.8.12) and we are not able to compile KDE Frameworks 5 without it. There is a push on having KF5 available in RHEL 7 through EPEL, so we might get a CMake update at some point. Once that is done, there should be no problem providing Plasma 5 packages for CentOS/RHEL 7 through EPEL.


Daniel Vrátil | www.dvratil.cz | dvratil@kde.org
IRC: dvratil on Freenode (#kde, #kontact, #akonadi, #fedora-kde)
Daily_b
Registered Member
Posts
1
Karma
0

Re: plasma 5 on centos 7

Sun Feb 07, 2016 2:21 am
Any update on this by any chance?
User avatar progdan
KDE Developer
Posts
68
Karma
0
OS

Re: plasma 5 on centos 7

Mon Feb 08, 2016 5:15 pm
Yes, as a matter of fact, we are on the right path now. We got new-enough CMake (thanks to Helio), so I managed to build and update KDE Frameworks in COPR. I did not have time yet to build Plasma 5, but that should be easy ;)

https://copr.fedorainfracloud.org/coprs ... /packages/


Daniel Vrátil | www.dvratil.cz | dvratil@kde.org
IRC: dvratil on Freenode (#kde, #kontact, #akonadi, #fedora-kde)
BS86
Registered Member
Posts
1
Karma
0
OS

Re: plasma 5 on centos 7

Wed Mar 02, 2016 6:04 pm
is there a small chance that Plasma 5 will be available on EPEL soon? ;)
User avatar progdan
KDE Developer
Posts
68
Karma
0
OS

Re: plasma 5 on centos 7

Sun Mar 20, 2016 11:15 pm
Hi,

I started working on importing KDE Frameworks packages into EPEL7 just now, so that's the first step :) We can't ship Plasma 5 in EPEL7 directly but we agreed to set up a COPR repository with Plasma 5 packages. No promises when that will happen, hopefully after the 5.6 update.


Daniel Vrátil | www.dvratil.cz | dvratil@kde.org
IRC: dvratil on Freenode (#kde, #kontact, #akonadi, #fedora-kde)
LaWix
Registered Member
Posts
2
Karma
0

Re: plasma 5 on centos 7

Wed Mar 23, 2016 1:26 pm
Hi progdan,

Plasma 5.6 is released, any idea when released version on centos ? o)

Thanks
User avatar progdan
KDE Developer
Posts
68
Karma
0
OS

Re: plasma 5 on centos 7

Sun Mar 27, 2016 10:31 pm
LaWix wrote:Hi progdan,

Plasma 5.6 is released, any idea when released version on centos ? o)
Thanks


We don't even have 5.6 in Fedora yet :-) First I need to import Frameworks into EPEL, but that is currently blocked on some missing dependencies, so I need to solve that first. Sorry it's all taking so long.


Daniel Vrátil | www.dvratil.cz | dvratil@kde.org
IRC: dvratil on Freenode (#kde, #kontact, #akonadi, #fedora-kde)
LaWix
Registered Member
Posts
2
Karma
0

Re: plasma 5 on centos 7

Tue Mar 29, 2016 9:06 am
Ok thanks :'(
ahoffman
Registered Member
Posts
19
Karma
0
OS

Re: plasma 5 on centos 7

Thu Mar 31, 2016 5:08 pm
...

Last edited by ahoffman on Sun Apr 10, 2016 3:25 am, edited 1 time in total.
User avatar google01103
Manager
Posts
6668
Karma
25

Re: plasma 5 on centos 7

Thu Mar 31, 2016 5:25 pm
you show no errors, you should post some of the logs of the failed builds


OpenSuse Leap 42.1 x64, Plasma 5.x

ahoffman
Registered Member
Posts
19
Karma
0
OS

Re: plasma 5 on centos 7

Thu Mar 31, 2016 6:05 pm
google01103 wrote:you show no errors, you should post some of the logs of the failed builds

Hi, here's the first few:

# kdesrc-build running: 'gmake' '-j8'
# from directory: /opt/kde/build/phonon
Scanning dependencies of target phonon4qt5_automoc
Scanning dependencies of target phononwidgets_automoc
Scanning dependencies of target phonon4qt5experimental_automoc
[ 4%] [ 4%] [ 4%] Automoc for target phonon4qt5
Automoc for target phononwidgets
Automoc for target phonon4qt5experimental
Generating phononcollection.moc
Generating moc_seeksliderplugin.cpp
Generating moc_videoplayerplugin.cpp
Generating moc_videoplayertaskmenu.cpp
Generating moc_videowidgetplugin.cpp
Generating moc_volumesliderplugin.cpp
[ 4%] Built target phononwidgets_automoc
Generating moc_avcapture.cpp
Generating moc_audiodataoutput.cpp
Generating moc_factory_p.cpp
Generating moc_videodataoutput.cpp
Generating moc_videodataoutput2.cpp
Generating moc_videowidget.cpp
Generating moc_visualization.cpp
[ 4%] Built target phonon4qt5experimental_automoc
Generating moc_abstractaudiooutput.cpp
Generating moc_abstractmediastream.cpp
Generating moc_audiooutput.cpp
Generating moc_audiooutputadaptor_p.cpp
Generating moc_backendcapabilities.cpp
Generating moc_effect.cpp
Generating moc_effectwidget.cpp
Generating factory.moc
Generating moc_factory_p.cpp
Generating moc_iodevicestream_p.cpp
Generating moc_mediacontroller.cpp
Generating moc_mediaobject.cpp
Generating moc_pulsestream_p.cpp
Generating moc_pulsesupport.cpp
Generating moc_seekslider.cpp
Generating moc_swiftslider_p.cpp
Generating moc_videoplayer.cpp
Generating moc_videowidget.cpp
Generating moc_volumefadereffect.cpp
Generating moc_volumeslider.cpp
Generating moc_audiodataoutput.cpp
Generating moc_statesvalidator_p.cpp
[ 4%] Built target phonon4qt5_automoc
Scanning dependencies of target phonon4qt5
[ 5%] [ 8%] [ 8%] [ 10%] [ 11%] [ 13%] Building CXX object phonon/CMakeFiles/phonon4qt5.dir/abstractmediastream.cpp.o
Building CXX object phonon/CMakeFiles/phonon4qt5.dir/abstractaudiooutput_p.cpp.o
[ 14%] Building CXX object phonon/CMakeFiles/phonon4qt5.dir/abstractaudiooutput.cpp.o
[ 16%] Building CXX object phonon/CMakeFiles/phonon4qt5.dir/abstractvideooutput_p.cpp.o
Building CXX object phonon/CMakeFiles/phonon4qt5.dir/abstractvideooutput.cpp.o
Building CXX object phonon/CMakeFiles/phonon4qt5.dir/audiodataoutput.cpp.o
Building CXX object phonon/CMakeFiles/phonon4qt5.dir/audiooutput.cpp.o
Building CXX object phonon/CMakeFiles/phonon4qt5.dir/audiooutputinterface.cpp.o
[ 17%] Building CXX object phonon/CMakeFiles/phonon4qt5.dir/backendcapabilities.cpp.o
[ 19%] Building CXX object phonon/CMakeFiles/phonon4qt5.dir/effect.cpp.o
[ 20%] Building CXX object phonon/CMakeFiles/phonon4qt5.dir/effectparameter.cpp.o
[ 22%] Building CXX object phonon/CMakeFiles/phonon4qt5.dir/effectwidget.cpp.o
[ 23%] [ 25%] Building CXX object phonon/CMakeFiles/phonon4qt5.dir/factory.cpp.o
Building CXX object phonon/CMakeFiles/phonon4qt5.dir/globalconfig.cpp.o
[ 26%] Building CXX object phonon/CMakeFiles/phonon4qt5.dir/iodevicestream.cpp.o
/opt/kde/sources/phonon/phonon/factory.cpp:265:2: warning: #warning this actually breaks with qmake.... [-Wcpp]
#warning this actually breaks with qmake....
^
[ 27%] Building CXX object phonon/CMakeFiles/phonon4qt5.dir/mediacontroller.cpp.o
[ 29%] Building CXX object phonon/CMakeFiles/phonon4qt5.dir/mediaobject.cpp.o
[ 30%] Building CXX object phonon/CMakeFiles/phonon4qt5.dir/medianode.cpp.o
[ 32%] Building CXX object phonon/CMakeFiles/phonon4qt5.dir/mediasource.cpp.o
[ 33%] Building CXX object phonon/CMakeFiles/phonon4qt5.dir/mrl.cpp.o
[ 35%] Building CXX object phonon/CMakeFiles/phonon4qt5.dir/objectdescription.cpp.o
[ 36%] Building CXX object phonon/CMakeFiles/phonon4qt5.dir/objectdescriptionmodel.cpp.o
[ 38%] Building CXX object phonon/CMakeFiles/phonon4qt5.dir/path.cpp.o
[ 39%] Building CXX object phonon/CMakeFiles/phonon4qt5.dir/phononnamespace.cpp.o
[ 41%] Building CXX object phonon/CMakeFiles/phonon4qt5.dir/platform.cpp.o
[ 42%] Building CXX object phonon/CMakeFiles/phonon4qt5.dir/pulsesupport.cpp.o
[ 44%] Building CXX object phonon/CMakeFiles/phonon4qt5.dir/seekslider.cpp.o
[ 45%] Building CXX object phonon/CMakeFiles/phonon4qt5.dir/statesvalidator.cpp.o
[ 47%] Building CXX object phonon/CMakeFiles/phonon4qt5.dir/streaminterface.cpp.o
[ 48%] Building CXX object phonon/CMakeFiles/phonon4qt5.dir/swiftslider.cpp.o
[ 50%] Building CXX object phonon/CMakeFiles/phonon4qt5.dir/volumefadereffect.cpp.o
[ 51%] Building CXX object phonon/CMakeFiles/phonon4qt5.dir/volumeslider.cpp.o
[ 52%] Building CXX object phonon/CMakeFiles/phonon4qt5.dir/videoplayer.cpp.o
[ 54%] Building CXX object phonon/CMakeFiles/phonon4qt5.dir/videowidget.cpp.o
[ 55%] Building CXX object phonon/CMakeFiles/phonon4qt5.dir/pulsestream.cpp.o
[ 57%] Building CXX object phonon/CMakeFiles/phonon4qt5.dir/audiooutputadaptor.cpp.o
[ 58%] Building CXX object phonon/CMakeFiles/phonon4qt5.dir/phonon4qt5_automoc.cpp.o
Linking CXX shared library libphonon4qt5.so
/bin/ld: skipping incompatible /usr/lib/gcc/x86_64-redhat-linux/4.8.5/../../../libpulse.so when searching for -lpulse
/bin/ld: skipping incompatible /lib/libpulse.so when searching for -lpulse
/bin/ld: skipping incompatible /usr/lib/libpulse.so when searching for -lpulse
/bin/ld: cannot find -lpulse
/bin/ld: skipping incompatible /usr/lib/gcc/x86_64-redhat-linux/4.8.5/../../../libpulse-mainloop-glib.so when searching for -lpulse-mainloop-glib
/bin/ld: skipping incompatible /lib/libpulse-mainloop-glib.so when searching for -lpulse-mainloop-glib
/bin/ld: skipping incompatible /usr/lib/libpulse-mainloop-glib.so when searching for -lpulse-mainloop-glib
/bin/ld: cannot find -lpulse-mainloop-glib
collect2: error: ld returned 1 exit status
gmake[2]: *** [phonon/libphonon4qt5.so.4.8.51] Error 1
gmake[1]: *** [phonon/CMakeFiles/phonon4qt5.dir/all] Error 2
gmake: *** [all] Error 2


# kdesrc-build running: 'cmake' '/opt/kde/sources/knotifications' '-DCMAKE_BUILD_TYPE:STRING=debug' '-DKDE4_BUILD_TESTS=true' '-DBUILD_TESTING=TRUE' '-DCMAKE_BUILD_TYPE:STRING=debug' '-DCMAKE_CXX_FLAGS:STRING=-pipe -DQT_STRICT_ITERATORS -DQURL_NO_CAST_FROM_STRING -DQT_NO_HTTP -DQT_NO_FTP -Wformat -Werror=format-security -Werror=return-type -Wno-variadic-macros -Wlogical-op -Wmissing-include-dirs -std=c++11 ' '-DCMAKE_INSTALL_PREFIX=/opt/kde/install'
# from directory: /opt/kde/build/knotifications
-- The C compiler identification is GNU 4.8.5
-- The CXX compiler identification is GNU 4.8.5
-- Check for working C compiler: /bin/cc
-- Check for working C compiler: /bin/cc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Check for working CXX compiler: /bin/c++
-- Check for working CXX compiler: /bin/c++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
--

-- Looking for __GLIBC__
-- Looking for __GLIBC__ - found
-- Performing Test _OFFT_IS_64BIT
-- Performing Test _OFFT_IS_64BIT - Success
-- Looking for XOpenDisplay in /usr/lib64/libX11.so;/usr/lib64/libXext.so
-- Looking for XOpenDisplay in /usr/lib64/libX11.so;/usr/lib64/libXext.so - found
-- Looking for gethostbyname
-- Looking for gethostbyname - found
-- Looking for connect
-- Looking for connect - found
-- Looking for remove
-- Looking for remove - found
-- Looking for shmat
-- Looking for shmat - found
-- Looking for IceConnectionNumber in ICE
-- Looking for IceConnectionNumber in ICE - found
-- Found X11: /usr/lib64/libX11.so
CMake Error at CMakeLists.txt:62 (find_package):
Could not find a package configuration file provided by "Phonon4Qt5"
(requested version 4.6.60) with any of the following names:

Phonon4Qt5Config.cmake
phonon4qt5-config.cmake

Add the installation prefix of "Phonon4Qt5" to CMAKE_PREFIX_PATH or set
"Phonon4Qt5_DIR" to a directory containing one of the above files. If
"Phonon4Qt5" provides a separate development package or SDK, be sure it has
been installed.


-- Configuring incomplete, errors occurred!
See also "/opt/kde/build/knotifications/CMakeFiles/CMakeOutput.log".


# kdesrc-build running: 'cmake' '/opt/kde/sources/kwallet' '-DCMAKE_BUILD_TYPE:STRING=debug' '-DKDE4_BUILD_TESTS=true' '-DBUILD_TESTING=TRUE' '-DCMAKE_BUILD_TYPE:STRING=debug' '-DCMAKE_CXX_FLAGS:STRING=-pipe -DQT_STRICT_ITERATORS -DQURL_NO_CAST_FROM_STRING -DQT_NO_HTTP -DQT_NO_FTP -Wformat -Werror=format-security -Werror=return-type -Wno-variadic-macros -Wlogical-op -Wmissing-include-dirs -std=c++11 ' '-DCMAKE_INSTALL_PREFIX=/opt/kde/install'
# from directory: /opt/kde/build/kwallet
-- The C compiler identification is GNU 4.8.5
-- The CXX compiler identification is GNU 4.8.5
-- Check for working C compiler: /bin/cc
-- Check for working C compiler: /bin/cc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Check for working CXX compiler: /bin/c++
-- Check for working CXX compiler: /bin/c++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
--

-- Looking for __GLIBC__
-- Looking for __GLIBC__ - found
-- Performing Test _OFFT_IS_64BIT
-- Performing Test _OFFT_IS_64BIT - Success
-- Found Gettext: /bin/msgmerge (found version "0.18.2")
-- Found PythonInterp: /bin/python (found version "2.7.5")
-- Performing Test COMPILER_HAS_HIDDEN_VISIBILITY
-- Performing Test COMPILER_HAS_HIDDEN_VISIBILITY - Success
-- Performing Test COMPILER_HAS_HIDDEN_INLINE_VISIBILITY
-- Performing Test COMPILER_HAS_HIDDEN_INLINE_VISIBILITY - Success
-- Performing Test COMPILER_HAS_DEPRECATED_ATTR
-- Performing Test COMPILER_HAS_DEPRECATED_ATTR - Success
CMake Error at src/runtime/kwalletd/CMakeLists.txt:10 (find_package):
By not providing "FindKF5Notifications.cmake" in CMAKE_MODULE_PATH this
project has asked CMake to find a package configuration file provided by
"KF5Notifications", but CMake did not find one.

Could not find a package configuration file provided by "KF5Notifications"
(requested version 5.20.0) with any of the following names:

KF5NotificationsConfig.cmake
kf5notifications-config.cmake

Add the installation prefix of "KF5Notifications" to CMAKE_PREFIX_PATH or
set "KF5Notifications_DIR" to a directory containing one of the above
files. If "KF5Notifications" provides a separate development package or
SDK, be sure it has been installed.


-- Configuring incomplete, errors occurred!
See also "/opt/kde/build/kwallet/CMakeFiles/CMakeOutput.log".
User avatar google01103
Manager
Posts
6668
Karma
25

Re: plasma 5 on centos 7

Thu Mar 31, 2016 6:37 pm
note: I don't do these things so I'm not sure of the nomenclature but you're missing libraries that are required for the compilations

it seems:
-for the first on you are missing libpulse-dev
-for the second you're missing Phonon4Qt5-dev
-for the third you're missing KF5Notifications-dev


OpenSuse Leap 42.1 x64, Plasma 5.x

ahoffman
Registered Member
Posts
19
Karma
0
OS

Re: plasma 5 on centos 7

Thu Mar 31, 2016 7:52 pm
Thanks for the reply.

I don't think that's the problem as builddeps appear to be met:

Code: Select all
Getting requirements for phonon-4.6.0-10.el7.src
 --> Already installed : libxcb-devel-1.11-4.el7.x86_64
 --> Already installed : libxml2-devel-2.9.1-6.el7_2.2.x86_64
 --> Already installed : pulseaudio-libs-devel-6.0-7.el7.i686
 --> Already installed : glib2-devel-2.42.2-5.el7.x86_64
 --> Already installed : 1:qt-devel-4.8.5-11.el7.i686
 --> Already installed : 1:pkgconfig-0.27.1-4.el7.i686
 --> Already installed : kde-filesystem-4-47.el7.x86_64
 --> Already installed : cmake-2.8.12.2-2.el7.centos.x86_64
 --> Already installed : automoc-1.0-0.20.rc3.el7.x86_64
Getting requirements for phonon-4.8.3-8.el7.centos.src
 --> Already installed : automoc-1.0-0.20.rc3.el7.x86_64
 --> Already installed : cmake-2.8.12.2-2.el7.centos.x86_64
 --> Already installed : kde-filesystem-4-47.el7.x86_64
 --> Already installed : 1:pkgconfig-0.27.1-4.el7.i686
 --> Already installed : glib2-devel-2.42.2-5.el7.x86_64
 --> Already installed : pulseaudio-libs-devel-6.0-7.el7.i686
 --> Already installed : libxml2-devel-2.9.1-6.el7_2.2.x86_64
 --> Already installed : 1:qt-devel-4.8.5-11.el7.i686
 --> Already installed : 1:qt-devel-4.8.5-11.el7.i686
 --> Already installed : 1:qt-devel-4.8.5-11.el7.i686
 --> Already installed : 1:qt-devel-4.8.5-11.el7.i686
 --> Already installed : qt5-qtbase-devel-5.5.1-11.el7.x86_64
 --> Already installed : qt5-qttools-devel-5.5.1-2.el7.x86_64
 --> Already installed : qt5-qtbase-devel-5.5.1-11.el7.x86_64
 --> Already installed : qt5-qtbase-devel-5.5.1-11.el7.x86_64
 --> Already installed : qt5-qtquick1-devel-5.5.1-2.el7.x86_64
 --> Already installed : libxcb-devel-1.11-4.el7.x86_64
Getting requirements for phonon-4.6.0-10.el7.src
 --> Already installed : libxcb-devel-1.11-4.el7.x86_64
 --> Already installed : libxml2-devel-2.9.1-6.el7_2.2.x86_64
 --> Already installed : pulseaudio-libs-devel-6.0-7.el7.i686
 --> Already installed : glib2-devel-2.42.2-5.el7.x86_64
 --> Already installed : 1:qt-devel-4.8.5-11.el7.i686
 --> Already installed : 1:pkgconfig-0.27.1-4.el7.i686
 --> Already installed : kde-filesystem-4-47.el7.x86_64
 --> Already installed : cmake-2.8.12.2-2.el7.centos.x86_64
 --> Already installed : automoc-1.0-0.20.rc3.el7.x86_64
Getting requirements for phonon-4.8.3-8.el7.centos.src
 --> Already installed : automoc-1.0-0.20.rc3.el7.x86_64
 --> Already installed : cmake-2.8.12.2-2.el7.centos.x86_64
 --> Already installed : kde-filesystem-4-47.el7.x86_64
 --> Already installed : 1:pkgconfig-0.27.1-4.el7.i686
 --> Already installed : glib2-devel-2.42.2-5.el7.x86_64
 --> Already installed : pulseaudio-libs-devel-6.0-7.el7.i686
 --> Already installed : libxml2-devel-2.9.1-6.el7_2.2.x86_64
 --> Already installed : 1:qt-devel-4.8.5-11.el7.i686
 --> Already installed : 1:qt-devel-4.8.5-11.el7.i686
 --> Already installed : 1:qt-devel-4.8.5-11.el7.i686
 --> Already installed : 1:qt-devel-4.8.5-11.el7.i686
 --> Already installed : qt5-qtbase-devel-5.5.1-11.el7.x86_64
 --> Already installed : qt5-qttools-devel-5.5.1-2.el7.x86_64
 --> Already installed : qt5-qtbase-devel-5.5.1-11.el7.x86_64
 --> Already installed : qt5-qtbase-devel-5.5.1-11.el7.x86_64
 --> Already installed : qt5-qtquick1-devel-5.5.1-2.el7.x86_64
 --> Already installed : libxcb-devel-1.11-4.el7.x86_64
Getting requirements for phonon-4.6.0-10.el7.src
 --> Already installed : libxcb-devel-1.11-4.el7.x86_64
 --> Already installed : libxml2-devel-2.9.1-6.el7_2.2.x86_64
 --> Already installed : pulseaudio-libs-devel-6.0-7.el7.i686
 --> Already installed : glib2-devel-2.42.2-5.el7.x86_64
 --> Already installed : 1:qt-devel-4.8.5-11.el7.i686
 --> Already installed : 1:pkgconfig-0.27.1-4.el7.i686
 --> Already installed : kde-filesystem-4-47.el7.x86_64
 --> Already installed : cmake-2.8.12.2-2.el7.centos.x86_64
 --> Already installed : automoc-1.0-0.20.rc3.el7.x86_64
No uninstalled build requires
User avatar google01103
Manager
Posts
6668
Karma
25

Re: plasma 5 on centos 7

Thu Mar 31, 2016 8:13 pm
since they're not found then maybe they're not in your LD_PATH (again I've never so I could be .........)


OpenSuse Leap 42.1 x64, Plasma 5.x


 
Reply to topic

Bookmarks



Who is online

Registered users: atelierrosa, Baidu [Spider], Bing [Bot], bionan, Capitain_Jack, claydoh, Exabot [Bot], Google [Bot], johssw, philippg, Sogou [Bot], TheraHedwig, Yahoo [Bot]