Reply to topic

Black desktop on login with plasmashell crash

rolff
Registered Member
Posts
3
Karma
0
Same issue here....
After fresh installation of 15.04 I could work for 3 hours.
Don't know whether or not it has something to do with it: I modified fstab after which the screen turned black. When rebooting the system I logged in into a black screen! >:(
rolff
Registered Member
Posts
3
Karma
0
Same issue here...
After fresh installation of Kubuntu 15.04 I coud work for about 3 hours before the screen went black. SDDM seams to work fine (apart from the fact that it only recognises US KB layout).
The current version was obviously released much too early.
I probably will go back to 14.10...
rburgosnavas
Registered Member
Posts
4
Karma
0
Deleting .cache/ did not solve anything for me. In fact, before deleting .cache/, I was logging in to a black screen. After deleting, I try to log in by entering my password, the login screen freezes, then asks me for my password again, on and on and on. I don't know what to do.

This is actually the fourth time this has happened to me since upgrading. The first time, for lack of knowledge, I reinstalled the whole OS. The other times, I had to create a new user and transfer all my files from the old account to the new. That worked for a while until plasma crashed. Then for some reason kubuntu-desktop got uninstalled because I opened a tty, tried apt-get install kubuntu-desktop and to my surprise, I got installed (no mention of kubuntu-desktop being already installed)!
rburgosnavas
Registered Member
Posts
4
Karma
0
Moved .config/ to .config_OLD/ and restarted the machine. I got my desktop back. >:(
falvarez
Registered Member
Posts
1
Karma
0
hi

just rename the following file "/home/username/.cache/ksycoca5" and all good so far, I hope this is of help guys
User avatar Malsasa
Registered Member
Posts
56
Karma
0
OS
google01103 wrote:couple things to try to isolate the problem
2) move your plasma files then restart Plasma forcing a return to the defaults
Code: Select all
kquitapp plasmashell
 sleep 20s
 mkdir -p $HOME/plasma-config/
 mv ~/.config/plasma* $HOME/plasma-config/
plasmashell &


This should tell if its a Kwin or a Plasma config issue

note: this is the std code we used for KDE 4 which I've adjusted (hopefully correctly) for Plasma 5


You help me again, Sir. Your number 2 workaround worked perfectly on

Kubuntu 15.04 i386
KDE Plasma 5.2.2
Crash: no panel, no wallpaper, only window and KRunner

I followed one by one command you mentioned on number 2 above. Thank you.


ThePythonicCow
Registered Member
Posts
1
Karma
0
I posted some further analysis and a workaround for this black screen that works for me at least. See my post at: http://askubuntu.com/a/630562/415293

To summarize that post, it seems that my $HOME/.config/plasma-org.kde.plasma.desktop-appletsrc was getting substantial portions of itself removed, perhaps by some configuration tool I used to fine tune my Desktop, after installing and starting to use Kubuntu 15.04.

The first time this happened, I reinstalled entirely. The second time, I had a backup from a day earlier that was pretty close and still worked.

The third time this (black screen) happened, I was able to debug it some, and after experimenting with moving various $HOME/.cache and $HOME/.config files aside and restarting sddm (systemctl restart sddm, from my Ctl-Alt-F1 terminal window), I narrowed it down to my $HOME/.config/plasma-org.kde.plasma.desktop-appletsrc file.

When that plasma config file works, it is about 100 lines long; when it doesn't work (and my desktop is all black except for the cursor), that plasma config file is less than 40 lines long, and missing many sections that look that they could be useful.
robster9000
Registered Member
Posts
1
Karma
0
OS
N00B here :)
random753 wrote:Same thing here Running Kubuntu 15.04 on AMD64.
Though deleting .cache restores session, default panel has to be manually re-added.
Apparently has to do with the plasma .lock


Removing this worked for me too!
For anyone else with this bug, here is a workaround what worked for me:

Code: Select all
sudo rm -rf ~/.cache*
#then reboot with
sudo reboot

After you log in you will need to add any panels and widgets back (right click)
User avatar vayu
Registered Member
Posts
125
Karma
0
OS
I don't know if it's the same black screen, I could use alt-f2 and still use any windowed program I knew the command for. This worked for me:
rm -r ~/.local/share/kscreen/
surion
Registered Member
Posts
1
Karma
0
falvarez wrote:hi

just rename the following file "/home/username/.cache/ksycoca5" and all good so far, I hope this is of help guys


This solved it for me. Thank you! :) I wonder for how long.

This is such an annoying bug! I had an account I had to leave behind because I couldn't figure out what was going on and I noticed that an account for a new user works fine.
mlegault
Registered Member
Posts
9
Karma
0
Hello,

this is my first post to these forums... I thought I would try to make it a helpful one!

Today I decided to upgrade from 14.04 to 14.10 to 15.04... I first did it on my 2008 MacBook, and it went superbly. Not a hitch.
Then I went to my frankenstein computer and decided to do the same, and when I was done upgrading to 15.04, I was getting nothing but black screen from the get-go, right after grub bootloader. Not even the plymouth was showing up. After some searching around, I found that the issue could be related to NVidia drivers.
After much screwing around, I ended up booting in recovery mode, with networking, and safe graphics mode. This allowed me to get low-res (but something on the screen!!) and I was able to log in and go to my system settings to choose the "recommended" NVidia drivers. One reboot later, all is working without a hitch as well!

In the hopes that someone could benefit from this simple how-to...

For those interested, Frankie is a 64bit i7 3770 3.4 quad core, with a NVidia GF114 (GTX560 Ti) graphics card on an ASUS P8H61-I R2.0. 8 gigs ram. The "recommended" driver version is 346.59 from NVidia. Good luck to everyone still struggling!
jimomma
Registered Member
Posts
1
Karma
0

PROPER FIX

Tue Aug 04, 2015 7:17 pm
This bug occurs after editing certain files as root. The permissions get fragged.

The proper fix is to just boot into KDE. After you get the black screen:

1. CTRL+ALT+F2

2. Login with your regular user name and password.

3. Enter the following command:
Code: Select all
sudo chown USER:USER ~/.cache/*
Substitute your user name for BOTH USER sections above. IE if user is chris then:
sudo chown chris:chris ~/.cache/*

4. Final step:
Code: Select all
sudo reboot
This works for me and I don't have to delete, rename or recreate anything.

If you need to launch an app as root instead of using gksu or gksudo use:
Code: Select all
kdesudo APPNAME
kdesudo handles temporary permissions differently than gksu or gksudo and won't frag your plasma desktop.
mlegault
Registered Member
Posts
9
Karma
0
Ok. So my first suggestion was a bust because my plasma desktop ended up going on the fritz again. More specifically, when playing around with window decorations, ended up without any decorations when applying a new set, so decided to log out and try to log back in... to end up with the black screen, and an open instance of system settings, which had been left open on log out. However, the system settings gave me a popup saying there were no focuses therefore nothing to display.

After some searching online, I found an article from someone with the blank screen issue saying he resolved it by renaming his ~/.cache folder, and logging in, everything was back to normal, and the system was usable.

I did the same, and turns out it worked for me.

I don't have enough KDE or Linux knowledge to be able to help debug the situation, but if this can help narrow down the issue....

And I have to specify, this happened to me after a clean install because this issue occurred several times after my first post in this thread. I am running Nouveau drivers for nVidia because the proprietary drivers, when booting up, show me a low-res screen with "starting version 219" and then nothing.

If I can be of help to anyone to try anything on my setup, please PM me, I would be glad to use my computer as a guinea pig for the greater good.

M-A



P.S. - JimOmma :

Thanks for the precisions as to why my manipulations of ~/.cache worked.

My question remains though, as to why applying, while using the regular system settings application and not as root, a new window decoration, starts off by temporarily (or permanently?) breaking window compositing, and after logout/login stops the user from having a working plasma desktop.
en.ko
Registered Member
Posts
1
Karma
0

User deleted?!

Tue Sep 22, 2015 3:00 pm
I have the same problem here. I added another admin user before the problem occurs the first time (again). Also I prepared a virtual terminal starts when I login, so I still have access on programs if the error occurs. If the error occurs, I can't start any program by using "Alt+F2".

After the plasma crashed on first users GUI, I still can open the second users GUI without any problem. I opened the graphical settings and I can't find the first user in the list of users. However I still can login and running programs as first user. But it seems most settings deleted, especially the plasma-settings. But the files are still in /home/FirstUser folder.

EDIT: I got the GUI back by using the solutions: "deleting ./chache" and "mkdir -p $HOME/plasma-config/". "mv ~/.config/kwinrc ~/.config/kwinrc-old && kwin_x11 --replace" not works for me. By using "mkdir -p $HOME/plasma-config/" the problem comes again, now I used "deleting ./chache", wait how long it works. But anyway, I have to change lots of settings again. This is not an acceptable solution.
pedromartinez
Registered Member
Posts
23
Karma
0
I had the same issue and figured out that the problem happened everytime I opened dolphin as root.
I dealt with the problem by creating an alias in bashrc:
Code: Select all
alias CACHE='rm -Rf .cache; qdbus org.kde.ksmserver /KSMServer logout 0 0 0'

As is evident, this was extremely annoying, since I had to restart my session all the time, and, if I eventually forgot to run "CACHE", plasma would crash and I would have to add, once logged in again, the default panel and customize it again.

As a workaround, I am now using the following alias:
Code: Select all
alias SD='sudo dolphin .; sudo /bin/chown "username" ~/.cache/*'


Of course, I had to add the chown bit to sudoers.
So far, it seems to be working.

 
Reply to topic

Bookmarks



Who is online

Registered users: airdrik, Baidu [Spider], Bing [Bot], farid, Google [Bot], jacobseated, jvapr27, mihaela-prkos, Section_8, Sogou [Bot]