Reply to topic

External display in plasma 5 not working

User avatar sredna
Registered Member
Posts
179
Karma
0
OS
I have no screen management in systemsettings, connecting an external display does not work at all.

I have libkscreen-frameworks 5.2, libkscreen 1.0.5 and kscreen 1.0.2. What is missing?
User avatar einar
Administrator
Posts
3400
Karma
7
OS
You will need a KF5-enabled version of kscreen. In openSUSE it's "kscreen5", not sure about the other distributions.


"Violence is the last refuge of the incompetent."
Image
Plasma FAQ maintainer - Plasma programming with Python
User avatar google01103
Manager
Posts
6668
Karma
25
the package might be called kscreen-frameworks


OpenSuse Leap 42.1 x64, Plasma 5.x

User avatar sredna
Registered Member
Posts
179
Karma
0
OS
kscreen-frameworks in archlinux as well.

First try was rather unstable, I could not cycle through all the possible configurations and get back, and after disconnecting the external display, plasmashell crashed, leaving me with no choice but killing startkde.
User avatar sredna
Registered Member
Posts
179
Karma
0
OS
Tried again, connecting to my TV using HDMI.

First it appeared to work, but plasmashell and kwin crashes. After connecting neither display reached a usable state, my only solution was to kill startkde from a console login.

I dislike the way kscreen works, why can't I have a graphical choice of what I want? Even if it worked, it appears to be slow and the violent blinking happening on my laptop display is indeed uncomfortable!
luebking
Karma
0
crashes of plasmashell and KWin are likely
https://bugreports.qt.io/browse/QTBUG-44158
https://bugreports.qt.io/browse/QTBUG-32681

(interim lack of any screen)
User avatar sredna
Registered Member
Posts
179
Karma
0
OS
Sounds correct. I have plasma/kwin crashing quite often at this time, I wondered if there were a memory issue, crashes appears to happen more frequently when resources are low. I have plenty of swap space though.
User avatar sredna
Registered Member
Posts
179
Karma
0
OS
After the release of plasma-workspace 5.2.1, I tried connecting an external display again, and by now it's kinda working.
Although some of the transitions between different concepts/configurations (Fn +F5 on my laptop) are somewhat slow, nothing crashes.
When I figure out which setup have the external display as the primary screen, I can run a presentation in impress, and see my notes or progress screen on the laptop (calligra stage does not seem to support this) - very nice!
If I pull the plug when the laptop display is not in its natural size, with plasmashell visible on it, plasmashell becomes stuck in some weird size, leaving some of the space unused to the right and bottom. [1]
At some point, the window on the external display (my TV in this case) became quite weird, with a strip between the plasma panel and the bottom of the window that was not filled when maximizing windows. [2]
After pulling the external display, the icons in the task switcher appears to be lost, which is quite annoying.

[1] http://owncloud.alweb.dk/public.php?ser ... 281d00dbfa
[2] http://owncloud.alweb.dk/public.php?ser ... 356efec0a5
User avatar sredna
Registered Member
Posts
179
Karma
0
OS
The configuration that works for me is the two displays side by side, with the laptop as primary. When that is activated, plasma for some reason moves alle the windows to the external display, I wonder why - it is mostly inconvenient. For example impress have to be moved back for things to work nicely.

Pulling the external display when active works ok, with this configuration.

Switching the TV to display TV and then pulling the plug, plasma does not experience that the display was removed. I can move windows back to the laptop screen by using the move action from the task button context menu - rather inconvenient. The window switcher is now gone, but I can switch windows using ALT + TAB. It may return later, appearently. The krunner window also dissapeared, but later showed up partially in the top right corner. Typing something in it caused some blinking, and finally a reset of the screen configuration.

I was able to restore sound after directing it to HDMI.

So all in all, it is possible to connect an external display, use it, and with relative ease to restore things - quite happy for now :-)
User avatar sredna
Registered Member
Posts
179
Karma
0
OS
Firefox gets confused after using an external display.windows start in half size, and never gets back to maximized, and full screen display does not get the size correctly. The display is correctly sized for plasmashell, and kde apps. Display configuration shows only the laptop display. Not sure about other non-kde apps, no others tried as of yet.
User avatar sredna
Registered Member
Posts
179
Karma
0
OS
After my tests I have been logged out of the plasma workspace, and back in again. Still, the thumbs in the task switcher are missing.

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], Google [Bot], skylerjett, tosky, TristanDee, Yahoo [Bot]