Reply to topic

Unknown protocol 'file'

nfrandeboeuf
Registered Member
Posts
9
Karma
0
OS

Unknown protocol 'file'

Tue Mar 10, 2015 7:45 pm
Hi,

since I upgraded to Plasma5 I've got this error when trying to use DCC in Konversation (and Konversation crashes) :

Code: Select all
couldn't create slave: "Unable to create io-slave:
klauncher said: Unknown protocol 'file'.

I also have some issues when dealing with files/folder selection (when trying to change my wallpaper for example) so I guess this error is not due to Konversation but Plasma5 itself.

I know this might come from the upgrade but if anyone had a clue on how to resolve this issue, that would be a huge help :).
I am using kubuntu-ci/stable ppa on Kubuntu 14.10.

The full log :

Code: Select all
nicofrand@desktop:~$ konversation
kf5.kiconthemes: "Theme tree: (Brise)"
XSync seems available and ready
XSync Inited
Supported, init completed
Created alarm 98566145
Using blocking call!
codecForName: ucnv_open failed ISO-8859-16 U_FILE_ACCESS_ERROR
codecForName: ucnv_open failed ISO-8859-16 U_FILE_ACCESS_ERROR
service is "org.kde.StatusNotifierItem-18789-1"
Registering a client interface to the KStatusNotifierWatcher
"The certificate is self-signed, and untrusted"
"The certificate has expired"
kf5.kservice.sycoca: Trying to open ksycoca from "/home/nicofrand/.cache/ksycoca5"
Calling notify on "Sound"
WARNING: bool Phonon::FactoryPrivate::createBackend() phonon backend plugin could not be loaded
WARNING: bool Phonon::FactoryPrivate::createBackend() phonon backend plugin could not be loaded
WARNING: bool Phonon::FactoryPrivate::createBackend() phonon backend plugin could not be loaded
WARNING: bool Phonon::FactoryPrivate::createBackend() phonon backend plugin could not be loaded
WARNING: Phonon::createPath: Cannot connect  Phonon::MediaObject ( no objectName ) to  Phonon::AudioOutput ( no objectName ).
WARNING: bool Phonon::FactoryPrivate::createBackend() phonon backend plugin could not be loaded
WARNING: bool Phonon::FactoryPrivate::createBackend() phonon backend plugin could not be loaded
Calling notify on "Taskbar"
0 98566164
Closing notification 1
not found dbus id to close 1
WARNING: bool Phonon::FactoryPrivate::createBackend() phonon backend plugin could not be loaded
Calling notify on "Sound"
WARNING: bool Phonon::FactoryPrivate::createBackend() phonon backend plugin could not be loaded
WARNING: bool Phonon::FactoryPrivate::createBackend() phonon backend plugin could not be loaded
Calling notify on "Taskbar"
0 98566169
Closing notification 2
not found dbus id to close 2
WARNING: bool Phonon::FactoryPrivate::createBackend() phonon backend plugin could not be loaded
Calling notify on "Taskbar"
0 98566150
unknown status:  0
unknown status:  0
ip:  "62.210.86.149"
port:  10020
filename:  "File.zip"
filesize:  216466398
token:  ""
"85.69.115.63"
0  ->  1   "File.zip"  ( 1 )
connecting slots for  "File.zip"  [ 1 ]
[BEGIN]
1  ->  2   "File.zip"  ( 1 )
URL:   QUrl( "file:///home/nicofrand/Téléchargements/File.zip" ) 
Overwrite:  false
Resume:  false  (Position:  0 )
kf5.kjobwidgets: kuiserver found
couldn't create slave: "Unable to create io-slave:
klauncher said: Unknown protocol 'file'.
"
couldn't create slave: "Unable to create io-slave:
klauncher said: Unknown protocol 'file'.
"
Erreur de segmentation (core dumped)
User avatar einar
Administrator
Posts
3400
Karma
7
OS

Re: Unknown protocol 'file'

Wed Mar 11, 2015 9:40 pm
Looks like a missing dependency / packaging error to me.


"Violence is the last refuge of the incompetent."
Image
Plasma FAQ maintainer - Plasma programming with Python
nfrandeboeuf
Registered Member
Posts
9
Karma
0
OS

Re: Unknown protocol 'file'

Thu Mar 12, 2015 7:53 am
Nothing seems wrong when I do apt-get update/upgrade or anything like that. How can I check this, please ?
luebking
Karma
0

Re: Unknown protocol 'file'

Thu Mar 12, 2015 10:56 am
try running "kbuildsycoca5", watch out for errors - might be a messup between KDE4 + KDE5
nfrandeboeuf
Registered Member
Posts
9
Karma
0
OS

Re: Unknown protocol 'file'

Thu Mar 12, 2015 11:15 am
Here is the output :

Code: Select all
nicofrand@desktop:~$ kbuildsycoca5
kbuildsycoca5 running...
kf5.kservice.sycoca: Trying to open ksycoca from "/home/nicofrand/.cache/ksycoca5"
Reusing existing ksycoca
Recreating ksycoca file ("/home/nicofrand/.cache/ksycoca5", version 300)
Still in the time dict (i.e. deleted files) ("apps")
Menu "applications-kmenuedit.menu" not found.
Saving
Emitting notifyDatabaseChanged ("apps")
luebking
Karma
0

Re: Unknown protocol 'file'

Thu Mar 12, 2015 11:54 am
Not very interesting.
Stupid question: is your konversation KDE4 or KDE5?
nfrandeboeuf
Registered Member
Posts
9
Karma
0
OS

Re: Unknown protocol 'file'

Thu Mar 12, 2015 12:09 pm
Konversation
Version 1.6-master #5001
Using KDE Frameworks 5.8.0


But I am pretty sure this is not due to Konversation since I seem to have several other issues when dealing with files (I had the same error while using the "Folder" plasma widget but now the error message is not displayed anymore, just leaving a blank space instead of showing any folder/file).
luebking
Karma
0

Re: Unknown protocol 'file'

Thu Mar 12, 2015 3:16 pm
The latter guess was, that you might be using konversation from KDE4 but have only the KF5 kio libs installed. That's however not the case.

-> Did the error survive the sycoca rebuild? (you may have to restart konversation)
nfrandeboeuf
Registered Member
Posts
9
Karma
0
OS

Re: Unknown protocol 'file'

Thu Mar 12, 2015 5:40 pm
The error survived, yes. And I did not have to restart Konversation, it crashes automatically ;)
User avatar claydoh
Registered Member
Posts
465
Karma
5
OS

Re: Unknown protocol 'file'

Thu Mar 12, 2015 10:41 pm
kubuntu-ci/stable ppa on Kubuntu 14.10.


You are using automated daily plasma builds pulled from git, there may be will be some anomalies to be expected at times, I would think. Konversation is part of this, too.

Plasma 5 has been problematic on Utopic 14.10

It might be helpful to check which version of the kio package you have installed

Code: Select all
apt-cache policy kio

It should show 5.7.0+git20150310.0154+14.10-0ubuntu0 as the version installed.
If you were using the plasma-next/next-backports ppa, you might have a different version of the various kio and libkf5kio* packages, perhaps.


claydoh, proud to be a member of KDE forums since 2008-Oct, and KDE user since 2001
nfrandeboeuf
Registered Member
Posts
9
Karma
0
OS

Re: Unknown protocol 'file'

Fri Mar 13, 2015 9:01 am
Nevermind, I had an issue with linux itself after an update (yeah, I am a lucky man) and had to reinstall the whole thing, so I chose Kubuntu 15.04 (beta1).
I still did not have the time to test it but everything seems to work (this error has disappeared at least). I had to remove .kde, .config and .cache tough since I did not format my home partition (maybe one of these three would have been enough but eh…).

Anyway, I really want to thank you all for your help !

PS:
You are using automated daily plasma builds pulled from git

Yeah, I had to use this ppa due to another error

I guess I will not try new versions such early in the future, but I am always impatient :D.

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], boudewijn, Google [Bot], kakosf, Majestic-12 [Bot], Mamarok, millaan, Moski, raphaelra