Reply to topic

kde5 missing global notification mute

adent
Registered Member
Posts
1
Karma
0

kde5 missing global notification mute

Sat Jun 06, 2015 12:37 am
hi all,

i am looking in KDE5 for the kde4 option to mute the audio notifications globally (yes, i could do it individiually in kde5, but this is not appreciated)

Here (in kde4) was the old location:
systemsettings > application and system notifications > manage notifications > player settings : no audio output.

Any hint where i can find this in kde5 (5.10.0) ?

thanks in advance...
User avatar einar
Administrator
Posts
3400
Karma
7
OS
From your message, I infer you're using Plasma: 5.10 is the library version and not the version of the workspace (Plasma 5). In fact, please do not use "KDE5" as a term as it makes support harder.

That said, what version of Plasma are you using? You can check by typing "plasmashell --version" in a terminal. The issue you are experiencing may have just been an oversight of porting the application: you may want to post a bug on bugs.kde.org, but if you do so, please attach screenshots of how the configuration module was laid out in Plasma 4.x.


"Violence is the last refuge of the incompetent."
Image
Plasma FAQ maintainer - Plasma programming with Python
User avatar mck182
KDE Developer
Posts
138
Karma
0
OS
If you have kmix5, you should see "Event Sounds" output in there, that is the one that controls volume of the Notifications sound. If you mute it, the sound will be muted.

If you don't have kmix5 (yet), you can install pavucontrol (PulseAudio Volume Control), which has the same slider but named "System sounds". You can mute it there too.

There is no other checkbox anywhere anymore; it's a sound and as such should be with other sound controls (ie. in the mixer).

Hope that helps


KDE Telepathy | Plasma | Plasma Mobile
luebking
Karma
0
So PA is now considered a soft dependency for KDE?
User avatar mck182
KDE Developer
Posts
138
Karma
0
OS
Not exactly, notification sound playback now goes exclusively through Phonon. I'm not entirely sure what Phonon does with "NotificationCategory" sound playback when there's no PA.


KDE Telepathy | Plasma | Plasma Mobile
cmacq2
Registered Member
Posts
3
Karma
0
This would work, provided that applications actually *used* the "Event Sounds" stream. Unfortunately, they do not.
Screenshot of the reality, here: https://bugs.kde.org/attachment.cgi?id=94485
Bug report filed, here: https://bugs.kde.org/show_bug.cgi?id=352455
wolfi323
Registered Member
Posts
1125
Karma
11
OS
cmacq2 wrote:This would work, provided that applications actually *used* the "Event Sounds" stream. Unfortunately, they do not.

Use the gstreamer backend and they do.

As explained in the bug report you linked to, that's a bug/limitation in VLC that it doesn't use/allow to set the correct category.
Fifoxtasy
Registered Member
Posts
41
Karma
0
OS
Have the same problem. i'm on plasmashell version 5.6.5 linuxmint.

system sounds in mixer only appears for the time a notification is playing, since they are usually really short it only appears for a moment. i had to move quickly to the mixer window to press the mute button.

this seems counter intuitive, it's more like tricking your computer into doing what you want. and you have to have the knowledge about where the setting is going to appear and when.

besides isn't the OS still playing back the file and using CPU resources for that even though it is muted in mixer?



edit: had to mute plasma playback stream as well. so it is even more than one application that you have to silence. annoying
User avatar Rog131
Registered Member
Posts
828
Karma
10
Bug 157272 - disable system notification for all applications should be possible (as in kde 3.5.x) (disable sounds for all apps) : https://bugs.kde.org/show_bug.cgi?id=157272
Status RESOLVED FIXED


https://git.reviewboard.kde.org/r/127926/
This saves a lot of clicking compared to selecting each event
in the list and unchecking the "Play sound" checkbox, something
I have to do any time I set up a new computer (for me or around the office).

CCBUG: 157272


With the Plasma 5.8 there is an option: "Disable sounds for all of these events"

Image
Fifoxtasy
Registered Member
Posts
41
Karma
0
OS
great to hear !
Thanks !
CitizenJoe
Registered Member
Posts
6
Karma
0
I tried this hoping that it would end the nightmare of clicks, beeps, chimes, etc. and the screen pictured did nothing. I then used the drop down menu to try to find system sounds and clicked to disable or mute all sounds and when I boot I get the login screen and log in and the KDE symbol shows, I still get the annoying login tune and the desktop does not load. I can't get to a command prompt or anything. This is a serious usability issue!! Why does KDE seem to think that everything has to beep or click or chime or play a tune????? With every OS I have installed since win95 the FIRST THING I DO, even before installing any drivers or programs, is disable that hugely annoying clicking and beeping!! Plasma 5 has some nice aspects but incomprehensibly it also took away some MAJOR functional aspects!!! Fortunately I have several computers here that are not yet running Plasma 5!! :-)
bardak
Registered Member
Posts
1
Karma
0
brutal method is to delete *.ogg files in /usr/share/sounds/
User avatar scummos
Global Moderator
Posts
1138
Karma
7
OS
As noted above, the important thing is to install phonon-gstreamer, and set that as the preferred backend. After that you can just mute notifications in the mixer.


I'm working on the KDevelop IDE.
User avatar domson
Registered Member
Posts
20
Karma
0
OS
less brutal method is to hide relevant files in /usr/share/sounds

Code: Select all
cd /usr/share/sounds
for f in Oxygen-Sys* KDE-Sys*; do sudo mv "$f" ".$f"; done


The ships hung in the sky in much the same way that bricks don't. - Douglas Adams
baxksterjohnmoli
Registered Member
Posts
22
Karma
0
WHY THE HELL IS THIS SO HARD??????

After reading for hours all the 10 different ways you are supposed to deactivate events sounds, all of them are at zero, muted or both and STILL I hear the damn annoying notification sounds of KDE. What the hell is going on here? You guys realize that you made KDE WORSE in the last releases, this NEVER before was a problem, I have been using KDE for over 13 years now.
Do you guys know what a regression bug is? KDE is going down the tubes, this is not the only thing, quality in the DE has degraded seriously over the last years.
So now I will erase the sounds, brute force and honestly a super dumb and pathetic way to have to solve this. Not happy.

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Belliric, Bing [Bot], Google [Bot], leodd, Yahoo [Bot]